3DR Solo CLI - Command line

I wonder if someone can help me with this.  Recently, i purchased a 3DR Solo and decide to create some programming projects with its SDK.  Just starting off, i ran into issues already.  I have been trying to install the 3DR Solo CLI - command line, it seems the installation was fine. But i am having problem of when i type "solo info" or "solo wifi" to connect to the Solo, it just stuck at connecting.

solo info
solo wifi --name=<n> [--password=<p>]
solo flash (drone|controller|both) (latest|current|factory|<version>) [--clean]
solo flash --list
solo flash pixhawk <filename>
solo provision
solo resize
solo logs (download)
solo install-pip
solo install-smart
solo install-runit
solo video (acquire|restore)
solo script [<arg>...]

C:\Windows\system32>solo info
connecting to Solo and the Controller... <-------- this the part it stuck at for very long time!!!!!!

Traceback (most recent call last):
File "C:\Python27\Scripts\solo-script.py", line 9, in
load_entry_point('solo-cli==1.1.1', 'console_scripts', 'solo')()
File "C:\Python27\lib\site-packages\pkg_resources__init__.py", line 547, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "C:\Python27\lib\site-packages\pkg_resources__init__.py", line 2719, in load_entry_point
return ep.load()
File "C:\Python27\lib\site-packages\pkg_resources__init__.py", line 2379, in load
return self.resolve()
File "C:\Python27\lib\site-packages\pkg_resources__init__.py", line 2385, in resolve
module = import(self.module_name, fromlist=['name'], level=0)
File "C:\Python27\lib\site-packages\soloutils__main__.py", line 39, in
File "C:\Python27\lib\site-packages\soloutils\info.py", line 12, in main
controller = soloutils.connect_controller(await=True)
File "C:\Python27\lib\site-packages\soloutils__init__.py", line 56, in connect_controller
return connect('', await=await, silent=silent)
File "C:\Python27\lib\site-packages\soloutils__init_.py", line 33, in _connect
client.connect(ip, username='root', password='TjSDBkAu', timeout=5)
File "C:\Python27\lib\site-packages\paramiko\client.py", line 325, in connect
File "C:\Python27\lib\site-packages\paramiko\transport.py", line 488, in start_client
File "C:\Python27\lib\threading.py", line 621, in wait
File "C:\Python27\lib\threading.py", line 359, in wait
KeyboardInterrupt  <------ had to press ctrl+c to cancel


does it have something to do with line 621 and 359 of threading.py?  

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • Hi Daryl, I'm having the same issue as Katie.  I've tested "solo info" and "solo provision" and I can't get past the "connecting..." message. I am able to connect to the controller with both the PC and the Solo App. I've tested my PC's connection by running "ping" and I am receiving packets as expected. After looking through the solo-cli (and its dependencies') source code, I've pinpointed an infinite loop in the wait_for_response(self, event) which is caused by the line "event.wait(0.1)". This makes me wonder if the issue is that there is some other connection or process that is preventing me from sending commands via solo-cli. Any thoughts?

    • hello Savannah,

      Do you resolve your connection issue. If so, can you tell me how you resolve the problem.

      I have no problem connecting to solo with solo app,or mission planner or Tower app or MAVProxy and no problem getting log files out, just have problem using CLI or dronekit. Both struck on connecting.


  • Was there any update on this issue? I am having the same problem now, and can't seem to find a work-around. 

    Thank you!

  • I had similar problem trying to retrieve the logs with "solo download" command. Don't know the cause.

    I guess you will get by the connection issue when you do a ssh-keygen to generate the ssh keypair and do a solo provision.

    The solo provision however also failed on the connection problem.

    Worlaround: Try to manually add the keys to the .ssh/authorized_keys file (see the provision python code for this).

    I have not tried it. I retrieved the logfiles simply via scp instead of the solo download command.

  • Hi Peter - did you ever sort this out? I'm having the same issue. Thanks!

This reply was deleted.