3DR Solo CLI - Command line

I wonder if someone can help me with this.  Recently, i purchased a 3DR Solo and decide to create some programming projects with its SDK.  Just starting off, i ran into issues already.  I have been trying to install the 3DR Solo CLI - command line, it seems the installation was fine. But i am having problem of when i type "solo info" or "solo wifi" to connect to the Solo, it just stuck at connecting.

solo info
solo wifi --name=<n> [--password=<p>]
solo flash (drone|controller|both) (latest|current|factory|<version>) [--clean]
solo flash --list
solo flash pixhawk <filename>
solo provision
solo resize
solo logs (download)
solo install-pip
solo install-smart
solo install-runit
solo video (acquire|restore)
solo script [<arg>...]

C:\Windows\system32>solo info
connecting to Solo and the Controller... <-------- this the part it stuck at for very long time!!!!!!

Traceback (most recent call last):
File "C:\Python27\Scripts\solo-script.py", line 9, in
load_entry_point('solo-cli==1.1.1', 'console_scripts', 'solo')()
File "C:\Python27\lib\site-packages\pkg_resources__init__.py", line 547, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "C:\Python27\lib\site-packages\pkg_resources__init__.py", line 2719, in load_entry_point
return ep.load()
File "C:\Python27\lib\site-packages\pkg_resources__init__.py", line 2379, in load
return self.resolve()
File "C:\Python27\lib\site-packages\pkg_resources__init__.py", line 2385, in resolve
module = import(self.module_name, fromlist=['name'], level=0)
File "C:\Python27\lib\site-packages\soloutils__main__.py", line 39, in
File "C:\Python27\lib\site-packages\soloutils\info.py", line 12, in main
controller = soloutils.connect_controller(await=True)
File "C:\Python27\lib\site-packages\soloutils__init__.py", line 56, in connect_controller
return connect('', await=await, silent=silent)
File "C:\Python27\lib\site-packages\soloutils__init_.py", line 33, in _connect
client.connect(ip, username='root', password='TjSDBkAu', timeout=5)
File "C:\Python27\lib\site-packages\paramiko\client.py", line 325, in connect
File "C:\Python27\lib\site-packages\paramiko\transport.py", line 488, in start_client
File "C:\Python27\lib\threading.py", line 621, in wait
File "C:\Python27\lib\threading.py", line 359, in wait
KeyboardInterrupt  <------ had to press ctrl+c to cancel


does it have something to do with line 621 and 359 of threading.py?  

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • Solo install-runit is very buggy.  If solo install-runit does not work for the first time, reboot and try again.  If it still doesnt work, do solo install-smart once more, then solo install-runit.  Like i said, its buggy so you'll just have to play around with it.

    • hello Peter,

      After rearrange the company wifi, finally go the password changed to simple text and get solo connected to internet.

      solo install-smart was completed without issue

      however solo install-runit ran into 

      busybox-1.21.1-r1@cortexa9hf_vfp_neon is not available for down loading

      How do I resolve the issue.


  • I'm having a very similar issue! Did you ever resolve this problem?

    • i delete the old Solo CLI that didnt work, install the new updated version and also install the virtualenv and it worked!!!!

      p.s. I also had to SSH into Solo for the CLI to work.  If you dont, it will not work.

    • can you give us a walk thru for ssh

      I did



      ssh-copy-id doesn't work on my window PC. 

    • here is what I did with ssh. I got ssh-copy-id command not found error. I'm using Git version 1.9.5


  • Hi Peter. Are you still stuck on this?

  • Robert Hermans is right, If you use a ssh key, everything works.

    Into a GIT console:
    ----> ssh-keygen

    Then copy the key to the drone (connect to the solo wifi network):
    ----> ssh-copy-id -i .ssh/id_rsa.pub root@       
    Enter password:  TjSDBkAu  
    To verify the connection without password: 
    ----> ssh root@

    I can use solo info after without blocking at "connecting..."

    Hope it helps.

    • 3702622970?profile=original
      I followed this procedure, and believe that the keys are in the appropriate place on the solo ^^^

      I'm still stuck on the "connecting to the controller" command. Is there any additional troubleshooting that needs to be done?

    • Hi Katie. Which CLI command are you trying to run? Are you able to connect to the controller from the app?


This reply was deleted.