Hello folks,

so after a nightmarish event of dealing with 3dr, I finally received my gimbal and attempted to install it.

The installation was acceptable, I won't say it went smoothly because, that simply wouldn't be true (the wires definitely could of used more room, or at the very least better placed.

All systems have been updated, including the go pro. I

So upon placing my GoPro Hero3+ Silver (3.02) into the gimbal and powering everything on according to the instructions included by 3dr, I'm asked to update my GoPro firmware, which makes no sense considering I have the latest firmware version (GoPro also confirmed this), and upon dismissing this request, I'm met with a please plug in the hdmi cable screen, thus no video link. Further more upon shutting down the system my GoPro remains powered up, and completely frozen, requiring the lipo to be pulled from the go pro in order to reset it. I have also tried all capture settings (1080p,960,720) (60fps,30fps) (narrow, medium, wide) still causes go pro to crash.

Isn't the gimbal compatible with the Hero3+ silver? It does say in the manual that it in fact does support it fully, however at this point I have a hard time in believing much of what 3dr says.

Now after doing some research I came across a link on 3drpilots.com referring to other users experiencing this same issue, with the response from 3dr claiming it to be a bug that they are working on, and for the time being convert back to the GoPro 2.00 firmware. I myself asked 3dr such, and was simply referred to the online pdf of their included manual, which seems shady to say the least why some users are given a solution and others are simply pushed aside and routed back to the manual. 

So upon downgrading firmware (GoPro highly recommended against this I should note), I does still request the firmware on the GoPro to be updated within the Solo App, however upon unplugging and plugging back in the hdmi cable I now get video signal.

However the issue I'm now faced with is the inability to record onto my GoPro as I cannot access the record button due to the gimbal covering, and I can not control the go pro record/stop video the controller or app, and simply only being able to record directly on to my iOS device, which a subpar at best.

So does is anybody else having similar issues? If so have you discovered a solution?

Thanks in advance.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • This may help you with your issues...or not. I guess we'll see.  (I posted this elsewhere)


    Okay…maybe I’m the dumbest RC pilot alive. Perhaps so dumb I don’t even know how to tie my own shoes. Maybe I can’t even breathe voluntarily.
    But on the off chance I’m  not alone, I think you should share how to control the on/off record function of  a GoPro camera  on a 3DR Solo.
    Here's my breakdown:
    • First, this only works with the gimbal installed.
    • Second, make SURE you have the latest firmware installed on your GoPro.
    • Third, go into the phone’s setting and make sure the “save to camera roll” switch is turned OFF.
    Done, done & done? Good.
    Now, if you are looking for a button on your controller clearly marked “RECORD” you  will not find it.
    If you look for it in the manual. Not there either.
    How about the training videos? Nada.
    Or maybe the FAQs? (shaking head).
    Perhaps you are supposed to use your powers of Telekinesis. Well, maybe…but I, myself, am not gifted as such.
    To save everyone the trouble of having to call tech support (which I did to find out - they were great, btw):
    you turn on and off the record by….
    clicking the left paddle on the controller.
    That’s correct.
    You press IN  the control that control’s the Gimbal’s  up/down motion.
    It’s on the forward face of the controller.
    You’ll feel a slight click when you do.
    Click ON. Click OFF. 
    That’s it.
    TOTALLY obvious, right?
    Ya, I thought so too.
    Some videos or screen shots show a range of controls on screen that allow you to control the GoPros settings right from your phone.
    Pretty cool, huh? Too bad of of this date they do not exist.
    Anyway, you’re welcome.

    • @Fish , thanks for your response,

      what model of GoPro  model are you using? They all have different levels of compatibility, this is why I ask.

      As with the Hero3+ Silver, it automatically freezes upon powering the system up, requiring the battery in the go pro to be removed to get it to power down, with the latest firmware installed.

      As for the paddle control, while I am very familiar for which is the record/stop button, with the new firmware update this simply does not work (not supported) with the Hero3+ Silver (perhaps the Hero3+ Black is?) as stated by philip from 3DR on the main Solo discussion page. There's actually a discussion about this very topic on 3drpilots.com also, although I haven't been keeping track of their progress, 

      If your are in fact using a Hero3+ silver, then that is definitely great that you got it to work!.


    • The Hero 3+ black and 4 black is what I own and both work with full firmware upgrades.


    • BTW: I'm SCREAMING at 3DR about this. It is a glaring omission in their literature. And the tech support guy, as friendly as he was, seemed stunned I didn't know this.

  • @Art, that is very unfortunate, hopefully you get it resolved sooner rather than later as I think we've waited long enough for the gimbal at this point!

    @Ray, thats good you finally got your gimbal! And I definitely hope you are correct with regards to the update!

    Getting my gimbal was probably one of the worst purchasing experiences I have ever had in my lifetime!!!

    I'm afraid to invest anymore into this system (GoPro H4 for instance) at this point than absolutely necessary.

    I contacted 3DR directly requesting a RMA# to return my Solo and extra batteries, as I felt completely unsatisfied (my whole season was waisted with funds invested into a product that's unusable without a gimbal, and since its already -2*C where I'm located, snows on its way so at this point it wouldn't be used till next season), and I was within their policy grounds for a return.

    Then I was informed about how they were sorry, they would send me a gimbal overnighted asap (I stated I wasn't paying more than I would here in Canada, and that I really wanted to return it more than anything). So Wednesday passed with no response, then Thursday I'm told I wouldn't have it for Friday (my final research trip of the season), so once again I was back to emphasizing on returning it. Then at the last second I get an email stating they found one and it was going out overnighted, they'd call for payment info (at which point I re-itterated once more that I'm not paying more than I would here in Canada, otherwise I just want to be done with this nonsense and return it, which the individual says no problem, it will be no more in costs)..Waited for a bit then finally got a call...The guy on the phone had very little idea as to what was occurring and tried to bill me far more, even keeping me on hold for half an hour!!! Then says they'll have to contact the individual I talked to and get back to me...So I waited an hour before giving up, and headed out late for a meeting.

    Next day I get an email from the individual saying they sent it anyways that they'll call me for payment and I have to pay what the guy on the phone said....So basically after I told them NO time and time again, they sent it to me anyways, then had the nerve to tell me what I'm paying them. So after responding saying its not happening, I'm not paying more than what I said, that they were told countess times through email and on the phone I want a refund and not to send it if they expect me to pay more.

    So then they tried to harass (and somewhat bully) me by calling me, emailing me, saying I have to pay what they want or I have to go out of my way to send it back now (at which point I was late several hours departing waiting for it to arrive, and they were informed I was leaving for a research trip, then surgery, so I would be out of town and range). So their foolishness became my problem further...Waisting even more of my time...They eventually agreed and accepted my original payment offer (although, I'm sure it was only after mentioning that if need be I would take this further, filing complaints).

    So I think its safe to say that I'm going to avoid submitting a ticket unless I'm in dire need to do so...Hopefully the update is sooner than later...Just don't need that kind of negativity in my life...

    • I was THIS close to pulling the trigger on a Phantom 3 but somehow found out about the Solo and that it used GoPro cameras and it was compatible with the 3+ Silver up.

      As luck would have it I had a 3+ given to me last Christmas that I didn't want and didn't have any need for.  So it was still in its packaging.  I figured I could spend a few bucks more on the Solo and Gimbal and have a better drone for not that much more.

      Since I received the gimbal I've got about 6 minutes of video.  My GoPro is on 3.0.1 and basically locks up every time I connect it to the gimbal.  If I've started video then it stops and locks up.  I don't even know how I got that six minutes  of video.

      I can't get the app to upgrade so I'm going to spend some time tonight trying other methods.

      At this point I'd settle for at least being able to take video, and suffer without FPV.

      On a side note I've now gotten more practice just flying the thing.

    • @Corbin,

      Well if I personally had the choice to do it over again I would have never even considered buying the Solo!

      3DR is nothing but a company built on false advertising, and being untruthful.

      And as a owner of both the Solo with a gimbal (Hero3+ Silver also) and a Phantom 3 Pro, they really aren't in the same league, with the P3P being far superior on all fronts (except the required cable from tablet/phone to remote), they even offer the so called Smart Shots 3DR claimed no one else would have. The Phantom 3 is truly a unit built for capturing video/images, although I'm not a fan of dji or its "cookie cutter" design approach (I think they could do better with regards to design)...

      As for the issue at hand "No Video/GoPro Freeze/No Record", well theres several things I have learned

      1. the Hero3+ Silver, while was and sitl is advertised as working with the Solo/Gimbal, it actually does not!!! This was simply a false claim by 3DR (I can post links and docs showing it clearly states fully compatible with Hero3+). Philip from 3DR even stated that they had no intention on fixing this issue on the Solo's main page.

      So after waiting almost half a year with over 2k invested, many are left with an unusable unit with either the option of attempting a return (3DR will tried to avoid this at all costs even though its in the documentation so good luck with route), or being forced to go out and invest further into a newer GoPro, at which point you would have spent as much is not more than what an Inspire is worth.

      2. There is a slight work around, although it doesn't offer perfect results and is kind of a pain to run through each time (it also may put added wear on your gimbal)

      If you downgrade your GoPro firmware to 2.00, which after contact GoPro, they highly recommend against as they said it could easily damage your GoPro by downgrading (I have an email from them stating this if you wish to see it also), you will regain a form of video feed! 

      This issue with this is that, every time you boot up the system it'll ask you to upgrade the go pro firmware (dismiss this), then it will probably say no hdmi plugged in, so unplugging and plugging back it video will come back after a second. 

      However this does not give you access to any form of record unless its on the tablet/phone, which will most certainly be effect by reception, so quality will be poor at best from any real distance.

      The go pro finally will not shut off once the system of shut down so you will be manually powering down the cam each time! Which could be hard on your gimbal!

      A few tricks I've picked up to somewhat work around some of these issues:

      1.Set your go pro to 1 button record option! This will allow the go pro to initiate record and stop simply by powering on and off the system! This one is key since the gimbal blocks access to the shutter button!

      2. In order to avoid plugging/plugging the hdmi cable each time, manually power on the go pro before the solo ect...After getting it going I changed batteries but did not shut the go pro off and upon repowering the system I immediately had video feed. This will initiate the record with 1 button but also same from having to apply pressure on the gimbal itself in the form of the unplug/plug option, but still unnecessary pressure non the less.

      Finally the downgrade will also correct the freeze effect the go pro endures as a result of such a lack of compatibility, however as I stated you will need to manually shut it down afterwards, but as Philip has stated they have no intentions on getting it to be compatible so that means absolutely no record/stop control or go pro itself control from the app or remote.

      It's unfortunate this is what is has come down to just to be able to get an expensive product to at least work somewhat, after being told and sold on the fact that it would work!

      We should not be forced to put our gopro's in harms way just to simply get Solo to work when it was sold as being fully functional!

      It's sad and unfortunate that they have to resort to these tactics (making false claims, being untruthful), just to try and compete, but at this point its not a surprise coming from them...Perhaps formal complaints with business bureaus are in order....

      Best of Luck...

    • Does anyone know where I can get the 2.0 firmware? 

    • Hi Kevin,

      it's been a while now since I ran that particular update, as I've changed to the Hero 4 now, but you could give this a try http://drivers.softpedia.com/get/SCANNER-Digital-CAMERA-WEBCAM/GoPr..., it should be what your looking for I believe.

  • I have this same issue with the 4BLK. It seems to work if I power on the gopro before completing the gimbal connections. Otherwise I receive firmware needs updated message. The last time I tried flying with gimbal, I received the firmware message then the live feed popped up but the recording button was faded out and didn't function as intended. I just wanted to show a friend a quick demo so I wasn't too worried about recording but the gimbal kept whipping from side to side once I had it in the air, even when hovering in place.

    I quickly landed it and afraid to even turn it back on after that.
This reply was deleted.