Solo with Tower (speed issue)

I don't know if I have an hardware/software issue or just don't understand how Tower works.

Was trying to do a slow mission with tower with a dozen waypoints, a circle and one ROI.

I changed my waypoint #2 to 3 f/s which I thought should set the speed for the rest of mission unless I added another speed waypoint which I did not do.

The mission flew fine, did the circles, ROI, etc but it booked at 30+ f/s.

If I have waypoint 2 set at 3 f/s shouldn't everything after that fly at that speed?

3DR Solo, with latest firmware and latest version of Tower off the play store.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • You could set your waypoint nav speed parameter (WPNAV_SPEED)  to something slower and run the whole mission at that speed.  Then you don't have to worry about setting a speed changes during the mission.

  • Ran another mission and set another speed point after the next waypoint and it worked.

    So with mine if I set my speed point too early it totally ignores it. It did not even kick in a few waypoints later.

    Thanks for the link.

    • Developer

      I've actually just found a bug in our mission library that may be related.  If a "Do" command (like do-change-speed, do-set-roi, etc) is the very first command in a mission, it may be run again and again after the vehicle passes a waypoint.

      Most missions start with a take-off command (which is not a do command) so this may be why the bug has persisted for so long.

      I expect we will fix this for AC3.3.

    • Developer


      Ok.. well.. weird.  It should be processed wherever it is in the mission.

  • Randy I am new to tower. So all I am doing is adding an extra waypoint "#2" and after the rest of my waypoints are complete, going back and clicking on the waypoint and in top right menu I am changing it to speed and setting it to 3 f/s. But it basically flies full speed from start to finish which was about 30 f/s.
  • Developer

    So you're using the do-set-speed mission command I guess?

    It should work although it's possible the speed change won't take effect until the next waypoint if this fix isn't in Solo's version of ardupilot (Solo uses a modified version of AC3.3 and maybe it's missing this fix).  Solo should converge with master in a few months (hopefully) so if this is the issue it should be fixed.

This reply was deleted.