SoloLink wifi "not in range" on Android devices

I can successfully connect my brand-new Asus MemoPad and brand new Solo to SoloLink and run the Solo App or Tower, but once I'm disconnected and try to reconnect to the SoloLink wifi network, the network shows as "not in range" but it is only 10 feet from me, and my iPhone both sees the network and can connect to it w/o issue.

The only way I've been able to "fix" the connection is to "Forget it" and either manually add the SSID and pw or, if I'm lucky, it shows up again in a scan and I can provide the password and it works. But again, once disconnected from it, the SSID will again show "not in range" and it starts again.

Has anybody else seen this and/or have any fixes? I'm an IT Manager by trade and know all the basic troubleshooting stuff. This seems to be an issue on this Android device, as my iOS devices have no trouble seeing or connecting to SoloLink, ever, and my other home WiFi networks are seen and I can connect to them with the Android device with no issues at all.




You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I have the Asus MemoPad8, I have not had these problems, that said i just got it all back from RMA and have not flown on the latest software... make sure your MemoPad is up to date as well, I believe it will have atleast 3 or more system updates itself and usually they come several days apart. Im unsure if they can be forced.

    Have you went into wifi- hit menu, choose advanced, then uncheck smart network switch or something like that.

    • Hi Chris,

      There is no such setting in my Adv wifi settings. that's the issue in a nutshell. Glad yours is working well. I did do the updates, and actually got it to 5.0 via manual update but it was still the same. :) 

  • How default are your settings on the MeMO Pad ?  As an IT guy maybe you have done some security tweaks?

    Anyway, I'd definitely call 3DR support on this one.  They should know there is a potential issue with the MeMO Pad.  They *might* have a fix in the form of some simple thing you have overlooked.

    • Erik, I will call them to report this so that they can add this as a note to their HW list. Thanks for that suggestion!

      Otherwise, my solution was to return the MeMo Pad and get a Samsung Tab 4, which (so far) has allowed me to have total manual control of my networks, right out of the box. :)

    • It was brand new, factory reset.

      I might have to try a custom ROM on it to be able to better control the wifi settings.

  • Brit, I experience this exact issue on my android tablet. The strange thing is that my Galaxy S2 will work every time. The only time I've experienced this issue is when I attempt to fly from my front yard. When I go to the park, everything works just fine.
    • I think I'm closing in on the issue. Shortly after connecting, I get a message that the wifi connection "has a poor internet connection" (duh, yes, not trying to get to the Internet via SoloLink) and I say OK (the only option) That then puts the SoloLink into some Android wifi shit list and won't allow me to connect to it again (out of range).

      On some versions of Android, it seems that there is an option to disable that "feature" under WiFi Advanced Settings. But there is no such option for the Asus Memo Pad K01A (C70CX), either in 4.4.2 or 5.0. Does your Galaxy S2 have this option?

    • My bad, I meant it's an S5. There is an option to forget network which makes it to where it will no longer attempt to auto connect. The other option is to modify network. Does your tablet give you the same options?
    • So I just took back the MeMo pad and got a Tab 4. I can switch wifi networks manually w/o it doing any kind of checking. Basically working as expected. Problem solved!

  • You're an IT Manager and you bought an ASUS device???

    Sorry couldn't pass that up.  I have no help for you at all.

This reply was deleted.