Waiting for GPS - Solo won't fly

Solo waiting on GPS for hours. Never able to lock on so no flying. Solo requires GPS signal to fly even when in the Android app under advanced you set "Enable Advanced Flight Modes" which supposedly allows "fly without GPS." 

I have done a factory reset - held down power and fly, re-paired controller and Solo, re-updated software but no luck. 

As you can see from the pic below a GPS signal fix was available on tablet:


In the picture below you can see the yellow icon at bottom left of screen which indicates "Waiting for GPS..." 


Has anyone else been able to solve this issue?

Disappointed 3DR would make me wait till Saturday when they are closed to download Android app in order to update to be able to fly. Received Solo on June 3 had to wait till June 6 to update and now have to wait till June 8 to speak with tech support. Odd they couldn't ship with updated working firmware.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • Hi Brandon,

      I tried that but Solo gives two quick beeps - almost like it is saying no no. 


    • Hi Jeevan,

      Thanks so much for replying. Yes, I submitted logs but since you have to
      log off the WiFi connection to the Solo and then log into home WiFi I am
      not sure they get sent - I tried 3 times.

      After resetting the controller and then re-pairing with the Solo and
      re-updating we got the same error. This afternoon we left it outside till
      the battery ran down but it never attained a GPS connection. As you can see from my
      pics I posted the tablet I am using easily acquired a GPS fix.

      Let me know if you need me to try to upload the logs again. 


  • 3D Robotics

    Try power cycling the controller and Solo again. It may take up to 3.5 minutes to get GPS the first time. 

    • Hi Chris - Tried that plus as I mentioned even did a factory reset and started from scratch again. Have tried 3 different Android devices in case that might be an issue. Now have it sitting in the yard battery down to 60% and I am still waiting for GPS.

      3702571492?profile=originalHopefully someone can solve this!

    • Do you have a camera attached, I'd suggest trying without it just to see if there is change. I realize everyone will want a camera attached, but it's easiest to troubleshoot ruling out rf interference, wifi on, etc. My Gopro 2 would completely lockout gps with my old APM 2.5 & GPS.
    • Hi Todd,

      Yep, we thought of that so removed camera. Still no luck.

    • And power cycled I hope. Unfortunately I don't have one yet either so I don't know the quirks of it. If I think of anything else I'll throw it out. Is there a gps indicator on the solo, could the GPS been disconnected from the controller during shipping? I'm sure 3DR had great results with the firmware that was shipped.
    • Hi Todd,

      Yes, power cycled. Probably this is a defective unit as there is no sat reception at all.

    • 3D Robotics

      If you swipe down the top bar on the app from the right side, it will show you detailed info, including the number of GPS sats it's seeing. Can you do that and tell me what it says?

    • Hi Chris -

      It says GPS: 0 SATS | 0.0 HDOP


This reply was deleted.