Cannot connect Desktop and mobile apps

First off, I'm so sorry for sending this out earlier today as individual messages to everyone.

I'm not familiar with a forum that's also kinda formatted like Facebook. :)'s the issue I need help with, in case you didn't see it elsewhere:

I'm trialing UgCS to see if it might be a good solution to collect imagery for creating topographic surveys. I currently have a DJI Phantom 3 Advanced, controlled with an nVidia Shield K1 tablet. I'm able to get the mobile app installed, and it will connect to the Phantom. I have the Desktop app installed on my Win7 x64 PC, and I've created a test mission, but I cannot for the life of me get the desktop app to connect to recognize the mobile app so I can upload the mission to the drone. I've read the PDF, and it just says they should recognize each other automatically. Both machines are on the same network. The tablet is wifi, the PC is wired, both run through the same router. I've even tried switching the PC to wireless via a USB adapter, but it still doesn't connect. What else should I do? Until I get this sorted, I can't even try out the software.

Thanks for any advice,


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Before support comes to work on Monday, please try following.

    On tablet go to Menu, scroll down to very bottom. There you will see IP and UgCS Connection port. Write down those values IP and port.

    Go to UgCS on PC, open Menu->Configuration->VSM. Find DJI VSM.

    Click on it. Click Edit button. Enter IP from Tablet in host field and port in port field.

    Restart both devices and give it a try.

    Provided that does not solve the issue something less common and exceptional is going on. Please report the issue to support as unfortunately we will need our tech guys from support at office to help you.

    Good luck!

  • My IP for the desktop is, the subnet is

    The IP on the tablet is, it doesn't show me the subnet, but I have no reason to believe it's not the same.

    It's somewhat baffling that there's no instruction or troubleshooting direction given beyond "it should work automatically".

    I guess I'll have to try emailing support...

  • Hi, Please check your IP and subnet for each device to ensure they are really on same network. If that is not helping please write to

This reply was deleted.