UGCS 2.11 Problems / Can I do tablet rollback?

We bought a new tablet and are now forced to update to UGCS 2.11. After using it for 2 jobs it has some terrible bugs that need worked out. We are getting a very bad latency issue and the drone is not even remotely close on the screen to were it is in real life and then will skip forward a bunch and is super glitchy. We can roll back the computer software to 2.10 which works perfect but does anyone know how we can do the same with the tablet? The app store only shows 2.11. From what we can tell 2.10 doesnt work with 2.11 so they both have to be on the same update. Any help here would be great. Thanks!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Thank you!

    I emailed UGCS support as well and they already responded also. I installed the old version on the tablet and it worked fine so I uninstalled and reinstalled 2.5 the new one to work with 2.11 on the computer and it worked fine also. I was happy but confussed maybe I had a bad install. It was strange because I did 2 separate flights in 2 different locations with the same results of it being glitchy. Now everything seems to be working just fine. Thanks for the download link as well as the fast response. 

  • Hi Kurt, please send message to and they will provide link to previous version of UgCS for DJI app.

    Please note that there isn't version downgrade procedure, so you can't install UgCS 2.10 on top of 2.11.

    But if UgCS 2.10 was upgraded you should have your old database here - C:\Users\[USER NAME]\AppData\Local\UGCS\backup\server_db. You can save it before UgCS 2.11 uninstall, install UgCS 2.10 and copy your old database on top of freshly installed database.

    Could you post more details about your problems? I didn't hear about such problem with UgCS 2.11, this version was used by tens of beta testers last 3 months.

    May be Live video streaming is switched on in UgCS for DJI app? In such case you can experience latency.

This reply was deleted.