Installing APM Planner 2.0 on Ubuntu 14.04LTS

DaVinci Challenge

As instructional materials designer for the DaVinci Challenge, I need to provide clear and concise guidance on all aspects of building and operating drones including preparing ground control systems. With Microsoft as a sponsor of the DaVinci Challenge, I usually start by encouraging installing Mission Planner or APM Planner 2.0 on Windows, despite the difficult of installing unsigned drivers on Windows 8. For those participants with a MAC, guidance is to install APM Planner 2.0. Inevitably, a few students will arrive with a Ubuntu 14.04 as the only operating system. I can't help but smile, because I prefer Linux over Windows, but it does mean extra effort to guide the students through a more complex install process.

So to smooth out the process, one of our Interns created a shell script that checks the version of Ubuntu, installs that latest version of APM Planner 2.0, and creates a desktop icon -- all with a single command.

We are making this available to the public via our Guthub  

DaVinci Challenge

Please let me know if you have any difficulty.

Views: 7119

Comment by Sebastian S. on November 28, 2014 at 6:35am

Hello Ronald,

Nice. But now please do the same for Mission Planner. APM Planner right now isn't reliable enough...

Sebastian

Comment by HawkEye UAS on July 28, 2017 at 10:58am

Hi,

I was running the script provided and it execuited flawlessly until this point:

(Reading database ... 268888 files and directories currently installed.)
Preparing to unpack apmplanner.deb ...
Unpacking apmplanner2 (2.0.15-7-gd94637c) ...
dpkg: dependency problems prevent configuration of apmplanner2:
apmplanner2 depends on libasound2 (>= 1.0.16).
apmplanner2 depends on libc6 (>= 2.4).
apmplanner2 depends on libflite1.
apmplanner2 depends on libgcc1 (>= 1:4.1.1).
apmplanner2 depends on libgl1-mesa-glx | libgl1.
apmplanner2 depends on libqt5core5a (>= 5.2.0).
apmplanner2 depends on libqt5gui5 (>= 5.0.2) | libqt5gui5-gles (>= 5.0.2).
apmplanner2 depends on libqt5network5 (>= 5.0.2).
apmplanner2 depends on libqt5opengl5 (>= 5.0.2) | libqt5opengl5-gles (>= 5.0.2).
apmplanner2 depends on libqt5printsupport5 (>= 5.0.2).
apmplanner2 depends on libqt5qml5 (>= 5.0.2).
apmplanner2 depends on libqt5quick5 (>= 5.0.2) | libqt5quick5-gles (>= 5.0.2).
apmplanner2 depends on libqt5script5 (>= 5.0.2).
apmplanner2 depends on libqt5serialport5 (>= 5.1.0).
apmplanner2 depends on libqt5sql5 (>= 5.0.2).
apmplanner2 depends on libqt5svg5 (>= 5.0.2).
apmplanner2 depends on libqt5test5 (>= 5.0.2).
apmplanner2 depends on libqt5webkit5.
apmplanner2 depends
dpkg: error processing package apmplanner2 (--install):
dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.22-1ubuntu1.1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Errors were encountered while processing:
apmplanner2
The user `abe' is already a member of `dialout'.

abe@abe-Satellite-E55t-A:~$

What should my next step be?

Please advise,

Abe

Comment by Ronald Pandolfi on July 28, 2017 at 7:17pm

This is a rather old script. Since then the installation of APM Planner 2.0 in most Linux flavors has been simplified. Try installing using thttp://ardupilot.org/planner2/docs/installation-for-linux.html#installation-for-linux

Comment

You need to be a member of DIY Drones to add comments!

Join DIY Drones

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service