3DR GPS uBlox LEA-6

Yesterday i got my LEA-6 GPS module and made a short comparison.

I Placed my Copter outside on the street and wait 2-3 mins to get a good GPS Signal and then I running a track on the street with my copter over my head. First with Mediatek and after with the new LEA-6.

Surprise! the LEA-6 are mutch better! I Got the GPS Fix under 30sec, got GPS in my House... and the now the Loiter works mutch better!

Arducopter GPS.png

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I'm at a loss here. I have tried ever way to search for this and can not find any info.

    I have a APM2 with built in mtech gps. I want to replace it with a ublox, is there any information on the forums explaining if this can be done and how ?

    Thanks much,

    Ken

  • Dear Silvio

    Is there any driver to be installed for UBLOX LEA-6? I have pluged my LEA-6 to my APM 2.5, but it shows no signal.

    there is a very tiny red LED on the back. Should I change the back up battery or add some driver?

    Thanks for help

  • Developer

    AC is night and day better with the new UBlox chipset. The MTEK has a firmware fix, but it's still not as nice.

    Jason

This reply was deleted.

Activity

Derrick Davies liked lisa TDrones's profile
3 hours ago
xemone liked Max Gilson's profile
Aug 31
nick rymer left a comment on ArduCopter User Group
"I recently switched laptops and now have Windows 10. I installed Mission Planner on my laptop and plugged a mRo SiK Telemetry Radio into the USB port. The radio is not recognized on the com ports but is instead on the "Other Devices" tab in Device…"
Aug 20
More…