A week of Arducopter misery

After a week spent working on my Arducopter 2, I have still failed to get it airborne and I've broken two props already. In the interests of other people avoiding the misery I've  had to go through, I'll post my lessons/experience here in a summarised form. The brevity of what I've written doesn't reflect the amount of effort put in, or combinations of solutions attempted. I'll conclude with that I think the problem is and I invite suggestions from more experienced users.

My first mistake was to not check that the GPS cable was plugged into the correct port. I believe my AC was shipped with it plugged into the incorrect port, and this prevented it from arming. I spent a long time trying to get the motors to arm, setting up again & again, trying different TX/RX combinations and even switching between two APM1.4s that I have. Eventually I pulled out the GPS and got it to arm, and that prompted Chris to suggest that I may have it plugged into the wrong port. Given that the ports on the IMU and the APM board are identical, some sort of warning about this in the 'Troubleshooting' page may be helpful.

However my problems were not over. I then could not get the AC off the ground - it flipped first time out and broke a prop. I went through the appropriate troubleshooting menu for flipping and wobbling and got no further.I decided to change radios from DX7 to DX8, because the latter has a throttle curve and permits very slow throttle advance - allowing one to catch a flip before it goes over and analyze it. I couldn't get an AR7000 or AR8000 to send signal to the APM, eventually an OrangeRX 9 channel worked. I did some slow 'flips' and noticed that it was pitch instability - in both directions, implying that the stabilizing compensation was reinforcing rather than offsetting a change. Roll and yaw stability seemed to be working.

I ran the latest firmware, reset everything and saw that various sensor feedbacks in the APM Planner were now garbage (fluctuating all over the place). I switched IMUs again, set everything up again, and my second IMU showed stable feedback although the compass on this one seems to be broken. Nevertheless, encouraged by the stable gyro feedback I decided to try to fly again. I set up and slowly raised the throttle, but although I tried to catch it, this also ended in a flip and another broken propeller.

This is about as much as I can stand at the moment. Given that there are two different issues on two different IMU boards & that I have ruled out all other options, I have to assume that they are both faulty. My question then is - has anyone else been sent out-of-box faulty goods by uDrones? Is quality control an issue? I don't know if sending the boards back to them will help, but maybe someone else has done this and had success?

I also fly a GAUI 330x with a HoverFly Pro board, and I also fly two MK hexas, so I'm not a total newbie when it comes to quads. I've just never had this many problems on any one project.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Jeez John,

    As I would NOT have helped you?

    Ok, joke, but my ArduCopter has been flying successfully for the last 3 months or so, and my UAV plank has done a number of successful missions(sounds professional, doesn't it !)

    Yeah, we also had one sensor board with a definite fault, and one maybe.

    All the ones I've assembled seems to be working...........

    You're welcome to pop around, just give us a call, in case I'm working late, or away.



  • Glad to hear you got it up and fkying. I still cant stop drooling at your multirotor collecttion.


    I guess I was lucky as my first ever board was a pre-assembled one from uDrones my other 2 were soldered by me so far all have no problem (crossing fingers. Hope you get it sorted out with uDrones.


  • Excellent news guys - my Arducopter has finally flown!

    The help I got on here was key - thank you Mike, Jeff, Jason, Chris, u4eake , Matthew and Helldesk. In the end, Helldesk put his finger right on it, although I guess anyone who suggested motors/sensor inversion was on the right track. I did what was suggested by Helldesk and swapped ESC connectors by using servo extension leads. I swapped the two CW motors and the two CCW motors, mostly because this was the easiest first option, did the hand test and I could feel it was now inherently stable. Next was a ground launch and I got it airborne! I've now done about 20 mins of airtime with it and all is well.

    In trying to understand this problem, everything points to a sensor being mounted reversed on the board. The 'motors' test in the CLI passes correctly with the orginal wiring, so the software and radio configuration was originally correct. I found this page very helpful:


    And to quote it:

    "If the multicopter is tilted along an axis and quickly flips on that axis, this is an indication that either the sensors are setup backwards (if you are buidling your own Shield) or the motors are setup backwards..."

    Which brings me to the issue of the quality of workmanship at uDrones. Both my pre-assembled Arducopter and my additional APM1.4 were bought from uDrones and both arrived faulty. The AC board has a sensor reversed and the other board has haywire sensors on all 3 axes. These faults cost me a lot of time and frustration and I will be taking this up with uDrones. You pay a premium for pre-assembled equipment precisely in order to avoid these problems, and this adds to my ire. I'd like to thank Chris Anderson for fostering accountability by bringing Gigio from uDrones into our discussion.

    Next steps - fit my XBee set and start practicing autonomous flying!

  • I just realized you are more experience than I am. I can only dream of having MK hexa, its exaclty what I wanted to build but cant afford it.

    Anyway, an interesting result on the hand test. It was a bit the same with my 3rd quad when I loaded v39 on it (first firmware on that frame) I recheck everything time and time again no luck. It will always dip in random direction and hand test ill go crazy. Nothing was change on the frame/motor/prop and others except the firmware. Not that I am suggesting it could be the case with your setup. Others may be right this could be hardware and possibly a short somewhere.

  • OK I've now done the 'hand' start test and I have an interesting result. With the copter level in my hand and motors running, it feels basically stable, but when I ease the throttle up & start to tilt it - in whatever direction - it immediately accelerates into that direction. This is consistent with flipping off a ground launch.

    @Jeff - believe me, it would not have flown for a second like that - as it is the copter was nearly ripped out of my hand. Whilst I really do see the value of PID tuning, I fail to believe my AC would be so unstable using the default PIDs for my configuration. Presumably they were set using exactly the configuration that I have.

    I took that APM out and installed my other APM1.4. I erased, reset and set everything else up. In Mission Planner Flight Data, the gyros are still haywire. Basically the data coming back makes it look like the thing is performing acrobatics, while all the time its stationary on the floor next to me. Clearly there is a ghost (pilot) in the machine!

    I then tried to arm the motors but I can't even get that far with this board. I guess its not surprising given that the processor thinks that the copter is highly unstable.

    So in summary - board number 1 seems to be inverting the response to gyro feedback. Its as if the stabilization algorithm is doing the exact opposite of what its supposed to do. This could be a software or hardware issue.

    Board number 2 simply has haywire sensors. This seems like a short in the electronics?

    Just a reminder that its not one of the following (all checked many times over):

    • ESCs uncalibrated
    • Radio not set up
    • Motor/s wrong direction
    • Props wrong direction
    • APM facing wrong way/wrong frame specs
    • Not levelled - I re-levelled using the throttle to the left technique for 10s, and using a spirit level across the copter arms.
  • Jeff and Mike, thank you, that is valuable advice & took time to put together. My problem is not any of the basics, but I'll go through what you've advised step by step. Non-levelling, non calibrated ESCs, bad radio setup, oscillations are definitely ruled out. I haven't ever uploaded via the IDE, I wanted to avoid installing another app on my PC, but I'll definitely consider that so I can revert to an earlier firmware/mission planner combination.

    I'm taking a little break from AC and APM for now, so I can get some flying time in :-P. When I pick it up again I'll go through the items you guys suggested.

  • Hi John sorry to here about your mishaps, I've those days or weeks with those issues and it can really be frustrating. My first ACM board was from Udrones and it had fair share of crashes some 20-30ft drop and even had the IMU slightly detached to ATMega board but it is still runing until now (lesser crash). I've had 2 other boards that I soldered myself and they had their fare share of mishaps as well specially my latest frame (3rd). I am in no way saying you have missed anything or trying to think that you did not read wiki but for me if something is not right I will go back to basics.

    A few things I find could cause flip during take off, my personal observation
    1. Not properly leveled quad
    2. wrong motor rotation CW / CCW or motor numbers
    3. Oscillation during spool up (sometimes oscillating during take of seem to confuse IMU on whats level)

    Things I do when everything goes wrong
    1. Re-uplaod via arduino, i know they are trying to eliminate this but I find it my last resort
    2. use CLI to preconfigure in the steps mentioned on wiki
    Erase EEPROM/RESET/reboot/set frame/level/enable mag/set declination/enable sonar/go to test/run IMU (to initialize offsets)/go back to setup run radio calibration/then esc calibration then connect to Mission Planner and cofnigure my known PIDs/configure modes
    (new version have the reset command configure to erase eeprom after reboot)
    3. Run the the pretest the hand test 1/3 throttle Jason mentioned if everything seems to point correctly on pitch roll input and it stabilize when leveled then I would do the spool up

    In my experince (personal) the combo of mission planner 1.0.57 with ACM 2.0.38 is my base setup. When newer firmware doesnt cut it for me I would go back to those. Again personal preference.

    It is quite frustration when you have mishaps and sometimes cause you to even do more misjudgement but if you pause and reminisce for a while a light bulb moment happen. Just to share some stupid mistake, on my third frame I can never get it of the ground without it will always flip in different direction. I then attempted a hand launch and it flew but PID needs some adjustment so I brought it down and tried something. I then tried to take off from the ground and it took off but not stable I had to counter a bit again during flight notice I need more PID tuning needed so brought it down and change settings but it wont take off so I did hand launch but lucky I was alone as it tilted backwards towards the ground. all in all I broke 2 CCW blades. I almost gave up, but decided another go, loaded back v38 and had to replace the Groupner E-prop as I run out of spare with jdrones composite blades and to my surprise it is about a 70% success on take off and thats where I notice the oscillation on take up, my LG seems to cause the quad to be a bit bouncy during take off so I put some foams as feet bot it will take off without issues. Event got confident to put a gopro on the frame and had my first blog here on diydrones.

    Sorry for the long reply but just hang in there some mishaps will happen but after those it will make you a lot more experienced and easier to spot issues in the future.

  • Thanks for the feedback guys.

    @Chris: thanks, I will take you up on an offer of a Skype call. Will coordinate via email. Haven't spoken to uDrones yet but I will once I've read through the feedback here, maybe 'pilot error' is yet the problem!

    @jason: good feedback, I've never done the hand test because I've never yet needed it. Believe it or not, these are the first props I've broken on any quad of mine. I've never experienced such a violent flip, seemingly accelerated & hard to stop. But yeah, I certainly will next time as part of my preparation.

    Re the CLI, I went through every single test mutliple times. The Wiki doesn't explain how to interpret the tests, but I just applied common sense. The IMU test, for example, seems to represent sensor feedback and if the AC is static you would expect close to zero data. In the 'gauges' part of the APM Planner flight data, I could also see gyro feedback etc & could tell when my one IMU went haywire.

    Re radio setup - no problems. I made sure the endpoints/travel were acceptable and mapped the correct switches to AUX1 and 2 etc. I tested all the radio output in the CLI test and the guages window in APM Planner. I successfully enabled AH on the ground so I'm sure the switches and the sticks are correct.  Radio setup is part & parcel of other quad setups so I'm sure I'm ok on this score. I love the DX8 for its advanced options & especially the throttle curve - makes quad flying without AH much easier.

    @ Matthew - I did scour the wikis. One thing I find confusing is 'disappearing' wiki pages. For example, in May I printed out and filed most of the AC2 Wiki, but I now can't find some of those pages. I couldn't find any reference, for example, to what role the dip switches play in quad setup. I assume none therefore. Re PIDS - since I run a stock standard AC2 with 28cm arms and standard motors & ESCs, I haven't changed them. Also haven't found help on how to analyse & adjust them either. Will check though - and if someone has a link to a reference on the PIDs I'd appreciate it.

    @ Mike - OK send me some luck mate! Alternatively, maybe you can point me to a resource/wiki page on PID Tuning?

  • Moderator

    Wow, sorry to hear, I feel a little guilty. My experiences have gone so well that I think you took on the troubles for both of us. The warning about the GPS port is in the APM and AC2 build guide itself, but you would not have looked there if it came prebuilt. 
    I have scratch built three frames and all three have flown from the start, despite having different dimensions. None of them should have flown as well as they did, I didnt even have a magnetometer on the first... sure, some of them skated away, or yaw'ed a bit, and sometimes flipped, but all flew.
    And as for quads, I am a complete n00b. I've stolen your good luck. 
    There are a great many tips and bits of experience with this specific hardware sprinkled all throughout the "manual/wiki", and in the forum, and being so new to every aspect, and given that I assembled APMs and my own frames, and am both solo and n00b, I read them all many times. It doesn't sound like that would have helped get you flying all the same in the end. Here's wishing you the best, and sorry about stealing your mojo. Things have been great for me so far. I'm deep in PID tuning, and having a ball. I have 16 more motors and ESCs on the way from jdrones (having given up on the backorder at diydrones - never fear, I keep buying other stuff there, oh, and not as replacement motors, so far I have only lost one prop, and that was during a ground test, not even from flying!) - and my bixlers (three of them) are in an airplane. Waiting on hobby king has been my greatest challenge :)

  • I have purchased 3 kits that I soldered and assembled myself, with no issues. On one the baro later failed and it was cared for very quickly by C.S.

    In my experience in climbing the Learning curve at building a few Quad with ACM it has been 90% myself as the problem. Either I was not aware of a building issue or had not read the WIKI and forums well enough to learn the small details.

    I run 2 Quads with a DX8 with no issues. Check carefully your PIDs for pitch... not a misplaced decimal point for example. Select the right frame,etc. Do the motors start at the same time?

    Maybe addressing one issue at a time in this forum might help to resolve these bit by bit.
This reply was deleted.


DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
DIY Robocars via Twitter
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4