This is a discussion re the ArduCopter-3.1 AutoTune feature.  A place for people to report successes and failures, ask questions and get answers.

The AutoTune wiki page is here.


Views: 74322

Reply to This

Replies to This Discussion


  IMO HobbyWing Xrotor is the way to go if you're already set up with standard ESC's (meaning not 4-in-1). Best bang for the buck. There is a thread about them here:

I have XRotor's on my 750 Y6, but not BLHeli flashed. On that RCG thread there is a lot of info. Bottom line is HobbyWing's are great ESC's, just that my latest build may be too much to ask from the Quattro. On my test quad they are excellent as it is a more compact frame and lighter.

Yes you want OPTO, even though they aren't "true" OPTO; very few are.

Thank's DG, taking a look.

Need advice. Sync issues were said to be an issue with large pancake low kv motors using simonk. My exp has been sync issues with those same motors only with high poll count. Those motors having low poll count i havnt had sync issues. Having said that, i havnt tried autotune with them. I have a Tarot x6 with Multistar 50 size motors with 274kv,which are rebranded Arris 288kv motors. Using Pixhawk/Flycolor 45 amp escs, 20000mah 6s batt. Flying GREAT! These motors are low poll count--12/14. 18in carbon props. As i said, flys very well. Just would like to know if autotune would be an issue. Please advise. Frank.

I am using nearly the same setup, but with blheli esc´s. So I think its not really compareable. With BLHeli I got several Vibration issues with fast rpm changes and sync issues with the braking features activated. I think the right setup of the esc settings I essential. Motor Brake/ Low Brake should be disabled.Motor advance should be 12 to 15 degrees.These settings based on my personal experience with BLHeli 14.1 so if you like to tweak your esc´s be very careful to test them on the bench before flying them.

Cheers Gregor

Hi Frank,

You can test for Sync issues by switching the throttle high and low. If you don't have a problem there then Autotune should be fine. And remember, if Autotune finds a sync issue then there is a very good chance that you will find the same issue during normal flight.

Already had vibe issues. On first flghts, stabilize flights were good until I went to post hold, and it would just land. Balanced props, and all went well. .
LENARD, Thank you for the response. With props off, I did high low throttle changes with no sync issues. Was just wondering with the large,heavy 18in carbon props,if that would exacerbate the issue.. Frank.

Hi Frank,

You do want to test for sync issues with the props on. A common approach is to turn the props upside down.

Thank you Lenard, I will. Pretty big, I think I'll strap it down first. I will post back on my findings. Frank.

What do you use to flash them? thank's

Not upside -down - just swap 2 wires so they rotate the wrong way.  I did my testing by hooking the ESC's directly to the receiver and testing just one at a time and holding the copter arm in one hand while playing with the throttle with the other hand.  Go from zero to full throttle as fast as you can.  Jump around suddenly different throttle speeds.  Consider programming the ESC acceleration features at this point in time.

I'm thinking just swapping two wires won't have full effect, as the props just spinning backwards won't have the same thrust. I will turn them upside down and move them in one direction around like compassmot. Then I will replicate full thrust.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service