Developer

This is a discussion re the bad Accel, Gyro and Baro values that we're seeing with ArduCopter-3.1.  The increase in the SPI bus speed from 500khz to 8Mhz has exposed a hardware problem on some boards.  That hardware problem is that the 3.3V regulator has been blown so all sensors are running at 5V instead of the intended 3.3V.

 

How have these regulators been burnt out?

  • Attaching a radio receiver or MinimOSD to the APM while the APM is only powered through the USB (see video below)

  • Some clone boards seem to come from the factory with blown regulators.  3DR boards might also come with blown regulators although they do a specific check of the regulator as part of the regular QA process.
  • It is not (as far as we know) actually caused by the AC3.1 software itself, it just exposes the problem.  You could prove this to yourself by checking the 3.3V regulator (see video above) before and after the upgrade.

 

How can we fix the regulator?

Option #1:  If it's a new board (so that it's less likely you burned it out yourself) you could report the problem to the retailer that sold you the board and ask for an replacement.  If it's 3DR it's called an "RMA".

Option #2: if you're handy with a soldering iron you can replace the regulator yourself.  On the APM2.5.2 (and higher) boards it's not that difficult.  On the APM2.5 it's far more difficult.

3691073788?profile=originalFor APM2.5.2 : TPS79133DBVR

For APM 2.5: MIC5219-3.3YML TR

How can I stop it from happening again?

Do not connect any devices such as a radio receiver, MinimOSD, GPS, etc while the APM is powered especially while powered only through the USB cable.

Attaching a 100uF capacitor across any of the APM's radio input's 5V and GND pins will stop the regulator from being blown by plugging in a receiver.  video here!

There are very few reports of regulators being blown twice and no reports of it ever failing in flight.

 

Below are some graphs of the types of values that we are seeing on these boards.

3691073724?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Replies are closed for this discussion.

Replies

  • I am running APM rover 2.45 and have verified I2C voltage as 4.60 VDC.  I also have a rock & roll horizon in MP.

    The controller is 3DR of 12/12/2012 vintage so no warranty.  The board has flown well for over a year on my quad and I just recently moved it to my rover on 3/14.  I do not know how the regulator was blown but I can clearly see the blowout (see pix).  I do not normally make wiring changes with power on, but this could probably be due to operator error.

    Question 1:  How do I precisely identify the board?  I can see no ID except AT 2560. 

    Question 2:  Assuming I have a 2.5 board, is the  MIC5219-3.3YML TR the best choice or would I be better off wiring a more robust regulator off the board?

    Question 3: Should I continue using Rover 2.45 firmware after repairs?

    3701693703?profile=original

    • Developer

      Hi emile,

      i can not think of any reason why you shouldn't use APMrover_2.45 after the repair.
      APMrover_2.45 is running here without problems on apm2.5 and clones.

      no problem at all.

      Regards,
      Linus

      • I received my APM2.5.2 clone last week. I have not fitted it to any copter so far. I have been getting familiar with MP and the APM board in general. So far I have only connected a USB lead (and the external compass/gps) to the board. There is no jumper at JP1. I have correct 3.3 volts.

        I can load firmware ok. But my problem is it hangs about 1/3 progress when connecting Mavlink. Terminal works ok. When I go test etc I get the "PANIC: failed to boot MPU6000 5 times"

        Am I doing something wrong?

        I have tried 3 usb leads, 2 computers (Xp & W7), uninstalling, rebooting etc etc.

        After reading this thread I am wondering about usb power not coming up to speed (voltage) quick enough?

        Any suggestions would be appreciated. I am stubborn enough not to accept a failed MPU6000...

        Thanks...

        • Phelec -

          The APM 2.5.2 has a built-in compass; if you have plugged in an external one as well it can lock up the I2C bus. To use the external compass, you need to cut the trace at the External Compass bypass. Later, you can re-enable the internal compass by soldering a bridge across those two pads.

          APMCompassModification.jpg?width=640

          Unless what you've actually got is a cheap clone "2.6" APM: There are many clone manufacturers shipping 2.5.2 APMs with compass omitted and selling as "2.6" boards, without even bothering to change the silkscreen; they still say 2.5.2. I have a friend on RCG who just got one sold as a 2.5.2 from a reputable US vendor; he's slightly torqued.

          Paul

          • Thankyou Paul. (actually my name is Paul as well). Yes my board is a clone. It has 2.5.2 marked on the bottom and has the compass chip removed. I tried with and without an external compass/gps connected. I still somehow cannot except the CLI  testing of MPU-6000 fail as an actual failed MPU.

            However, I have today sent the board back to China. Keeping all body parts crossed that there maybe some good come from this.

            I have been an electronics repair technician working at component level for more than 40 years. I had my own business for more than 20 years and employed 4-6 staff.

            Age is catching up to me as my eyesight weakens and the components keep getting smaller.

            So, are you suggesting that although the compass chip is not on the board, but the link is still inplace, that could have been my problem?

            Regards Paul

            • Paul -

              No; I was saying that if you had an actual 2.5.2 it would still have the compass onboard, which would interfere unless you disable it as per that photo.

              What you've confirmed is that you do in fact have one of those mislabeled APM clones, and for all practical purposes, it is actually an APM 2.6. THAT platform is what the GPS/Compass combo was made for, so should work as plug & play with no modifications to the board.

              Have you tried it without the GPS/Compass plugged in to see if it behaves any differently?

              Paul

              • Yes, I tried it with and without the compass/gps plugged in. Both ways it still would not complete the connection to Mavlink.

                I have only had this unit for 10 days and that is also the amount of time I have been learning so far. I have been reading from the internet each night for about 4 - 5 hours. I have contacted a few forums. I thought maybe there was some basic step I have missed. But, no one has prompted me such a thing. So, I think I have covered the basics.

                From being a repair technician, I hate (with a passion) giving up on a fault. I do always like to get to the bottom of a fault. Even if it concludes it is a write off.

                This however has a time limit where I have to return it to the supplier and hope for their justice.

        • Best to all colleagues, my name is juan jose and am new to the forum, my greetings to all and thanks in advance.
          Sorry for my bad English, and esperon be patient with me.
          Well it happens to me exactly what you Phelec, I have the right regulator and giving the 3.3v.
          When I connect the planer mission screen goes mavlink I rc10 stays trim and there does not happen.
          Probe all things possible and always with the same results.
          if anyone can help me out what hechar agradeseria of heart.
          Greetings.

    • Emile, what you are looking at is not the 3.3V regulator. Its the fuse that protects the APM when powering the APM over the RC output rail with JP1 plugged in.

      If you blew that then you probably made some kind of short circuit on the Vcc internal 5V power rail on the APM.

      Look at the top of this page, there are the 2.5.2 and 2.5 board 3.3V regulators identified in order to determine which board you have. The regulator is located on the other end from where your fuse is blown - closer to the GPS port.

      Since it works with USB power besides the 3.3V regulator your APM may survived the original cause for blowing that fuse. So you might get away with replacing the 3.3V regulator - depending which board version you have, one is easier replaced than the other. If you want to continue to use power over JP1 then you will most likely also have to replace the blown fuse in your picture.

      • Thank you Detlef,

        Closer examination reveals that I have a board later than 2.5, so I assume 2.5.2.  However, the voltages on two of the pins of the existing regulator show USB voltage (4.6 V in this case), so looks like I will indeed have to replace the 3.3 V regulator.  :-(

This reply was deleted.

Activity

DIY Robocars via Twitter
yesterday
DIY Drones via Twitter
RT @chr1sa: After more than a year of only virtual races, @DIYRobocars returns to the newly renovated @circuitlaunch on May 22 for the resu…
Apr 11
DIY Robocars via Twitter
RT @DAVGtech: And now available with LiDAR 🔥 https://twitter.com/Heavy02011/status/1381137016381964293
Apr 11
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #9 - #ParkingLotNerds #thunderhillracetrack, CA Join us for the next race April 24th,…
Apr 11
DIY Robocars via Twitter
RT @DWalmroth: Weather's finally cooperating, looking forward to racing 1:10 scale autonomous cars outdoors again! @diyrobocars, @NVIDIAEm…
Apr 7
DIY Robocars via Twitter
RT @AIDRI_: I finally succeeded in optimizing the trajectory and speed of a car on a #racetrack. Next step: implement a 2d controller and…
Apr 7
DIY Robocars via Twitter
@jetdillo @circuitlaunch Actually the second *in person* event in a year. We do virtual races every month
Apr 2
DIY Robocars via Twitter
Update: we're moving it back one day to Sunday (the 4th) at 11:00am instead
Apr 2
DIY Robocars via Twitter
@GrantEMoe @circuitlaunch Update: we're doing it on Sunday (4th) at 11:00am instead
Apr 2
Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
DIY Robocars via Twitter
RT @chr1sa: Maybe we should have a mini @DIYRobocars race in our lower school's playground https://t.co/xLFeua1R6X
Mar 29
DIY Robocars via Twitter
If anybody wants to join us for an informal outdoors hack/race we're going to be meeting at the @CircuitLaunch park… https://twitter.com/i/web/status/1375907409223249923
Mar 27
DIY Robocars via Twitter
RT @SmallpixelCar: Ready to reopen, innovation has to continue. Inside/outside, LiDAR/GPS, race/delivery https://t.co/jpmvttoHEd
Mar 26
DIY Drones via Twitter
RT @DAVGtech: By far best race yet! Congratulations to the winner @Heavy02011 🥇🏆🍾👏👏👏 @diyrobocars @donkey_car @NVIDIAEmbedded https://t.co/…
Mar 20
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #8 - #ParkingLotNerds ⁦@DAVGtech⁩ ⁦@DWalmroth⁩ ⁦@OttawaAVGroup⁩ - join us tomorrow h…
Mar 20
DIY Drones via Twitter
RT @mrpollo: 11 years ago, the pxIMU was announced to the world on @DIYDrones, and it changed the life of many (mine included). The followi…
Mar 18
More…