Hi.

I have a problem after updating AC to 3.2.1 from 3.1.5.

When in Loiter, the the speed of the motors rev up and down/pulsate quite rapidly. This was working fine when I was using previous versions of arducopter.

I have downloaded the logs, and have looked into accX, accY and accZ. These seems to be inside the range specified in the wiki at arducopter. (Log_vibrations.bin)

Please have a look at the Log.bin, and note the difference between ThrIn and ThrOut when I'm in Loiter mode.

 

Anyone having any idea what the problem may be?

Views: 27496

Attachments:

Reply to This

Replies to This Discussion

If you migrate to Pixhawk you can enjoy the better last firms, if you have little space take in consideration Pixracer, the new board for little setups; Z values is common that are higher than x and y ones; if you don't solved with moon gel try with leonards orange foam under the corners or with this  http://www.hobbyking.com/hobbyking/store/__76727__APM_Flight_Contro...

A thing that you can do easy, is to put aprox 50 grs weight over your controller well fixed with double sided tape until you recive the other dampening systems. (remember the compass if you use metalic material.)

I put a genuine 3DR APM 2.5.2, that was collecting dust, into my Quanum Nova to replace the factory APM that was in it. (The factory stuff requires custom versions of copter) The Loiter/AltHold pulsating started as soon as I upgraded to 3.2.1. After reading this info I started thinking the filter frequency could be my problem. Changed it to 20 and voila - no pulsing and a much better atlhold all around. Thanks to everyone here for this info.

Andy Piper said:

So this is really strange. If you look at the setting:

    // @Param: MPU6K_FILTER
    // @DisplayName: MPU6000 filter frequency
    // @Description: Filter frequency to ask the MPU6000 to apply to samples. This can be set to a lower value to try to cope with very high vibration levels in aircraft. The default value on ArduPlane, APMrover2 and ArduCopter is 20Hz. This option takes effect on the next reboot or gyro initialisation
    // @Units: Hz
    // @Values: 0:Default,5:5Hz,10:10Hz,20:20Hz,42:42Hz,98:98Hz
    // @User: Advanced
    AP_GROUPINFO("MPU6K_FILTER", 4, AP_InertialSensor, _mpu6000_filter,  0),

0 is supposed to mean default which I think is now 20Hz (was 42Hz). So if setting this to 20 gives different behaviour to 0 it has to be some kind of bug in the initialization of the sensor. Given that there was quite of lot of work in 3.2.1 specificly around sensor failure detection, it seems quite likely that something was introduced in 3.2.1 to cause this.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service