Adding extra functions to MinimOSD

I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:

Added:

- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading

- RSSI

- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)

Enjoy

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

        • Iv tried tried with both sides powered and not. And still no joy so im not sure that is the issue?

    • I have this problem, i have never been able to upload a new character set and i know they arnt uploading because i have tried editing out every single symbol so they are all transparrent and this is viewable when you preview the character set on the config tool. But when i upload it although it says "done" the character set clearly hasnt updated as the original character set is still viewable. Would really like to hear how this works.

      • Hi Robert I am not sure that mine is the same as yours as the latest version of the CT reads the number of the character set currently installed and it has clearly changed from the older number after my update but hey maybe I am wrong about that too.  I really do want to run the latest version as it has the icons and labels etc that I need to match my APM firmware and setup.  Here's hoping

        Hally

        • I agree, the config tool shows that that the latest charater set is uploaded but in reality, at least in my case, the character set on the board isnt really there.

  • Hi glen, just reverse the channel in your ap. hth.
  • Awesome work Gabe. Thanks for making the minimosd so much better for the community.

    I have a small request to get ezuhf rssi working correctly. The rssi value that ezuhf puts out is inverted so 0% on the OSD is full signal and 100% is no signal. If I put the raw value in back to front (low value as max and high value as min) it stops the rssi from working at all. Is it possible to either have an invert signal button next to the rssi channel select in the minimosd setup or re-do the code for min and max to allow for reversed numbers? Everything else is perfect :D
    • Hey Glen,

      I suspect you're the guy asking about this on youtube too?  In case no, I just want to stress that you really should be choosing LINK over RSSI on EzUHF anyway, as it has some heuristics that better estimate link quality, where the RSSI is only one of the data elements in the link quality but there for, if I recall correctly, legacy applications.  Oddly enough, my RSSI does work fine if I only choose that, or at least it did when I was tinkering last year, but maybe something has changed in the EzUHF firmware since upgrading to the latest version that is producing the behavior you're seeing.


      Good luck!

  • I've tried to modify the code in order to read Battery B.  The readout is hardcoded for now to show in the middle of the display.

    I've configured my APM 2.7 to read A0 and transmit 'voltage2' over mavlink.

    Unfortunately I see garbled characters instead of numerals. (I did use the upload Character_Updater_FW.hex - MinimOSD_2.4.0.2.mcm - <mycode>  methodology to minimize any upload follies.  The battery A readout I enabled  displays fine.

    I am willing to go farther (because its almost useless to me without this feature), but require a way to display debug information.  Since the serial pins are used by the APM-MINIMOSD connection, I'm not sure of what I can do.

    Else, if I can't show debug info while executing the code, I am at a severe disadvantage, and will humbly ask instead for those who are more knowledgable about the code to perhaps take a peek at what I've done. 

    I know this will benefit many fixed wing FPV folk in addition to myself.

    • I am glad you are still working on Bat B. Hope you get the help you need.

      Did you know the EagleTree Vector OSD has four battery voltages :-O

      • I'm not holding my breath for help.  The past number of months tell me I'm on my own for this task. At least I took my head out of my a$$ and clued in of course the Tx isnt used on the MinimOSD/APM connection so I can use it for debug. 

        Maybe so, but the vector OSD wont display APM mavlink data - which doesnt help me. 

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
4 hours ago
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Saturday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Saturday
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Friday
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Thursday
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
More…