Adding extra functions to MinimOSD

I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:


- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading


- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • You can code from:

      You can see how it looks in a screenshot I posted here:

      A new MinimOSD firmware! Contribute to minimosd-ng/minimosd-ng development by creating an account on GitHub.
      • Hi Luis,

        AlceOSD looks very interesting. Looking forward to test it if it is open source.



        • It really does ;)

          Ready for testing and contributing if its open source



          • Sorry, I missed this post!

            And I take the change to announce that the AlceOSD project has been invited to join diydrones github!

            You can find it @



      • Hi Luis,

        any chance you can give me some infor on what kind of video chip you are using on the AlceOSD?



      • HI Luis, 

        We will try it tomorrow and see how it works. Thanks for your help. 

  • Hi,

    I´ve got following issue: I get the low voltage warning even with full lipos. I have searched in the pixhawk log for voltage drops but canot find any under the set threshold.

    I am using the latest arduplane software 3.2.3 and the R800 for the minim.

    What is the reason?



  • Heya,

    Just wondering if anyone here can potentially help me, i have a quad running APM2.5 with Arducopter 3.2.1, i have a minimOSD flashed with R800 and 3DR radio telemetry module, these are connected with a Y cable (RX only on the OSD).

    My APM is powered by a power module and the MinimOSD has the solder tabs joined so is running 5v across the board.

    If plugged in direct to the APM with both Tx & Rx connected the OSD functions completely normally...

    If attached to the Y cable along with the telemetry radio the OSD boots up fine but it shows nothing but zero's for data, this stays the same if connected to Mission Planner (1.3.25) or not...

    If attached to the Y cable but with the telemetry radio unplugged I receive 'No mav data!'

    I have 'enabled Telemetry' within MP and also made adjustments to the settings of SR0 and SR1 and these seem to have made no difference.

    Any ideas? I have tried searching without much luck?

This reply was deleted.