ALT HOLD issue, the quad start to raise quickly

Hello, during a test with Arducopter and latest firmware version the quad started to gain altitude in a uncontrolled way, so I noted that the GPS was not fixed during this starnge behavior, the I disegnaged ALT HOLD recovering the fligth capability

So I wait for the fix then I tried again , ALT HOLD worked very fine any type of problem.

Then next day I redo the same tests and I paid attention to verify that the  GPS was not Fixed, the result was the same : unexpected and quick altitude gain.

Obviously the throttle stick was at the middle.

So, this issue is known ? I parametrized in a wrong way the quad ?

Suggestion ? Asks ?



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Paolo-

    I'm not an expert, but I don't thing GPS is used whatsoever in ALT_HOLD mode. Do you have sonar? If so, try without sonar.

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21