• problem after my Taranis plus upgrading  to firmware 2.1.1 and plug in the tincey adapter into the vx8r and pluggend into the apm 2.8 and the receiver what I get is all telemetry slots full message-press exit to continue ( will not let me out of the screen), can anyone please tell me how to fix this,  Thank you, Tj

  • @clooney

    at your fork in commit:

    you merge bsongis sport sync patch.

    but in commit:

    you remove the new interrupt Vector. is there a reason for. and is syncing to sport still the same than with  bsongis original patch. i noticed on my EU X8R receiver that it works perfect with the bsongis patch. with the old original code the data needs sometimes 10 seconds to refresh on taranis. on non EU firmware the sync is ok also with old teensy code.

    i ask because i add currently your fork which is at least forked from me:) as upstream to my fork to merge your changes on s-c-l-v-rc-opentx2.1 branch. and your last commit here make me a little bit insecure.

    maybe you can give me some infos here.



    Clooney82 - Overview
    Clooney82 has 2 repositories available. Follow their code on GitHub.
    • This reply was deleted.
      • @clooney @wolke

        I had hoped to get to grips with this system and contribute something back but unfortunately busy life has meant I just haven't had the time.

        Great to see you guys are actively developing and improving, and adapting it to opentx2.1. Keep it up :)

        • :),

          uff!!! since i update my old x8r and my taranis to EU conforming firmware everything currently messed up.

          sport sync from teensy do not work as expected with the EU receiver firmware. also i have the mavlink message problem with bsongis original patch. currently only this  s-c-l-v-rc-opentx2.1 branch with cloonys last commit do a little bit working. but also messages often need a long time.

          and today in the morning my brand new taranis-plus&x8r both EU versions arrived. totally happy i upload opentx2.1.1 to the new radio. but now nearly 16h later i am totally frustrated. i do not understand the new telemetry system. all my lua telm scripts rip on this system. also the fu...  "telemetry slots full message" drives me crazy. this do not happens with bsongis patch. but maybe because in this case no mavlink date flows.

          hmmpf. for today i give up this task ... frustrating.



          • This reply was deleted.
            • I deleted all the sensors, plugged in the tensy and it added back all the sensors I deleted a couple and it puts them back in, there must be some other setting in the apm that have to be changed, I changed SR0 per the instructions, and cut the trace I figure this must have something to do with the latest open source so I guess it must be somewhere in mavlink or in the data stream, Tj

              • I had the same problem with it filling up my slots with duplicate false sensors, it went away after i connected my APM telemetry module for talking to my ground station. Its connected to rx and tx then I removed the wire so the teensy only listen to the traffic. My conclusion are that the teensy didn't initiate the communication right so the APM never sent the data thus the Teensy was translating bogus data and adding false sensors to my Tanaris. 

                Maybe someone else have a answer why this happened but it solved my problem. The negative part is that I need the ground station connected and running to get any data to my tanaris now.

  • so if i start from scratch, what is the latest version of opentx i should install?  2.017?

    and what is the taranis config repo ?

    1- this ?

    2- this?

    thankyou ! 

    This MavLink_FrSkySPort repository is discontinued! The development is moved to Clooney82/MavLink_FrSkySPort where we work together on this. Please d…
    • in summary what is the right combination that is now working ?

      opentx 2.0.13? taranis plus, lua  , which lua script for pixhawk or apm 2.6 , which .bin configuration file 

      i tried different combinations , but non seams to work fine, the closest one , i have a screen that seams close to ok, but , shows invalid flight mode , and the screen chars looks bad , almost none legible on the display  , 

      direction is appreciated. 

      thank you

      • working and well tested firmware versions are:

        • opentx 2.0.17
        • ardupilot up to rev. 3.2.1 (pixhawk)


        • teensy3.1
        • FrSky X8R

        opentx firmware need lua enabled. and must run with protocol XJT - D16. Telemetry A1 - A4 must set to Raw (-). Vario Source is VSpeed. Serial Protocol is FrSky Sensor Hub. Volt source and Current Source must set to FAS.

        on lvale script you must configure your flight modes manually in telm1.lua. in wolkstein script flight-modes needs no configuration



        • Thank you Wolk , i do all procedure as supposed to , but still have errors,

          im trying to simulate the screen directly from companion , no teensy com yet , using 2.0.17 , but on the simulator display it says opentx 2.0.3 

          no mater what, it stays the same ( downloaded by using companion)

          The display shows strange chars, any ideas what should i try ?, thank you 3702795165?profile=original

This reply was deleted.