Hi ya'll,

The thread on my blog post is getting a little unmanageable.  How about we discuss test results here instead...  

I'll also post release notes as new builds are out.  The device must support 'USB host mode' (most devices running android 3.1 or later are fine).  You'll need a 'OTG' adapter such as this

Please post feedback here or on the github issues site - the google play comments are not really useful yet.



Hi ya'll.  Please move further discussion of this app to a newly created group:

Feel free to make new approprately titled discussion threads.  

Future app releases will be announced only there.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • This project is moving along much faster then I would have believed.  Before I try it out though, I was wondering how it works. Do I have to arm my quad and put in the air before laying in waypoints on the tablet? And what mode do I need to be in?

  • Just got home from school (UNM) Looking good. Here is 1.20 screenshot on Pipo S2



  • Hi Kevin.

    After seeing you are still improving the UDP part, one small consideration. UDP is bidirectional, isn't it? So using as example a phone as "sender" and a tablet as "reciever" means the host (Host IP adresse) is the one of my tablet? So the phone has to set up the connection (to the tablet). After loosing this connection (silly me, switching off wlan or similar, that means the phone can't see the tablet anymore), does it automatically try to reconnect afterwards? If the Host IP adress would be my phone i could try to reconect manually. So could you think about an additional option, so we could decide, if we want to use sender/host or reciever/host. The problem i see is, that in theory in this case we have 4 UDP mode posibilities

    1.1 telemetry/phone/sender (as host)

    1.2 telemetry/phone/sender

    2.1 receiver/tablet

    2.2 receiver/tablet (as host)

    Maybe this could be more important in the future ;). And maybe your new "UDP mode selection" does this job, then sorry and i ve misinterpretet "outbound host".

    Best c.

    P.S.: Please add a versions info in the app-setting. Google Play still says 0.1.12 and i know I got a newer version ...

  • Developer

    Hi Kevin, please can you add my device to the compatibility list on the market?
    Work fine here: "Vodafone Alps GT-I93000".

    Cheers, Marco

  • Thanks Kevin, great project!

    I've tried this app with my girlfriends Samsung Tab 2(P3100) and it loaded ok. I don't have 3dr so i can't test it more.

    I'm also asking support for bluetooth connection similar way it is in Copter-GSC. I'm using Xbee and only possible way to connect is BT or WiFi because my samsung phone [I9070] seems not to have otg support.

    Regards Jani

  • Moderator

    Sorry I'm holding you up on this.

    The code apparently means Play Services version not authentic so I tried uninstalling the updates to Play Services, then froze the app in Titanium, then uninstalled completely in Titanium and reinstalled from the Play Store website - each time trying the app, frustrating!!! (oddly Play Services does not show up when I search for it in the Play Store app so can only install through the website)

  • Developer

    So... Last night there was only one crash report (woot!).  It is some strange device called a "WonderMe WM8850".  If you were trying that device and it was failing for you: You don't have google maps, and when I try to raise a dialog on your device it barfs.  So I'm going to blacklist it for now...

  • Moderator

    Hi Kevin, don't know if you saw my posts about trying to fix the problem, anyway, I tried two friends' phones today, also Galaxy S2's, one said the phone is not compatible with the Play Store version and the other downloaded it fine and connected to G.Maps fine, both on standard ICS. I still get the G.Maps not installed. I'm upgrading to the new vesion of the ROM (JB v4.2.1) as soon as it comes out so hopefully it will work then.

  • so what exactly does this do? does it use the phone as the flight controller (in replacement to the apm), or is a ground station thing?

  • Developer

    Hi Kevin,

    had a short ArduRover SITL test with 1.7 today on my Huawei Honor  phone (No USB-host!).

    Works great! thank you for all the work!

    now i need to buy an adequate tablet ;)



This reply was deleted.