Anyone had a 3DR uBlox LEA-6 GPS fail?

I use a 3DR LEA-6 GPS receiver on my 3DR Hex.  It's connected to an APM2.5 running 3.0.1 firmware

 I always use telemetry and normally, I see 10 to 14 satellites.  If it's less, I usually wait a bit in order to acquire more before taking off.   When I'm in the house tuning things or setting waypoints, I normally get a fix of 5-7 satellites depending on which part of the house I'm in.

For the last week or so, I've only been getting 5-7 satellites outdoors and no satellites at all indoors.  

I recently switched over to a Taranis TX with the FrSky X8R receiver and thought perhaps the new receiver was causing the problem.

Today I disconnected the Taranis receiver to see if it would make a difference.  I also disconnected my 915Mhz telemetry radio so  that only the APM and GPS were powered. 

Today it's worse.... Now it won't lock on any satellites.  The flashing blue light never comes on and MP shows zero sats.   I tried it indoors and outdoors with no luck.  I even swapped the GPS to APM connector cable with a spare I had, but the GPS still won't lock on any sats...   Just to make sure there was no local interference affecting things, I fired up my Magellan hand held GPS unit and placed it beside my Hex..  The Magellan works normally and sees satellites.

Could something in the APM be causing this, or is it time for a new GPS?   If so, is this a common failure, or am I one in a million :)

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Did you ever solve this problem?
    Today I have the same problem ona quad that was working last week. No crashes or physical damage to vehicle cables or hardware. Gps just had red led. Blue led never flashes even after 10 minutes.
    • I never did get the bad one fixed.  It just died in its sleep never to work again..  I don't know if they can be repaired economically with all those micro surface mount components.  I never looked in to it.

      The new one with the built in magnetometer that I ordered as a replacement  worked great out of the box.  I guess it's just 'one of those things'. 

  • That's an interesting one!

    -Is there any physical damage to the GPS unit (broken antenna connector, etc)?

    -Is the GPS getting the full 5V power from the APM?

    Depending on your soldering skills, you could attach a second connector to the GPS and hook it up to a USB<->Serial cable to your PC. Then use the uBlox software to take a look at the GPS.

This reply was deleted.

Activity

DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
yesterday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
yesterday
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Friday
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Thursday
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
More…