APM 2.5 flips on take off

Hello,

I know, I am not the first one with this problem. I am flying in the stabalize mode, I downgraded the P value in stabalize but it's still flipping on take off. I am using a 4S lipo and flying with 9" x 4,7 props. On the other side, when I am flying with a 3S lipo, the APM flies perfect. 

I think this is very weird, because this started a few days ago and before that I made another 10+ flights without having any problems. Does someone of you know what else I can do to solve this problem? I did not change anything on my setup. 

I don't know what to do anymore.

Could this device solve my problem? https://store.3drobotics.com/products/apm-power-module-with-xt60-connectors

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Check your props! Make sure they are on correctly (not upside down, the props are spinning in the right direction and the correct prop (CW or CCW) is on the right motor)
  • Hello,

    I have added some logfiles, I still don't know whats the cause of this. The first flight went well, a bit wobbles. After that I disconnected and reconnected the battery to test, after that reconnect I am having the same trouble as before.

    Could it be a hardware defect?

    Sander

    logs.zip

  • T3
    What are you P values for the 3S and 4S? The power module only helps with powering your APM and allowing you to monitor power. I fly both 3S and 4S and I have drop P value for 4S. I've never had a flip problem, only when I mounted the APM wrong or put my props on wrong.
This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…