APM 2.5 No dataflash Compass init error

Hey everyone, I just received a Arducopter kit w/ full electronics, assembled it, everything is connected, installed MP, loaded driver, loaded 2.8.1 firmware. Problem I am getting is I cannot get Mission Planner to recognize the compass, doesnt work in Flight Data. Also the console reads No dataflash inserted  Compass Init Error. Attached are two screenshot I hope helps troubleshoot this. I hope the board isnt DOA.. The APM 2.5 came assembled in the case, but was missing 3 of 4 screws and the rubber reset button, bit surprised with this... Anyways, looking forward to any and all suggestions on getting this up and running. I am stationed in Japan and would like to see about troubleshooting this before sending it back to the vendor. Long mail times :P Thanks!




You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I also had the symptoms with no voltage from the regulator.

    -Yesterday/ Today

    1. I read the voltage across the output (0Vdc)

    2. I removed the regulator (it wasn't easy with my tools)

    3. Borrowed a Power Supply [PS] from work

    4. Soldered '+' wire from PS to pad corresponding to the '+' output of the regulator

    5. Soldered '-' wire from PS to pad corresponding to the '-' output of the regulator (any board ground would probably work)

    6. Plugged board into computer USB & verified that the problems were the same as before

    7. Disconnected board in Mavlink (still physically plugged in)

    8. Enabled PS

    9. Re-connected board in Mavlink

    10. Verified CORRECT operation of both GPS and compass

    11. Ordered free sample of the TPS79133 from Texas instruments (had to create 'legitimate' account)

    12. I am now waiting for the part to arrive - but I believe I have identified the root cause

    //I took this route because I was not about to splurge a bunch of money for a new board!


  • how did you fix this! Can you help me? 

  • Thanks you a lot I also found this problem on my brand new APM2.5.2! I will tried to change this IC regulator.

    • Before I change 3.3v regulator IC I also checked voltage at I2C socket and found the voltage is less than 1v. After I have changed that IC,the problem is solved! Thanks to diydrones community..... :)



  • Has anyone had any experience getting this APM2 Simulink Blockset to run on their APM2.x? (2.5 or 2.6) The link is :


    So far, I was able to get it to download code on my APM2.5 but couldn't get it to run normally. Also, my board showed the error"No dataflash inserted" after I downloaded the code, so that might be caused from running the APM2 Simulink Library, but unable to confirm. I believe that this is a fatal error for the board and it needs to be replaced. Does anyone else have any experience with this software set or getting this error after flashing new firmware? Thanks.

    Have you had any experience or heard if anyone who has worked with this before? My main concern is whether it is safe enough to use without damaging the board when downloading code onto the board. Also, is there a possibility that the dataflash or relevant hardware could be damagaed by the.burning process? I'm trying to finish up my thesis by end of the year so I'd greatly appreciate any feedback.

  • Looks like this happened to me twice! I just got a replacement board from 3DR after a couple weeks of complaining. I hook it up and it looks to be working. I run a ESC calibration according to their docs and when I try to connect to the APM after that, I get "no dataflash inserted" and a COMPASS INIT ERROR. If i run a test, I get an error that the baro didn't initialize within 500ms. This is the second component that's been sent to me twice and the replacement has been defective. I'm on my 3rd GPS unit and 2nd APM. Could I have a bad power module with my kit or something? I checked the voltage off the pads on my power module and they read 5.3v. Again... ordered the kit in mid july and still haven't gotten it to work yet because of a slow RMA process and defective components.

  • I'm having the radio calibration on a 2.0 APM with 3.0.1 code.  I've been using using this APM for ages.  Maybe this problem is more code related instead of hardware?

  • I'm having the exact same problem with my 2.6 straight out of the box.

    I'll see what I cn do to fix it

  • Looks like I have the same problem. I'm getting 1.14v on the output pins. Very very frustrated right now. Ordered my Y6 DIY kit over a month ago and it's been grounded due to various problems. First the GPS was backordered for 2 weeks. Then the kit arrived. The ublox GPS unit ended up being bad. One of the control leads on the PDB was not soldered correctly. Now this issue.... Everytime I have support open a case it takes a week of back and forth.... Almost about ready to see if they'll give me a refund or do a chargeback on the AMEX. On top of that, I was told the GPS is backordered again when I called in, but I got an email from a tech saying the part may ship today. Sorry for the vent. This is just a bad experience. It also doesn't give me confidence in the platform with so many different components going bad on a brand new kit. I understand stuff happens, but when it happens this many times... i don't know. At least none of these things went bad while it was in the air.... hopefully it will see air in it's lifetime....

  • Well I replaced the part on mine.  $1.40 plus shipping for part.  not easy at all to replace due to the size.  I now have the 3.3 volts across, but still having the issue. 

This reply was deleted.


DIY Robocars via Twitter
DIY Robocars via Twitter
DIY Robocars via Twitter
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17