Hey everyone, I just received a Arducopter kit w/ full electronics, assembled it, everything is connected, installed MP, loaded driver, loaded 2.8.1 firmware. Problem I am getting is I cannot get Mission Planner to recognize the compass, doesnt work in Flight Data. Also the console reads No dataflash inserted  Compass Init Error. Attached are two screenshot I hope helps troubleshoot this. I hope the board isnt DOA.. The APM 2.5 came assembled in the case, but was missing 3 of 4 screws and the rubber reset button, bit surprised with this... Anyways, looking forward to any and all suggestions on getting this up and running. I am stationed in Japan and would like to see about troubleshooting this before sending it back to the vendor. Long mail times :P Thanks!

Jake

Views: 19832

Reply to This

Replies to This Discussion

I'm not seeing your pic for some reason.

Well I replaced the part on mine.  $1.40 plus shipping for part.  not easy at all to replace due to the size.  I now have the 3.3 volts across, but still having the issue. 

Looks like I have the same problem. I'm getting 1.14v on the output pins. Very very frustrated right now. Ordered my Y6 DIY kit over a month ago and it's been grounded due to various problems. First the GPS was backordered for 2 weeks. Then the kit arrived. The ublox GPS unit ended up being bad. One of the control leads on the PDB was not soldered correctly. Now this issue.... Everytime I have support open a case it takes a week of back and forth.... Almost about ready to see if they'll give me a refund or do a chargeback on the AMEX. On top of that, I was told the GPS is backordered again when I called in, but I got an email from a tech saying the part may ship today. Sorry for the vent. This is just a bad experience. It also doesn't give me confidence in the platform with so many different components going bad on a brand new kit. I understand stuff happens, but when it happens this many times... i don't know. At least none of these things went bad while it was in the air.... hopefully it will see air in it's lifetime....

I'm having the exact same problem with my 2.6 straight out of the box.

I'll see what I cn do to fix it

I'm having the radio calibration on a 2.0 APM with 3.0.1 code.  I've been using using this APM for ages.  Maybe this problem is more code related instead of hardware?

Looks like this happened to me twice! I just got a replacement board from 3DR after a couple weeks of complaining. I hook it up and it looks to be working. I run a ESC calibration according to their docs and when I try to connect to the APM after that, I get "no dataflash inserted" and a COMPASS INIT ERROR. If i run a test, I get an error that the baro didn't initialize within 500ms. This is the second component that's been sent to me twice and the replacement has been defective. I'm on my 3rd GPS unit and 2nd APM. Could I have a bad power module with my kit or something? I checked the voltage off the pads on my power module and they read 5.3v. Again... ordered the kit in mid july and still haven't gotten it to work yet because of a slow RMA process and defective components.

getting 0v from the TPS79133 chip... same issue. emailed on saturday for an RMA. called in today and they said they would approve the RMA today once they found the email. I haven't heard from them since. Looks like I'll be without an APM for an additional week, since it'll take them 2 days to send the label, 1 day for transit, 2 days to process the RMA and another day to figure out to ship it. People have been telling me to get an HK clone. I'm sure if it has to ship from china, it'll still get here sooner. BTW, I tried paying for crossshipping with them- didn't make  a difference. My APM still took a week or more to get to me even though i paid for cross-shipping. In fact, the APM didn't ship until two days after they received my RMA and that was after complaining to the CEO

I bought a HK clone and am having to try and warranty it now because "no data flash". Im getting 3.3v on the output.

Following a reading elsewhere on Internet, you can also change 3.3V regulator with a more powerful one. By default, TPS79133 deliver 100mA.

It is also useful, as TSP79133 is hard to find and expensive on ebay. :(

By selecting right options on manufacturer configuration tool, you can choose a different version, with same packaging.

Having a look here TSP79133 equivalents. You can change default TSP79133 with a convenient TSP73133.

TSP73133 deliver 150mA, and it easily available on Internet (by 10 pieces roll, perfect just in case).

Follwing War Monkey Instruction, you can also protect regulator from pikes, by placing two TVS diode (such as P6KE150). They are easy to solder (regular diode, not CMS). 5V and GND can be found on many plugs (input, optional A1-A9 plugs and 5V plug (close to reset btn)). Solder it on back side. 3.3V and GND can be found on GPS and I2C plugs.

Enjoy :)

Has anyone had any experience getting this APM2 Simulink Blockset to run on their APM2.x? (2.5 or 2.6) The link is :

http://www.mathworks.com/matlabcentral/fileexchange/39037-apm2-simu...

So far, I was able to get it to download code on my APM2.5 but couldn't get it to run normally. Also, my board showed the error"No dataflash inserted" after I downloaded the code, so that might be caused from running the APM2 Simulink Library, but unable to confirm. I believe that this is a fatal error for the board and it needs to be replaced. Does anyone else have any experience with this software set or getting this error after flashing new firmware? Thanks.

Have you had any experience or heard if anyone who has worked with this before? My main concern is whether it is safe enough to use without damaging the board when downloading code onto the board. Also, is there a possibility that the dataflash or relevant hardware could be damagaed by the.burning process? I'm trying to finish up my thesis by end of the year so I'd greatly appreciate any feedback.

I have also the "no dataflahs inserted" error, my TSP79133 had zero volts at output pin so I change it with a TSP73133. but did not solve the problem , I'm still have the same issue.

I read the TSP73133 datasheet, the regulator is active when the enable pin is low , it is so, so I do not understand why it is not working.

Martinlbb, the TSP73133. WILL NOT WORK !!!

I have follow your suggestion and mount it but as Detlef in another thread told me that regulator has an inverted drive logic, so it needs a positive voltage to the EN pin while the original regulator on APM 2.5 needs to have the Ground connected to EN pin !

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service