Hey everyone, I just received a Arducopter kit w/ full electronics, assembled it, everything is connected, installed MP, loaded driver, loaded 2.8.1 firmware. Problem I am getting is I cannot get Mission Planner to recognize the compass, doesnt work in Flight Data. Also the console reads No dataflash inserted  Compass Init Error. Attached are two screenshot I hope helps troubleshoot this. I hope the board isnt DOA.. The APM 2.5 came assembled in the case, but was missing 3 of 4 screws and the rubber reset button, bit surprised with this... Anyways, looking forward to any and all suggestions on getting this up and running. I am stationed in Japan and would like to see about troubleshooting this before sending it back to the vendor. Long mail times :P Thanks!

Jake

Views: 19802

Reply to This

Replies to This Discussion

Thanks you a lot I also found this problem on my brand new APM2.5.2! I will tried to change this IC regulator.

Before I change 3.3v regulator IC I also checked voltage at I2C socket and found the voltage is less than 1v. After I have changed that IC,the problem is solved! Thanks to diydrones community..... :)
Attachments:

how did you fix this! Can you help me? 

I also had the symptoms with no voltage from the regulator.

-Yesterday/ Today

1. I read the voltage across the output (0Vdc)

2. I removed the regulator (it wasn't easy with my tools)

3. Borrowed a Power Supply [PS] from work

4. Soldered '+' wire from PS to pad corresponding to the '+' output of the regulator

5. Soldered '-' wire from PS to pad corresponding to the '-' output of the regulator (any board ground would probably work)

6. Plugged board into computer USB & verified that the problems were the same as before

7. Disconnected board in Mavlink (still physically plugged in)

8. Enabled PS

9. Re-connected board in Mavlink

10. Verified CORRECT operation of both GPS and compass

11. Ordered free sample of the TPS79133 from Texas instruments (had to create 'legitimate' account)

12. I am now waiting for the part to arrive - but I believe I have identified the root cause

//I took this route because I was not about to splurge a bunch of money for a new board!

 

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service