Replies

  • Hi, is anybody who is able to make optical flow v1.0 working on APM 2 ? I tried to set NPD to 3Volts but nothing in opticalflow_test running on APM2. Failed to initialize.

    This unit is now obsolete, I cannot buy. But I have it and I would like to use.

    Any help?

    Thanks.

    • Hi All,

      I just picked up the ADNS3080 form Ebay recently for $18. Just wondering if folks are still trying to get the ADNS3080 optical flow sensor working.  I have modified the test sketch and successfully ran it on an Arduino Uno and Mega but I do not have an APM board. If there is interest, I can upload the code.

  • can anyone please tell me about the complete setup and instruction manual needed for the optical flow sensor. I did all the required changes in the program but still its showing error. Friends please let me know about the changes in programs too. And I'm using APM2.5 with ArduCopter v3.1 and ADNS3010 sensor.
    Thanks in Advance.
  • Hi, 

    Did you end up getting it to work? I've had a similar problem, I'm using APM1.

    I get the message: Failed to initialise ADNS3080

    using the CLI and the python image viewer using the test sketch.

    Also i get this when typing 'c':

    sent 'c' to COM6
    Config: 0,0

    product id: 0 (hex)

    frame rate: 65535 (auto)

    resolution: 400

    shutter speed: 0 (auto)

    it doesn't let me change the frame rate or shutter speed or resolution.

    Also, when using the CLI it appears to have some sort of problem, as if its hitting enter a bunch of times after each command. for example, if i type 'm' it will say 'press any key to exit' and then it will exit straight away without pressing anything.also after pressing other commands such as 'i' it will repeat the list of commands a bunch of times (2-3 times) along with the line 'unrecognised command'.

    also when grabbing an image by typing 'i' i get (every time):

    image data --------------
    Optflow: failed to find first pixel

    the thing is, the first time i was trying to get this to work, i was getting a few images but hadn't tried the motion part of  it yet. I'm not sure whether itwas saying 'failed to initialize' back then. anyone know whats going on?

    I might add that because I have the APM1 i cant do what chris cooper said about data flash error. is there something equivelant that can be done there to perhaps get it to work? like how could you wipe the flash memory?

  • Did you do the setup as described in the Wiki?

     

    Randy

  • Is the optical flow supported on the APM 2.5?

    On my APM2 I often get this error in conjunction with the dreaded data flash error. Reinserting and securing the flash card often makes it go away.

    Also make sure the optical flow sensor isn't in it's test mode (entered when you load the test sketch). I think you just need to disconnect an reconnect power.
  • Nobody get it to work?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Saturday
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
More…