Hi,

my APM 2.5 just stopped working. When I connected it to Mission Planner via USB (battery not connected) it began to update the values as normal. But then in the middle of the job it just froze. Now I cannot connect to the Mission Planner anymore ("no hartbearts"), execept in terminal mode. There it says: "No dataflash inserted"

Is my APM broken? Is there a possibility to fix it?

All the best,
Markus

Views: 4287

Reply to This

Replies to This Discussion

I'm having the same issues. Any solution?

I'm afraid the board or a part of it is broken. Don't know why that happenend, it worked without any issue for six months. I wrote a mail to the 3D Robotics Support Team.

The most likely scenario is you had a hard landing that fractured the solder on one of the components in the dataflash circuit

Hmm, there was no hard landing. In fact the copter flew well all the time (attached the log of the last flight).

The problem happened not in the field but at my desk: When I connected the APM via USB it stopped suddenly during reading the values from the copter...

What do you suggest? How can I check if some components or solder broke?

Attachments:

Sorry for bringing up that issue again, but I can't stop thinking about the fact, that my lovely APM stopped working from one minute to the other (not even during flight but just sitting at my desk!). I checked the tlogs to lern what happened, but I saw nothing unusual. Perhaps somebody which more expertise could have a look? I added three tlogs, all of them recorded during the connection of my APM to my computer (no battery connected):

  • The first one was recorded shortly before the problem appeared - everything seems to be fine.
  • The second one was recorded, when IT happened. The APM froze during refreshing the values in Mission Planner.
  • The third one shows the issue: From now on the APM only can say: not dataflash inserted...

All the best, Markus

Attachments:

Hi

You already got a solution? I think my problem is TPS79133 chip

http://diydrones.ning.com/forum/topics/apm-2-5-no-dataflash-compass...

It's the same with my APM. The output voltage of the TPS79133 is only 0.5V. No solution yet...

just out of curiosity have you checked to see if all the lights still turn on when you plug it in to the computer? The reason that I ask is because I had this issue once, and no lights would turn on after plugging it into the battery/ usb. It turned out to be a burnt out diode.  

The green power LED still turns on. The rest of the LEDs remains off. There is no flashing of the red LED as it normally should be.

I am quite sure that the U3 (TPS79133) is dead. I'll try to solder a new one instead, Quite tiny that thing...

I believe that my the U3 (TPS79133) is dead too. I have a friend who makes micro welding, he saved the other APM had a loose USB port.
I did not find TPS79133 to buy in my town yet,
I found a few sites, but either do not sell less than 10 or the shipping is very expensive

I see you refer to TPS79133  my board has a MIC5219-3.3v  i'm getting 4.71 V from it.  any clue what is different between the two

I did it! I replaced the broken 3.3v regulator. It was the first time I soldered smd parts - and it worked, yes! Okay, it doesn't look very nice, and one leg of the regulator I had to connect via cable (a part of the conductor came off) - but the APM is running at last.

This description helped me a lot: http://diydrones.com/forum/topics/ac3-1-rc5-spi-speed-problem?comme...

Now I have to find a project for this old fixed APM - should be not the most valuable copter. Perhaps my old plane...

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service