APM 2.5 says: No dataflash inserted


my APM 2.5 just stopped working. When I connected it to Mission Planner via USB (battery not connected) it began to update the values as normal. But then in the middle of the job it just froze. Now I cannot connect to the Mission Planner anymore ("no hartbearts"), execept in terminal mode. There it says: "No dataflash inserted"

Is my APM broken? Is there a possibility to fix it?

All the best,

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hello,

    I have exactly the same issue of Marcus.

    My Apm 2.5 was fine, today I connected the USB cable to load a different firmware, update seems to be fine but now it is not possible to connect it with Mission Planner.

    At first attempt the loading freeze when reading Trim parameter, then it just do not connect, no heartbeats.

    Only terminal mode work but I get a "no dataflash inserted" , if I run  test mode, no baro or MPU seem to be present.

    All suggestions are welcome.

  • I'm, having this problem as well. Has anyone contacted 3DR about this?

    The problem is that I'm having trouble with my APM consistently climbing when in loiter regardless of throttle input but I can't really diagnose it without logs.

  • I'm now having a similar issue. I get "No dataflash inserted" but not a compass error and everything still works. I tested the voltage over the - and 3.3v pads and it reads 3.26 volts which to me says the regulator is still fine. Are there any other possibilites that could case the dataflash to no longer be read? I have no problems in mission planner and everything passes the tests in the CLI "except" logging. When I try to access log it freezes [mission planner] when I try to test logging it says  "No dataflash inserted". The board still flies well but i would like to fix whatever the issue is. Oh and this is on a 2.5 not a 2.5.x

  • I did it! I replaced the broken 3.3v regulator. It was the first time I soldered smd parts - and it worked, yes! Okay, it doesn't look very nice, and one leg of the regulator I had to connect via cable (a part of the conductor came off) - but the APM is running at last.

    3692882986?profile=originalThis description helped me a lot: http://diydrones.com/forum/topics/ac3-1-rc5-spi-speed-problem?comme...

    Now I have to find a project for this old fixed APM - should be not the most valuable copter. Perhaps my old plane...

  • Hi

    You already got a solution? I think my problem is TPS79133 chip


  • Sorry for bringing up that issue again, but I can't stop thinking about the fact, that my lovely APM stopped working from one minute to the other (not even during flight but just sitting at my desk!). I checked the tlogs to lern what happened, but I saw nothing unusual. Perhaps somebody which more expertise could have a look? I added three tlogs, all of them recorded during the connection of my APM to my computer (no battery connected):

    • The first one was recorded shortly before the problem appeared - everything seems to be fine.
    • The second one was recorded, when IT happened. The APM froze during refreshing the values in Mission Planner.
    • The third one shows the issue: From now on the APM only can say: not dataflash inserted...

    All the best, Markus

    2013-08-02 08-25-22.tlog

    2013-08-02 08-28-50.tlog

    2013-08-02 08-29-34.tlog

  • I'm having the same issues. Any solution?

This reply was deleted.


Santiago Perez liked Santiago Perez's profile