Replies

            • Yes, I did not mention Galileo, because when this system is operating (in 2020 ?) we will be discussing about the NEO 16 ;-)

        • big nonsense Ibrahim....that battery you see on board is to power EEprom...

          • maybe it is fake.

            see : http://code.google.com/p/i2c-gps-nav/downloads/detail?name=ublox-hw...

            • Developer

              @ibrahim no its not fake. For example jDrones GPSes have EEPROM installed and they also have configurations uploaded. 

              Battery is not for EEPROM. Battery is for keeping Navigation almanac and last position/lock informations alive inside GPS computer. Without it getting first position locks will take much l9nger as a lot of data needs to be loaded from satellites eg. Cold boot that clears all memories on GPS computer.

  • I'm still having a lot of GPS problems with APM 2.5 with NEO-6M UBLOX GPS using fw 3.1. Got GPS errors in logs and GPS BAD HEALTH during flight

    Fw 3.0 seems OK

    This is 3.0 log

    logapm30-28_zps748e1f53.jpg

    while this is 3.1 log

    logAPM-28_zpsf06f6a22.jpg

    in the same place, same time, same GPS.

    When gps shows errors copter goes crazy and flies away...you need to regain control in stab

    Has anybody the same problems? Has something to do with new gps glitch protection introduced in 3.1 fw?

    • I have same problem. I took off on stabilize mode, then switched to altitude hold and then loiter, there were no problems. When i switched to auto mode it flied away to sky :) up to 165 meter. Then decided to descend but then crashed. Luckily crashed on a empty area with no damage.

      I have external gps and compass module bought from ebay. I did not changed its configuration.

    • I was getting occasional similar GPS "runaways."  Loading the NEO-6M GPS configuration posted earlier in this thread seems to help:  http://diydrones.com/xn/detail/705844:Comment:1222612

      http://diydrones.com/forum/attachment/download?id=705844%3AUploaded...

      Though it seems like I still get a "runaway" every once in a while.

      --ET

  • I'm using NEO6 GPS configured with the specific configuration file from megapirateng group.

    I've used it for some month without any problem.

    With last APMcopter releases I've got a lot of GPS errors (documented in logs) that lead copter to fly away very often.

    I've solved the problem resetting GPS to default (NMEA-9600bps). 

    I noticed that, as reported by Linus, at power on APMcopter sets GPS to UBLOX protocol - 38400bps ...so I wonder if we still need to configure the GPS with 3dr.txt file (as stated in apmcopter documentation) or shall we leave GPS at defaults parameters and let APMcopter configure it.

    Luciano

    • I run a cheap $26 Chinese NEO6 unit  (with compass) as well, and left it completely standard. As long as you make sure you have plenty satellites before arming, it works perfectly well - loiter is rock solid.

  • I've just bought a $26 compass + NEO-6 unit from goodluckbuy, and - indoors - it seems to be reasonable accurate. Got sat lock in around 2-3 minutes from cold, and fluctuated between 8 and 10 sats 8 (which is the same for the LEA-6). Left it running in Mission planner for over an hour, and it was ok - didn't move about any more than the standard 3DR LEA-6.

    Also comes in a handy case with tidy cabling, and slightly longer than the standard as well, which is handy.

    I'm still not sure why NEO is so bad? Seems ok here...Are there any "gotchas" I should be wary of? I'm running arducopter 3.1.2 in quad mode.

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…