Hi all,

I am new to UAVs, I recently bought the APM 2.5, I have uploaded the Arducopter into the APM, if I try to connect via USB or the 3DR radios to mavlink, it does not connect, the error message is "No HEARTBEAT Packets Recieved", my baud rate for usb and radios i selected them correctly (115K and 56K), and i do not have the apm and radios connected to computer at the same time i.e if radios are connected to computer apm is powered via Esc. If i click on terminal it reads port is open, the board flashes LEDs 'A' and 'C' but if i type anything e.g test, pwm and hit enter nothing happens. as long as the board is powered on the LED 'A' is blinking. I tried reseting the board by pushing the reset button still no change in behavior of the board. Please HELP!!!!

I am building this UAV for my senior project.

Views: 9774

Reply to This

Replies to This Discussion

same here  used to work when I upgraded no more  same message.....HELP 

Are you seeing both com ports in the mission planner?  Are your 3DR packet radios just not working, or does USB still work?

Also, have you tried the stand alone 3DR radio application to test the radios?

hi Vitaly here    2.5 board  same   cannot connect using USB  I was trying to connect 3DR radio after having done a synch of all 6 ESC  all worked well could arm and disarm  switch everything off  tried to re power up later and noting working .  nothing was touched or disconnected 

Now I have just the APM2.5 connected to the mission planner latest version  and no luck 

the Planner see com18 as arduino mega 2560 and baud rate  tried all   but board not recognised ????

Unless you changed something, the default baud rate of 115k should be correct.  If you haven't, disconnect everything, Reboot the PC, then after the PC is back up, just connect the USB (remove the 3DR radio), and try from there first.  

the APM2.5  is disconnected from the radio Rx and from all 6 ESC 

juste connected to USB to laptop  live led is red on

APM is recognised as com 18   Arduino mega 2560 com18  baud set 115200

click on connect  get window Mavlink time out  trying to connect

after connect is clicked  Led A and C flash  then stop and led red A flashing 

at time out  new message window  No Heatbeat Packets Received

used to work fine every time before  only change updated Mission planner to 1.2.20 mav 1.0

did try to reload old version  same story........???   $##@!!!@@@

OK, so you're on mavlink 1.0 which sounds correct.

Try opening mission planner, don't connect, and click on firmware and try uploading again.  If that doesn't connect, try clicking on terminal.  See if you get anything there. If you can get in, try a reset.  

My other guess is that your baud rate was changed maybe.

The radios are able to load settings on 3DR configurator and in missionplanner, but donot connect to mavlink, the air module does not connect via FTDI to USB, it is not recognised. I reinstalled mission planner and now my computer does not recognise the APM either at all, no comport shows up in mission planner or in DEVICE MANAGER. The ABC LEDs turn on with the same behavior still.

Hmm, OK, I want to go back to USB troubleshooting first.  If you connect your APM, and open up your device manager, do you see a "Arduino Mega 2650 (COMX)"  listed anywhere?

nope it does not, it used to before I installed missionplanner 1.2.10

I want to jump in here as well.. I updated and I got nothing now. Same problem. My PC shows Arduino Mega 2560 but there is no com port number next to it in Device manager. I posted some screen shots too in this post asking Hammad's same question.
Hey, this guy found a fix! :)
Hope it works for ya.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service