APM 2.5 wont connect via USB to mavlink

Hi all,

I am new to UAVs, I recently bought the APM 2.5, I have uploaded the Arducopter into the APM, if I try to connect via USB or the 3DR radios to mavlink, it does not connect, the error message is "No HEARTBEAT Packets Recieved", my baud rate for usb and radios i selected them correctly (115K and 56K), and i do not have the apm and radios connected to computer at the same time i.e if radios are connected to computer apm is powered via Esc. If i click on terminal it reads port is open, the board flashes LEDs 'A' and 'C' but if i type anything e.g test, pwm and hit enter nothing happens. as long as the board is powered on the LED 'A' is blinking. I tried reseting the board by pushing the reset button still no change in behavior of the board. Please HELP!!!!

I am building this UAV for my senior project.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hammad  I have the same problem    I have found that UART2   the chip is opposite side of the silkscreen is blown

    it has a tiny pinehole in it    as well as the diode just above IC2    

    did you plug your USB to your PC with the lippo battery connected to the ESC and jumper 1 on

    I think it is really a poor design  no instruction came with the board and all you have is the blogs and wikki which are in fact very confusing   can anyone confirm having had the same  blow up board ????

  • did you also perhaps have this problem after calibrating the ESC been  connect disconnect reconnect the Lipo battery pack?

    did you use JP1 on?  I have a feel that this is the cause of spikes that damage the board.

  • Delete APM 1.2.20 and then google APM 1.2.19 and download the .msi file. you will go through the download sequence and it will install 1.2.19. After that, go to C:\Program Files\APM Planner\Drivers and click on the appropriate bit version for your computer. The "Install anyway" screen will come up. Click Install anyway and it will establish the com ports. The com port # will now show next to Arduino Mega 2560 in Device manager. Viola! It should work. Mine does now.. and to think I missed the only good day to fly in the last three weeks because of this.. smh
  • Hey, this guy found a fix! :)
    Hope it works for ya.
  • I want to jump in here as well.. I updated and I got nothing now. Same problem. My PC shows Arduino Mega 2560 but there is no com port number next to it in Device manager. I posted some screen shots too in this post asking Hammad's same question.
  • Are you seeing both com ports in the mission planner?  Are your 3DR packet radios just not working, or does USB still work?

    Also, have you tried the stand alone 3DR radio application to test the radios?

  • same here  used to work when I upgraded no more  same message.....HELP 

This reply was deleted.


David Hori liked Isabella Domi's profile
Jan 12
gotham liked gotham's profile
Dec 3, 2020