APM 2.6 v3.0.1: Refuses to ARM, won't say why

I've had to disable the Pre-ARM checks on my APM (Y6 f/w 3.0.1) because it will not arm.

The confusing part is that it won't say *why* it doesn't arm.

I have Mission Planner running, via 3DR telemetry, and the obvious causes do report on the screen on the first arm attempt.  (No GPS lock, etc).

With full GPS lock, all systems calibrated, and everything ready to go, it stays Disarmed.  The screen does not show a reason for the failure to ARM.

If I disable the pre-ARM checks, then it does ARM and fly correctly in Stable/AltHold/Loiter.

Is there any way to discern from the logs or other data why the Pre-ARM check is failing?

Thanks!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • you are lucky , me, disabling the pre-arm check won't do anything left stick down - right , nothing happen...

  • I had a similar issue that said 'GPS offsets are too high."  I had offsets that were anywhere from x209.425  y:562.593  z:-269.064  to x:2184.240 y:2036.103 z:10084.349 and greater. Turns out I had my GPS mounted backwards on the craft.  (other things I read suggested that you might have it mounted upside down - for which you'd have to select the appropriate No Roll, or ROLL_180 type of setting.)  So for me I had to turn my GPS unit 180 and then my all my offsets dropped to below 100.

  • I have the same problem! but i try to arm in room without GPS unit!  Must connect a gps unit before arming?

  • Hi,

    I had a similar issue. I figured out the problem lies in both hardware not software.
    Looking at the schematic from 2.5 to 2.6 there is something missing ... The compass. Hence the reason it is not healthy.
    Looking at this: https://code.google.com/p/ardupilot-mega/wiki/MagAPM2 The jumper in 2.6 is cut already.
    Also if you look below, the compass chip isn't there in 2.6
    The reason for this is apparently too much 'Magnetic interference'
    I haven't been able to get the 3.01 v working ... i dont know why :/

    But i downloaded the 2.9 version from: https://github.com/diydrones/ardupilot

    Got that to work so long as MAG_ENABLE = 0 (i tried just doing this on 3.01 but no dice)

    I think there may be a bug in the code (which i haven't found yet) which assumes you are using the external gps/compass

    Or something in the pre-arm checks ... not sure, but the root of the problem is the compass isn't healthy cause it isn't there!!!

    Stephen

  • I took a look in the code, and found the following reasons why pre_arm_check could fail:

    RC not calibrated

    INS not calibrated

    PreArm: Compass not healthy

    Compass not calibrated

    Compass offsets too high

    Check mag field

    No GPS Lock (fence)

    Baro not healthy

    Check Board Voltage (PX4)

    Each failure has a text report, so all I can figure is that the pre-arm check is failing with display_failure false, perhaps before the serial link is up to display the text?

    The checks are called with no display in the super_slow_loop(), so it's not clear if the same arm failure reason would later display when I attempt to ARM.  Anyone know?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @sunilmallya: Representation Learning +Instance Transfer to learn new reward functions along with advantage based filtering of new exper…
2 hours ago
DIY Robocars via Twitter
Apr 27
DIY Robocars via Twitter
Apr 27
DIY Robocars via Twitter
RT @f1tenth: Sliding (autonomously) into the weekend like ... 🤖😎 #f1tenth #robots #AutonomousVehicles @OpenRoboticsOrg @NVIDIAEmbedded @Aut…
Apr 25
DIY Robocars via Twitter
RT @chr1sa: One of the problems with autonomous car racing is that watching software drive is not a very exciting spectator sport. To help…
Apr 25
DIY Robocars via Twitter
RT @SmallpixelCar: Replaced AGX Xavier with @NVIDIAEmbedded Jetson Xavier NX. Now both cars look fast and clean https://t.co/jlcoY2EjZf
Apr 25
DIY Robocars via Twitter
RT @chr1sa: Yesterday we had a record number of competitors (36) in our monthly @DIYRobocars virtual autonomous car race. We kept it going…
Apr 25
DIY Robocars via Twitter
Apr 16
DIY Drones via Twitter
RT @chr1sa: After more than a year of only virtual races, @DIYRobocars returns to the newly renovated @circuitlaunch on May 22 for the resu…
Apr 11
DIY Robocars via Twitter
RT @DAVGtech: And now available with LiDAR 🔥 https://twitter.com/Heavy02011/status/1381137016381964293
Apr 11
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #9 - #ParkingLotNerds #thunderhillracetrack, CA Join us for the next race April 24th,…
Apr 11
DIY Robocars via Twitter
RT @DWalmroth: Weather's finally cooperating, looking forward to racing 1:10 scale autonomous cars outdoors again! @diyrobocars, @NVIDIAEm…
Apr 7
DIY Robocars via Twitter
RT @AIDRI_: I finally succeeded in optimizing the trajectory and speed of a car on a #racetrack. Next step: implement a 2d controller and…
Apr 7
DIY Robocars via Twitter
@jetdillo @circuitlaunch Actually the second *in person* event in a year. We do virtual races every month
Apr 2
DIY Robocars via Twitter
Update: we're moving it back one day to Sunday (the 4th) at 11:00am instead
Apr 2
DIY Robocars via Twitter
@GrantEMoe @circuitlaunch Update: we're doing it on Sunday (4th) at 11:00am instead
Apr 2
More…