APM 2 Version 2.60 Issue on channel 5,6 and/or 7

Hi,


I own the APM 2 since 2 months build in a MPX Cularis, the plane is ready for fhe first flight, and short time before I updated to 2.60.


I use CH 5 for the second aileron and CH 6 and 7 for flaps in manual (RC6,7_FUNCTION 1).


But with 2.60 my CH 6 Servo is not working anymore, allthough RC6OUT shows the right values.


I can change RC6_FUNCTION to 0 and back to 1 but nothing happens on the servo


The only workaround that works, is changing the value to 2 or 3 and then back to 1. After this,the servo works.

But when I reset or power off, function of CH 6 would be lost, allthough RC6OUT values are still ok.

I openend issue 725, within this other people have similar issues to CH 5 or CH 7, but CH5 and CH7 is working fine for me.

Strange ....

I already updated PPM Encoder to 2.2.68 but the issue still persists.

I am not sure, if I should make my first flights with 2.60 this weekend, maybe other issues could occur.

Maybe someone could help?

Regards

Gregor


PS: Sorry for my poor english

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I have a similar issue with APM2.6 with ArduPlane V2.78b (f0615253) firmware. 

    Missionplanner doesn't show any changes for channels 5,6 or 7 when I flip the switches. Signal is ok. Tested with servos and by connencting the m to APM inputs 1-4. Mode select on input 8 works also.

    Also tried all kinds of RCX_FUNCTION values. No help.

  • I could be mistaken but I swear I remember that the RCX_FUNCTION should be changed to "4" to enable the output channel. Take a look at "Optional Additions" in the Wiki, then Multiple Aileron Channels. Also, you did say that the Config Screen in the MP is behaving appropriately, right? Double check function in Manual, RTL and Stabilize.

    Best,

    Steven

  • Developer

    I have seen a similar issue on my plane, where it appears the [Aux] channels ( 5-7) are not being initialised properly on powerup.    changing any of the RCX_FUNCTION values to something different, then writing the settings to the plane, and then changing it back ( to where I want it) and writing the settings again, seems to cause the aux channels to initialise properly. ( untill the unit is powered down again).     It doesn't always do it on all channels, but the channels it does do it on are consistent, even if relocated.  eg if I have a gimbal on 5&6, and 5 is giving me the problem, then relocating the hardware ( servo lead ) to channel 7 and changing hte software to use channel 7 instead does NOT fix the problem.

  • Developer

    I'm not an arduplane expert but i have a little experience with the channel-aux stuff which is what you're struggling with.

     

    When you say RC6_OUT doesn't work you're looking in the mission planner's status screen where it shows all kinds of information from the APM?

     

    Of course after changing the FUNCTION of the various servos through the mission planner you're pushing the "write parameters" button?

This reply was deleted.

Activity

DIY Robocars via Twitter
Sunday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
Saturday
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…