APM Mini Fly Away - maiden flight.. :o(

Hi all,

High hopes dashed this evening probably through my own stupidity but I would welcome a diagnosis of the attached log, please.

This is a Tarot 250 mini quad with APM Mini 3.1 and 6M gps. All seems good, took off about 3 feet and kept her fairly steady in stab mode then went into alth at which point she started to rise steadily without response to any of my inputs. Got to roof level so I took her out of alth, even tried rth but she took a quick right and started heading down our street. I shot through the house and luckily a guy I know down the road saw it land in somebody's front garden. No apparent damage apart from a couple of props and a lost prop nut.

Seems there were some GPS glitches but I don't understand why she wouldn't go back into stab and let me bring her back down.

I'm successfully flying a powerful Spy 600 with Pixhawk and have never even had the slightest brown trouser moment with that..

Thanks,

Peter.

2015-03-05 18-01-14.log

2015-03-05 18-01-14.kmz

2015-03-05 18-01-14.log.gpx

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

      • Developer
        Vibrations in the Z axis effect the altitude. But they only matter if you are trying to hold abs alt. If you are in stab, you would compensate by lowering the the throttle.

        This is why we test alt hold first. Ie. Lock Z axis ie alt works, then we do loiter, ie. Lock X and Y works. If loiter works, we know it can fly autonomously I.e. RTL would be successful.
        • Hi Bill,

          I've changed the mount so vibrations are well within parameters now, please see log attached. GPS was lost altogether shortly after arming for some unknown reason, so she flew well in stab but I had inadvertently set the first flight mode to rfl instead of alth hence the ending.. Will try again today and try to ensure GPS lock before trying alth. 

          2015-03-12 18-13-29 2.bin.log

        • Hmm, I tried a small tethered flight this evening, logs attached. Seems that vibrations are wild and there seems also to be a problem with AccY.

          I have a specific mount for the Mini so I will fit that now and see if that helps but I'm confused at the AccY data..

          She did fly ok briefly in stab..

          2015-03-10 17-58-47.log

          2015-03-10 17-58-47.log.gpx

          2015-03-10 17-58-47.bin

          https://storage.ning.com/topology/rest/1.0/file/get/3702780418?profile=original
        • Hi Bill,

          I've attached the log from the last 'held flight' but no GPS data has been logged and this was with -6146 log bitmask.. Vibrations actually don't seem too bad to me although I didn't use full throttle. It doesn't seem to have recorded RCIN values either, which log setting would be most useful here?

          Thanks again.

          2015-03-09 17-58-53 49.bin.log

          https://storage.ning.com/topology/rest/1.0/file/get/3702780557?profile=original
        • Thanks Bill, I should know better, see here: http://ardupilot.com/forum/viewtopic.php?f=21&t=8569&hilit=...

          I'll re-mount the Mini, your explanation makes perfect sense although I still don't understand why complete control was lost in alt hold? Currently it's mounted on two layers of heli gyro pads which I'm sure are far too dense..

  • Looks like it went into RTL, unfortunatly you don't have many logs enabled to diagnose. Looks like you arenlt using a power module so not battery failsafe induced. Do you have radio failsafe set to RTL? maybe you had radio issues hence not being able to take back to stab...assuming you switched out of stab and back? It looks like you were in stab for the whole flight until the RTL.

    edit...I can see you have failsafe set to on in the log for throttle...i.e radio.

    Have you test loiter before? If you haven't got loiter dialed then you shouldn't be using RTL. You only have 6 satellites which isn't that great either which won't help RTL do its job at its best.

    If you have radio link and an RTL occurs you need to switch out of what ever flight mode and back to desired mode.

    • Hi Stuart,

      All was going according to plan until I switched to alth although the log doesn't appear to show that I did.. This was the first flight so I never got around to testing loiter and yes, I did switch back to stab, without effect..

      I have loaded 3.2.1 this evening, re-calibrated everything and enabled -6146 nearly all logging. I did notice that auto declination was checked so I've unchecked that, not sure if that would explain anything?

      I guess I was complacent as my Pixhawk has been so rock solid I honestly didn't anticipate there being a problem with this. The next flight will be 'interesting, will go somewhere much more open and larger..

      Fingers crossed, where's that fishing line..? :o)

      • You armed with a very high GPS HDOP.  

        • Thanks Bill, can you elaborate a little please, i.e. how would I know that, what steps should I have taken before arming, etc.

          • HDOP is a measure of how well your GPS is measuring horizontal position.  Normally, AC won't even let you arm with HDOP above 2.0, yours was over 4.0 

            So, you may have the pre-arm check disabled.

            Are you using Mission Planner?  You can see the HDOP value there, and then hopefully turn your pre-arm check back on.  Then AC will do it for you - won't let you arm until you have good GPS.

            What might have been going on with you, is you armed with too few satellites in view and the bad position solution gave you a "home" point somewhere other than where you really launched from. When you switched to RTL it tried to go there.  The Lat/Long of your RTL wp is in there, but I haven't got around to plotting it.

            Can you post another log or at least a param list so we can see what your pre-arm looks like?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @knightsautoteam: Hi @diyrobocars, we are Orlando's first Autonomous racing club and would love your support. We are hosting our first K…
Friday
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #14 - #ParkingLotNerds join us January 15th for #AutonomousRacing #RoboRace ⁦@DAVGtec…
Jan 16
DIY Robocars via Twitter
RT @chr1sa: And after that came our races, 50 in all. This battle between these two Russians was the best we've ever seen -- incredible fig…
Jan 16
DIY Robocars via Twitter
RT @chr1sa: Before our @DIYRobocars virtual race this weekend, we had a presentation from the team that won the Indy Autonomous Challenge i…
Jan 16
DIY Drones via Twitter
Dec 12, 2021
DIY Robocars via Twitter
Dec 12, 2021
DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Dec 4, 2021
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25, 2021
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23, 2021
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23, 2021
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20, 2021
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20, 2021
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9, 2021
More…