APM Mission planner v2.

APM Planner v2.0.18 installs fine, then crashes when run on a current Win8 machine.

Here's the Dr. Ming output:

apmplanner2.exe caused an Unknown [0xC000041D] Exception at location 036B5171 in module Qt5Quick.dll.

Registers:
eax=00000000 ebx=0cb198f8 ecx=0028d268 edx=09cc7190 esi=08fe9770 edi=0cb19950
eip=036b5171 esp=0028d2a0 ebp=0028d368 iopl=0         nv up ei pl nz na po nc
cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00010206

AddrPC   Params
036B5171 08FE9770 00000001 00000001 Qt5Quick.dll!QSGBatchRenderer::Renderer::renderUnmergedBatch(QSGBatchRenderer::Batch const*)
036B5C9A 08FEA8A0 036AB5E0 036AB5E0 Qt5Quick.dll!QSGBatchRenderer::Renderer::renderBatches()
036B6138 00000001 0CB7C318 0028D4E8 Qt5Quick.dll!QSGBatchRenderer::Renderer::render()
036BEAB0 0028D55C BF800000 0C976838 Qt5Quick.dll!QSGRenderer::renderScene(QSGBindable const&)
036BEE28 BCE07038 00000000 00000000 Qt5Quick.dll!QSGRenderer::renderScene()
036CACD8 09CC7190 00000000 00000018 Qt5Quick.dll!QSGRenderContext::renderNextFrame(QSGRenderer*, unsigned int)
036FC959 0028D69C 0028D600 0028DD3C Qt5Quick.dll!QQuickWindowPrivate::renderSceneGraph(QSize const&)
036E4411 091FD6F0 00000000 00000000 Qt5Quick.dll!QSGRenderLoop::instance()
036E494D 091FD6F0 0A1A9400 0028D758 Qt5Quick.dll!QSGRenderLoop::instance()
036E50FE 091FD6F0 0028DA04 084B4F78 Qt5Quick.dll!QSGRenderLoop::instance()
0327A2BC 0028DA04 0028DA04 0028D7F8 Qt5Gui.dll!QWindow::event(QEvent*)
0370645B 0028DA04 0028DA04 0028D838 Qt5Quick.dll!QQuickWindow::event(QEvent*)
0399829A 091FD6F0 0028DA04 0028D998 Qt5Widgets.dll!QApplicationPrivate::notify_helper(QObject*, QEvent*)
0399D60A 091FD6F0 0028DA04 00390000 Qt5Widgets.dll!QApplication::notify(QObject*, QEvent*)
668AB2CB 091FD6F0 0028DA04 0A1A9400 Qt5Core.dll!QCoreApplication::notifyInternal(QObject*, QEvent*)
03275017 095D80E0 00000001 003B0000 Qt5Gui.dll!QGuiApplicationPrivate::processExposeEvent(QWindowSystemInterfacePrivate::ExposeEvent*)
03275BA8 095D80E0 095D80E0 0028DAA8 Qt5Gui.dll!QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*)
03260336 00000000 091FD6F0 0028DAF8 Qt5Gui.dll!QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>)
03262A0C 0028DB3C 00000001 00000000 Qt5Gui.dll!QWindowSystemInterface::flushWindowSystemEvents()
6DCC3666 00180786 0000000F 00000000 qwindows.dll!qt_plugin_instance
6DCD4B4E 00000000 74C17694 00180786 qwindows.dll!qt_plugin_instance
74C17694 6DCD3570 00180786 0000000F USER32.dll!CallNextHookEx
74C195AB 6DCD3570 00000000 0000000F USER32.dll!GetWindowLongW
74C18D56 01EE1110 00000000 0000000F USER32.dll!FindWindowA
74C18EE9 0028DDFC 00000000 0028DE5C USER32.dll!FindWindowA
771DDD92 FFFFFF0F 0028FC18 668ED703 ntdll.dll!KiUserCallbackDispatcher
74C19C40 0028DED8 0028DED8 00000000 USER32.dll!DispatchMessageW
668ED703 0C623FC0 0A569000 0028FCA0 Qt5Core.dll!QEventDispatcherWin32::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)
6DCED5C3 0A0A7850 000003E8 000003E8 qwindows.dll!qt_plugin_instance
668AB630 00000000 000003E8 00B6FA46 Qt5Core.dll!QCoreApplication::processEvents(QFlags<QEventLoop::ProcessEventsFlag>, int)
03B13A71 084B4B70 00000041 0028FE70 Qt5Widgets.dll!QSplashScreen::finish(QWidget*)
00553585 0740FB38 0028FEC0 00000001 apmplanner2.exe
00A3849A 00000002 0028FF2C 7FFDE000 apmplanner2.exe
004010FD 7FFDE000 A38B1BEB 00000000 apmplanner2.exe
771E98EE FFFFFFFF 771DE0E0 00000000 ntdll.dll!RtlInitializeExceptionChain
771E98C4 00401280 7FFDE000 00000000 ntdll.dll!RtlInitializeExceptionChain

Is this an oversight on my part somewhere?

APM Planner v2.0.7 appears to run fine. Thanks.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Developer
    Try updating your video drivers
  • Try right clicking and running as administrator once. Or use mission planner which is a native win32 app not built on QT [I really do not like QT even on its native Linux]

    • Thanks for the response Craig. I did try runniung as admin w/no luck. Also tried installing again after installing current mission planner w/no success following that either.

      My OS of choice is SUSE Linux. Thanks again.

      • FWIW, also did install 2.0.14 last night w/no problem.

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…