Warning: If you power the APM 2.5 from a BEC you should include the diode fix used on the APM 2! It drops the voltage to 5.5V which is what the 3DR Power Module does!

 I've noticed a lot of USB connect issues lately and I have found some solutions. There are and could be several reasons for this. It could be hardware or software. It might be the connector on the board. It might be PPM and it might be something else. So if we all get together in one place we might have better luck solving these issues. So if you have a connect problem let's get to work on it here. Please be civil with me and I'll try and help. Together I think we can work this out. I don't care if you have a clone. Has nothing to do with finding a solution as far as I'm concerned. Be prepared to get dirty and have your camera ready and send screen shots too. Thanks let's fix this.

First things to try: PORT CONNECTIONS and COM PORT

Check com Port Speed in Mission Planner (115200)

Make sure of Com Port in Device Manager.

Turn off Bluetooth.

Remove any USB Devices you can.

Swap around USB ports.

Try a different USB cable.

Second things to try: SOFTWARE and DEVICE DRIVERS

Mission Planner checks for updates when it starts (if connected to the internet). Have you checked for Updates?

If Mission Planner just updated run threw the Port Connection and Com Port checks first.

Try installing USB Driver http://ardupilot.com/downloads/?did=19 (APM 2)

If you have another PC install Mission Planner on it and see if it works on it.

Uninstall Mission Planner and reinstall from MSI http://ardupilot.com/downloads/#Mission_Planner_3_raquo

If you having HUD display not moving problems-

Try installing latest STABLE FIRMWARE BUILD from http://firmware.diydrones.com/



Update/Reflash PPM Firmware

APM 2 http://code.google.com/p/ardupilot-mega/wiki/APM2Encoder

APM 1 http://code.google.com/p/ardupilot-mega/wiki/APM1Encoder


Mission Planner woes!

Make sure you have this font.


If you need to uninstall and reinstall Mission Planner

Make sure you go into device manager and uninstall the USB driver!

Make sure you have the proper .NET installed for Mission Planner (4.0 for the latest)

Make sure you install the MSI Mission Planner.

Make sure you reboot after making changes.



 I now offer a service to repair your APM for a $20 flat rate. If you send me your APM along with $20 and a self addressed return envelope with postage so I can return your APM to you if I can repair it or not. If I can't repair it I'll return $10 to you along with your APM.

Monroe King

995 CR 3040

Lampasas, Texas


 I'll be posting photo's/videos of repairs so others can learn too.

 I'm working on JTAG and UART0 work arounds that may give acceptable results for some.

Warning: Do not exceed Abs MAX input voltages when connecting the power supply or you will damage your board.
Warning: Connecting USB when you have input voltages at the high end of the range (near Abs Max) can damage the board. Disconnect battery before connecting USB or test input voltages so they are within the specified range.

Power Options Nominal Abs MAX JP1 status
Power on Output PWM connector 5.37V +-0.5 6V JP1 connected
Power on Input PWM connector 5.00V +-0.25 5.5V JP1 connected

Views: 56731

Reply to This

Replies to This Discussion

Upgraded to latest mission planner (Win8) and was unable to connect to APM 2.5 via USB. When plugged in via USB board is not showing in Device Manager. I can connect via the 3dr radios but am unable to re-install firmware. I'm guessing because the file is too large or firmware update via radio is disabled?

To eliminate variables I plugged APM into fresh XP machine which has no drivers or MP software on it. Does not show up in Device Manager. Unplugged everything from board and tried again, still not in Device Manager and getting red LED flashing (calibrating gyros?) and solid green (power).

If the sketch on APM has somehow corrupted, could I use the Arduino IDE to upload a simple sketch -- and then load firmware software from MP?

Thanks Monroe,

On my Win8 machine it has 1.2.53 installed from the MSI. It was only after the MP upgrade that USB recognition stopped.

The XP machine has no MP software or APM drivers on it.

I think the issue is prior to the MP software as the APM hardware is only showing up in Device Manager when connected via the 3dr radios.

I installed over top of the several month old MP. I then immediately ran the 'update' via the MP UI. It appeared to update several files.

I will run home now to grab my Win8 machine and try a clean install of 1.2.53

Uninstalled MP completely

  Deleted ProgFiles  / APMPlanner folder

Ran installation 1.2.53

   Note:  MP installation wizard reports 'Arduino LLC (usbser)' and '3D Robotics(usbser)Ports' drivers already installed\

Still no Ardu in DeviceManager 

Connected 3dr radios and successfully connected to MP

  USB SerialConverter correctly showing in Devicemanager


Click ArduCopter v2.9.1b quad

  Message: Can't detect your APM version, check cabling

  Same thing when trying to upload ArduRover


Issue definitely seems to be with USB connection. Anyone know how to uninstall the 3DRobotics usbser Ports driver?

Is it normally possible to update firmware via MP and 3DR radios instead of USB?

Monroe, any other ideas to figure out this USB issue?

I plugged in a Arduino Uno to my Win8 machine via USB and it correctly shows in DeviceManager under Ports on COM3.

Does the Uno use the same driver as the APM?

If so then I think this can be narrowed down to a hardware issue

I don't know how anything hardware wise could be blown, I purchased the APM a few months ago and it's never left my desk.

Monroe, how do I do the bypass you're describing?

Yes, I exist. Well at least as far as I know.

I am however on +12GMT Oceania time

Hi Monroe

Still having the issue (along with 3 others) where the APM will connect fine but then do nothing - no response etc.  The link strength indicator on the Flight Data page starts out at 100% then drops to 0% and a Red X appears.  This happens with USB or wireless.

I tried resetting to factory defaults and erasing the epprom but still no better.  I can install new firmware and connect but then it doesn't respond.  Whats weird is once and a while it will work - but the next time I connect its right back to doing the same thing.


Thanks for any help



Thanks Monroe, do you think my underlying issue is hardware?

If there's anything I can do in the meantime let me know..

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service