APM2.5 5V/Vcc Schematic

Frequently asked questions are about powering an APM2.5 or why the same does not work or why it has failed.

Here is a simplified schematic showing the major components of the 5V/Vcc circuit on the APM2.5

Target Audience: Readers who do not have Eagle or are confused about using it.

You Need: Basic electronic schematic reading ability

3690968635?profile=original

Note that I have separated the PWM Output section into the upper left corner with a heavy purple line that is bridged by the jumper JP1 on the APM2.5. This is to emphasize that diode D1 passes current through JP1 (and drops voltage). The remaining energy is then called 'Vcc'.  Everything outside the purple corner is Vcc.

This is why the USB will power the APM2.5 when connected to a computer/USB hub. Note the fuse on the APM2.5 side of the USB connector AND another fuse on the output of D1. Another change from APM2.0 is the D4 6.0V Zener diode. If an over voltage is applied to the board, D4 will crowbar what it can to protect devices.

As with APM2.0, any 5V source connected to any of the indicated Vcc/5V points outside the purple corner (with GND of course) will power the APM2.5.

Also of note is the 'Mystery Port'. This port takes 5VDC before D1 and the fuse and is called 'JP_VCC'. Other clues to the mystery are the lines to 'ADC 12' and 'ADC 13'. A mystery indeed!

Any errors in this drawing from editing are mine.

I hope this can be used as reference for solving problems.

-=Doug

 

27-FEB-2014 Eagle files are now located HERE

 

APM2_5 Simplified Power.PNG

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I lost the power to the mp6000 and baro when I connected the USB to the computer while the BEC was supplying the 5V to the inputs!  Seems to have fried a track next to the USB port.  So my APM 2.6 lasted 4.1 hours!

    Bad design!

    I think I will stick with Naza M.  I have ordered another APM but it will need a great deal of thought before I program and update it via USB.

    John

    • Developer
      @ John, why are you powering it with a BEC? If it was a genuine 3DR, you would have a power module. It was NEVER designed to run from a BEC on the input. A note to ALL. DO NOT power an APM via the input rail, or the Aux Rail
      Always use the Power Brick, and run your Servo power seperatly.
      • Philip,

        I bought the APM 2.6 from UnmannedTech and it came with just the APM and a couple of jumpers and a 6way lead.

        You need to NOT CONNECT THE RX to 5V ALSO.  That was my problem as nothing else was connected.

         

        Oh well you learn the hard way.  The APM is not designed like other USB connected devices.  You cannot have ANY 5v connected to the APM while you have the USB connected.

        It seems to have fried a track and the two surface mount components next to the USB connector.  This has somehow removed the 3.3V from the MP6000 and baro.  However, everything else seems to work.  I can read inputs and parameters but no Mavlink connection so through the terminal mode only.

        I did not have this problem with the NAZA M?

         

        All the best,

         

        John

         

        • Developer

          If you look at the 3DR store, you will see there is no option of purchasing this without the PM

          3DR Store Link It is disappointing that other suppliers have chosen not to supply this PM as a standard part.

          You can have the system fully connected with the USB connected. while being powered via the Power module. you can have the RX connected while connected to the USB.

          can you please post a picture of your full setup? and also of the burnt out components.

          • Philip,

            Just had it on the bench (anti static and solder station)  connected the RX to set modes rx is powered by and SBEC. 

            Plugged in the USB and used mission planner to connect - no problem.

            You know you are very sensitive to hot components so I unplugged to usb and SBEC

            I then unplugged the RX so just the USB connected..  Connected with the Terminal.. Too late it had burned the track and the MP6000 and Baro would not respond to tests.

            Checked the board and right next to the USB connector two burned components and a very fine track with about a -05inch blob or solder that looked like the track had melted.

             

            So that is where I am.  Two choices:

            Throw it in the bin and write it off to experience (£119)

            Try to fix it?

            I thought I should spend a couple of hours trying to fix it at least.

             

            Regards,

             

            John

             

            • That's bad news John and as I have mentioned previously (maybe here or in other 'burned track' posts) we have had some folk with success.

              Once you have identified the trace (Eagle file link location is down below or now edited in the master post), you will stand a better chance of fixing it.

              If it is just one component busted and the APM responds otherwise you may be OK depending on your application. i.e. a rover would not need barometric reading. Heck, even a multirotor used to fly for fun or FPV does not really need barometric data.

              If you really decide to give the board up, don't totally wreck it but offer it for sale.

              As I mentioned, a rover builder would not care if the barometer is busted.

              -=Doug

  • Hello again!

    Thank You for all the assistance I got, it was really good! Finally, everything is on its place and ready to go. I att. there are things we managed to change, with no significant damages to other chips in arround. D1, D4, low voltage regulator and famous 32u2 ppm encoder. Managed to preflesh with bootloader as well the new .hex required for it. All sensors are ok, firmwares are flashed with no problems.

    The picture in att. is not so good quality, but if You can see, D4 (the zener), is 6.2V, not 6v0 as Posted by R. D. Starwalt This makes a bit worry for me at the moment, since I couldnt get b...

    Thanks again, for this superb thread, hope that other people can benefits also! 

    Sincerely,

    Ivan

    Apm kvar Final.jpg

  • MR60

    Anyone could give me the pinout of the mystery/PM port ?

    Thx

  • I made it! I Did It! With success changed D1, D4 & 32u2 qfn (from beneath the board, without damage to sensors!). Flashed with FLIP 32u2 with appropriate .hex, bootloader also (but still not sure if it is working). Thus might be the reason of MP not connecting with apm2.5, although it sees (windows also) 2560 atmega & 32u2 from usb). It gets timed out, even if 2560 is connected and recognized to com9 (tried also on com port 1, same). Telemetry link also cannot connect with apm2.5, but before 32u2 replacement it could have been connected with 2560 via MP.

    Thats the progress for now, any ideas are appreciated much! And Doug, DevTeam is a good idea, but I am preffering test pilot ;)

  • MR60

    Hello,

    Have a few questions:

    -I will use the attopilot instead of 3DR PM because exceeding the 90amps limits. Could I connect the Voltage and Current lines of attopilot directly to the ADC12 and ADC13 pins of the mystery port ?

    -How to wire the "ground lines" in case I power like so : main battery feeds the ESCs, no ESC BEC connected on the output rail, then a second battery powers APM itself via a Switching BEC @5V on the input rails. I then have two battery sources, each with their ground. Do I simply need to connect the ground of the two batteries together ?

    thx for your insight

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…