APM2 v2.6 / MinimOSD w/ garbage overlay

I posted this initially in the OSD forum, but since I believe this to be specific to ArduCopter v2.6 and the Mavlink 1.0 firmware for MinimOSD I think this might be a better place to get feedback.

Here's the deal:


MinimOSD w/ ArduCAMOSD_19_MAV10.hex

APM2 w/ 2.6

It _sort of_ works...in that it works fine, but in areas where there is NO overlay activity, there are garbage characters overlaid.

When I power up the OSD, at first I get a clear video feed, then as soon as OSD starts to boot, I see this garbage anywhere there isn't OSD generated overlay.  Everything else works fine. 

I've re-updated the firmware, and even tried dumping on the newest .mcm charset I could find, which made no difference.  I'm NTSC but I've tried the settings for both w/ no difference.

I've searched around a bit and can't seem to find any posts about this occuring w/ other folks.




You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I've seen Sandro mention this happens when you program the char set on USB power. There is not enough juice to program correctly. 

This reply was deleted.