Developer

ArduCopter 2.7.1 Released

ArduCopter 2.7.1 will become available on Mission Planner and in the downloads area shortly. This release contains a few important bug fixes as well as the first implementation of the MPU6000 sensor-fusion code. 

Detailed changes are in the commit log. Here's a summary:

New:

- Preliminary support for MPU6000 on board sensor-fusion (DMP)

- AP_Limits: Experimental "bounce" mode, for smaller spaces (LIM_RECMODE)

Bugs:

- Bug fix for yaw error buildup on takeoff

- Fix in Auto mode for failsafe handling

- Fixes to 3-axis camera gimbal code

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Can someone shed some light please.

    Where can i find the #defines to change to 0.9 MAV ?

    My ODS units shipped with 0.9 and I dont have a AVR programmer... annoying

    Thanks

  • ArduCopter 2.7.2 releaset

    available on Mission Planner and in the downloads area.

    The official 2.7.2 release of ArduCopter  Functional Improvements: 
    -fast waypoints if the turn angle between two waypoint the copter is less than 60 degrees it does not slow down (Jason) -navigation improvements and logging including switching to filtered location for distance calculations (Jason) -flip improvements - more aggressive and flexible flip code based on attitude instead of timing (Jason) -improved camera control - you can now control any axis (roll, tilt, pan) with any rc channel. it probably makes most sense that you will use 6 but others are possible. (Amilcar) -flybar acro mode for TradHeli (Robert) -"fast gains" - allows strong correction of attitude using accelerometers while the quad is stationary on the ground but relies more on gyros while flying. (Tridge, Jason) -baro filtering improvements (Tridge) Bug Fixes: -dmp timing fix - the MPU6000's dmp unit was inadvertantly turned on and caused timing delays in the main loop (Randy) -xbee bricking issue (Craig / Tridge) -dataflash fixes (Jason) -engine ticking - was combination of roll/pitch rate D term being too high and the dmp timing fix above (Randy, Emile) -faster compass heading on start-up - resolves issue with simple mode getting incorrect heading if you took off very soon after start-up (Tridge) Code Cleanup: -increased maximum number parameters (Tridge) -formatting changes to code (Pat) -replaced "int" with "int16_t" everywhere (Randy)

     

  • Not finding GeoFence GUI.  Running Mission Planner 1.2.10 and 2.7.1 for the life of me I cannot find any GeoFence options anywhere in the GUI.  What am I missing?

  • Try the following: power the APM2 via USB, point it to N (0), connect the Mission Planer Flight Data and see what happens.  The display starts with 150  (almost opposite direction) and slowly drifts to smaller values.

    Wait a few seconds until it shows about 130 and then press disconnect, and connect again.

    The display starts again with 150  and slowly drifts to smaller values.

    thats odd!!

    Then connect to [Terminal Test Compass] und see the reading is still ok N (0) not drifting.

  • Compass behaves odd.

     

    APM2.0;  ArduCopter 2.7.1 traditional Heli; Mission Planer 1.2.10

     

    APM is powered via the USB all the time.

     

    I made 2 lines on the table, one  N –- S  and one   E --- W.

    I’ll places the Heli along these lines to check the compass readouts.

    The first ones are with the Mission Planer [Terminal Test Compass]

    The second are in the Flight Data Tab of the Mission Planer.

     

    I’m sure there is no problem with the hardware (sensors) because the readings in the  

    [Terminal Test Compass] are correct.

     

    I could easy find my way home with the [Terminal Test Compass] readouts,

    but would get lost with the Flight Data Tab readouts of the Mission Planer.

     

    Could someone help me please.

  • If some one is using 2.7.1 on APM1 (1280) which features you has switched off? I am trying to fit 2.7.1 to my APM1 but still  no luck....

    Thanks

  • I see three versions of 2.7.2 on the downloads section.  Where can I go again to see exactly what which version is for? Thnx,

  • Developer

    ArduCopter V2.7.2, the final release is coming, stay tuned:

    This is my flight n.150 during test with 2.7.2 beta/alpha/gamma/epsilon, etc...
    No issue, it's a pleasure, also in Acro mode, small problems have been reported and are being being worked on.
    I think that most of the big problems that some users are having are caused by defective components, setup wrong or incorrect tuning.
    If the problems were within the code would live during the innumerable tests that we do.
    There is always something to fix or improve, but I'd say we're at a good point.

    Bests, Marco

  • hey guys I need some help with SITL..... My quadcopter is not taking off... when i run the simulation the alt is remaining 0 and the it is yawing a lot...... other than yawing it is not doing anything.... can someone help urgent!!

  • This is best version so far, so big thx to Jason and other involved!!

     RTL and Loiter is much more accurate than was in 2.6, specially when there's wind and gust. Today i did few RTL's from different compass points and all went almost perfectly. Loiter seems to be basically same as accuracy of gps. In loiter I have some wobbles or "twitchy" feeling, same as some others have reported. I checked logs and it looks that NavLat gets high quickly when gps position changes 1-2m fast and this usually trigger short 4-6 degree roll or tilt correction "burst". Mostly this seems to be in Latitude direction, which is somehow weird..

    One thing i noticed is that gps track in logs are no so smooth anymore. Also bigger error or roughness always seems to be in latitude direction same as loiter wobble. Is lat and long in log directly from MTK gps nmea or is it processed somehow with gps algoritm and lag estimation??

    Other thing is how i get camera gimbal outputs to work? I have apm 1 and tried output 5&6 without succeed, was ok in 2.6...

    Tomorrow some Auto with waypoints.....:)

    Regards Jani

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…