Developer

ArduCopter 2.7 Released!

 

In just a short while, ArduCopter 2.7 will become available for download in Mission Planner. As we worked on ArduCopter 2.6.1, we saw that it had several new and compelling features (as well as many bug fixes and improvement) so it was decided to make this a major version release. 

A full list of changes is here, but they include:

 

New and Improved:

  • NEW: 3-axis camera stabilization
  • NEW: AP_Limits library: Altitude limits and geofencing.
  • NEW: Automatic Flip (Roll axis) is now enabled on Channel 
  • NEW: GPS lag estimator
  • NEW: the quad first rise vertically to the "ALT_HOLD_RTL" altitude (if declared) when engage RTL
  • Better altitude control in ALT_HOLD and better altitude transitions
  • Better loiter, rtl and auto missions, especially with the new 3DR uBlox GPS. Check out my video above!
  • Better yaw control
  • Better DCM implementation, resulting in noticeably smoother flight
  • Better velocity control in Auto missions
  • Etc

Bugfixes:

  • Fix to dataflash erasing, which should resolve an issue some users were having
  • Fix some MAVLink commands
  • Fix Circle command
  • Fix some units
  • Etc

Notes:

No more 1280 support (out of program space)
Know issue:
- throttle stick during loiter need better rpm range

Cheers,
Marco

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Sorry to re-post this here but I really need some help with this

    http://diydrones.com/forum/topics/xbee-adaptore-wont-talk-to-xbee-m...

    I have a new Xbee pro adapter from Jdrones I am having trouble to work withe the Xbee pro XBP09-DP module.

    I know its not the module that is the issue because I have another adapter that the module works fine with. I have tried both the baud 57600 and the 9600 but I always get the popup instruction to push the rested button. Ive tried the reset using a jumper to connect the GRD and RESET on the adapter board but nothing happens.

    I have followed the instruction in wiki how to reset/unbrick the adapter and module to reset the firmware. But nothing works.

    I am using the FDTI cable. When I plug this in I get a blue LED on right top side of the adapter that lights up which seems normal compared to my working Xbees. When I open X-CTU and click Test/Query a green LED to the top left of the adapter blinks for a few seconds and then goes solid green when the "Action Required" box pops up. When I close the popup box the green LED goes off. That's as far as I can get it to go.

    Ive tried to upload the firmware from my other Xbees, but nothing works because the X-CTU cant communicate with this adapter. Any idea why this isn't working and how to reset the adapter (not the module)? Note, this all works fine using the FTDI cable on my other two Xbees.

  • I am setting up the optic sensor and like to know what is the angle width of the lens. I am fixing it to a leg strut at 200mm from the ground. The bottom leg cross been is about 100mm of to the side where the optic sensors center focus point hits the ground. Will this leg strut interfere with the sensor and be in its field of view? Also does the optic sensor work together with the sonar?

  • My new Xbee Adapter wont talk to Xbee module. Can someone please help?

    http://diydrones.com/forum/topics/xbee-adaptore-wont-talk-to-xbee-m...

  • After yesterdays update I did a erase/reset/reload to 2.7. 1  APM2.0 MP 1.2.1

    did the set up calibrated the radio etc 

    went out for a test and can not get the quad to arm 

    New update today so I did it all again same problem rechecked everything 

    I have not had any problems setting up my other quad and Y6 that also have APM2.0 but older firmware versions

    After this last update APM took more than 5 min for the blue lite to stop flashing after the gps had solid blue

  • Last night I was flying my quad to drain the packs after crashing my heli again.  I've got the Ublox GPS on it, but I noticed the Loiter and RTL performance was really quite bad.  Error of... at least 20 feet.  Previously I've had the rock solid performance we've come to expect from the Ublox. When I got in, I checked the space weather, and apparently it's fairly stormy up there.

    So is this type of performance to be expected when there is high solar activity?  Or is something else going on?

    Right off the start I noticed that it had taken a long time, maybe 15-30 seconds to get a lock, which is unusual for the Ublox.

  • I see its now gone to 2.7.1. What issues were fixed in this revision?

  • Hello
    I have a problem in the APM1. In firmware 2.7 reversed the tilt axis of gimbal. On the 5th exit (Pitch) Servo reacts to the deviation of the axis Roll. And on channel 6 (Roll) Servo reacts to the deviation Pitch. In firmware 2.6 all fine. In what may be the problem? Thank you.

  • The last weeks I was chasing vibrations on my T-Rex 450, new Bearings, new flybarles head....to get the vibration down as much as possible. But still there are some, (you can’t totally avoid vibration on a Heli) so I tried to isolate the vibrations to the APM2.5 with different padding’s, in the case, without the case, different locations, but with not much success. Still always less or worse attitude drifts (in some case unflyable, nearly lost the Heli twice)  . The only way to minimise this attitude drifts was through change of head-speed quite below my favourite 3100rpm to around 2700rpm.

    It’s now flyable but still small drifts, which negatively influences all other flight modes. :-(

    I think this is much more obvious on a flybarles T-Rex450 then on a quad, as one mentioned if you going from a quad to a T-Rex450 it’s like going from driving a bus to a super bike, the T-Rex450 is much more reactive.

     

    I’m sure it’s about the relationship between sensor sample frequency and vibration frequency, aliasing.

    Is there any way to increase the sample frequency?

     

    Speaking of drifts, since I upgraded to ArduCopter 2.7  I noticed also a Compass drift. After replying the log of my 1. test flight, I realized the heli was pointing about 90degr. too much to the left.

    I placed the heli on the table pointing SW. If I turn the heli by hand to the right to NW and back to SW, the compass ticks slowly past SW to almost S and then stops. If I do the same procedure the other way round,  SW to SE and back to SW, the compass drifts slowly past SW to W and then stops.

    There are two different headings depending which direction I turned before stopping.

    There was nothing obvious before the 2.7 upgrade.

    Any suggestion please?

  • Hi guys,

    I noticed something when I was tuning my quad for alt hold and loiter in ver. 2.7.

    When I tuned the alt hold and alt throttle parameter away from the default settings, alt hold - 0.4 alt throttle - 0.31, alt hold is stable, but when I switched on Loiter the quad started to bounce. When I reverted to the default settings alt hold - 0.3. Alt throttle - 0.3 Loiter seems to hold altitude better. Is the altitude hold in Loiter now different? It used to be the same in previous versions.
  • Bonjour, je suis nouveau je m'apelle atus et merci d'avance

    J'ai problemes en mettant la mise a jour version 2.4 vers 2.7 je n'arrive pas a prendre la main sur mon APM1

                              impossible de controle le setup pour par exemple controle les moteurs

                                il bip  , n'y controle les donnees avec ma DX8 pourtant je suis bien detecte

                             vous avez change une partie de la communication qui ne me permet plus de me servir

                                du programme HK LIVE en 3D pour controle mes mission

     

    Hello, I'm new my name ATUS and thank you in advance
    I have problems putting the update version 2.4 to 2.7 I can not take a hand on my apM1

                               impossible to control the setup for example control the motors

                                 it beeps, no control of the data with my DX8 yet I am well detected

                              you change one part of the communication which no longer allows me to serve me

                                 HK LIVE program in 3D to control my Mission

                             If the system is not compatible reconnaisant I would be able to have version 2.4 has new

                                  in the update because I had my desaroi can not go backward

                                                                   I am French and a bit lost please let me escuse

                                                                                                             Thank you in advance

                            Si le system n'est pas compatible je vous serais reconnaisant de pouvoir avoir la version 2.4 a nouveau

                                 dans la mise a jour parce que a mon desaroi je ne peut plus revenir en arriere

                                                                  je suis francais et un peut perdu veuillez m'en escuse

                                                                                                            Merci d'avance

     

This reply was deleted.

Activity

DIY Robocars via Twitter
22 hours ago
DIY Robocars via Twitter
RT @SahikaGenc: AWS DeepRacer & Hot Wheels Track https://youtu.be/4H0Ei07RdR4 via @YouTube
Sep 14
DIY Robocars via Twitter
Sep 8
DIY Robocars via Twitter
RT @davsca1: We are releasing the code of our Fisher Information Field, the first dedicated map for perception-aware planning that is >10x…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: How this works: 1)object detection to find cones in single camera image, 30 frames/sec on @NVIDIAEmbedded Xavier. 2)comp…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: Use two color cones to guide the robocar. No map needed, on onsite training needed. Just place the cones and it will fol…
Sep 7
DIY Robocars via Twitter
Sep 7
DIY Robocars via Twitter
RT @roboton_io: Great to see http://roboton.io running at 60fps on the cheapest #chromebook we could find! #edtech #robotics #educat…
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Crazy in-depth article about using the OpenMV Cam for Astrophotography: https://github.com/frank26080115/OpemMV-Astrophotography-Gear https://t.co/BPoK9QDEwS
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Hi folks, it's finally here! Our first draft of our Arduino Interface Library is out! It works over SoftwareSerial, Hardware…
Sep 3
DIY Robocars via Twitter
RT @chr1sa: Please let them have an open API. This would be perfect for @DIYRobocars races https://twitter.com/NintendoAmerica/status/1301513099707658246
Sep 3
DIY Robocars via Twitter
RT @SmallpixelCar: Lanenet pretty much used all my GPU power on @NVIDIAEmbedded Xavier since I optimized with tensorRT. I need to run anoth…
Sep 3
xemone liked Max Gilson's profile
Aug 31
DIY Robocars via Twitter
RT @LyftLevel5: Our @kaggle competition on Motion Prediction for Autonomous Vehicles is now live! Experiment with the largest-ever self-dri…
Aug 24
DIY Robocars via Twitter
RT @chr1sa: Our next @DIYRobocars virtual AI car race will be on Sept 26th. Sign up here https://www.meetup.com/DIYRobocars/events/272786977/ https://t.co/UENKGSOWO8
Aug 24
DIY Robocars via Twitter
New ready-to-run @NVIDIAEmbedded JetRacer car from Waveshare. Perfect for the next @diyrobocars race as soon as we… https://twitter.com/i/web/status/1297960223013867520
Aug 24
More…