Developer

ArduCopter 2.7 Released!

 

In just a short while, ArduCopter 2.7 will become available for download in Mission Planner. As we worked on ArduCopter 2.6.1, we saw that it had several new and compelling features (as well as many bug fixes and improvement) so it was decided to make this a major version release. 

A full list of changes is here, but they include:

 

New and Improved:

  • NEW: 3-axis camera stabilization
  • NEW: AP_Limits library: Altitude limits and geofencing.
  • NEW: Automatic Flip (Roll axis) is now enabled on Channel 
  • NEW: GPS lag estimator
  • NEW: the quad first rise vertically to the "ALT_HOLD_RTL" altitude (if declared) when engage RTL
  • Better altitude control in ALT_HOLD and better altitude transitions
  • Better loiter, rtl and auto missions, especially with the new 3DR uBlox GPS. Check out my video above!
  • Better yaw control
  • Better DCM implementation, resulting in noticeably smoother flight
  • Better velocity control in Auto missions
  • Etc

Bugfixes:

  • Fix to dataflash erasing, which should resolve an issue some users were having
  • Fix some MAVLink commands
  • Fix Circle command
  • Fix some units
  • Etc

Notes:

No more 1280 support (out of program space)
Know issue:
- throttle stick during loiter need better rpm range

Cheers,
Marco

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Sorry to re-post this here but I really need some help with this

    http://diydrones.com/forum/topics/xbee-adaptore-wont-talk-to-xbee-m...

    I have a new Xbee pro adapter from Jdrones I am having trouble to work withe the Xbee pro XBP09-DP module.

    I know its not the module that is the issue because I have another adapter that the module works fine with. I have tried both the baud 57600 and the 9600 but I always get the popup instruction to push the rested button. Ive tried the reset using a jumper to connect the GRD and RESET on the adapter board but nothing happens.

    I have followed the instruction in wiki how to reset/unbrick the adapter and module to reset the firmware. But nothing works.

    I am using the FDTI cable. When I plug this in I get a blue LED on right top side of the adapter that lights up which seems normal compared to my working Xbees. When I open X-CTU and click Test/Query a green LED to the top left of the adapter blinks for a few seconds and then goes solid green when the "Action Required" box pops up. When I close the popup box the green LED goes off. That's as far as I can get it to go.

    Ive tried to upload the firmware from my other Xbees, but nothing works because the X-CTU cant communicate with this adapter. Any idea why this isn't working and how to reset the adapter (not the module)? Note, this all works fine using the FTDI cable on my other two Xbees.

  • I am setting up the optic sensor and like to know what is the angle width of the lens. I am fixing it to a leg strut at 200mm from the ground. The bottom leg cross been is about 100mm of to the side where the optic sensors center focus point hits the ground. Will this leg strut interfere with the sensor and be in its field of view? Also does the optic sensor work together with the sonar?

  • My new Xbee Adapter wont talk to Xbee module. Can someone please help?

    http://diydrones.com/forum/topics/xbee-adaptore-wont-talk-to-xbee-m...

  • After yesterdays update I did a erase/reset/reload to 2.7. 1  APM2.0 MP 1.2.1

    did the set up calibrated the radio etc 

    went out for a test and can not get the quad to arm 

    New update today so I did it all again same problem rechecked everything 

    I have not had any problems setting up my other quad and Y6 that also have APM2.0 but older firmware versions

    After this last update APM took more than 5 min for the blue lite to stop flashing after the gps had solid blue

  • Last night I was flying my quad to drain the packs after crashing my heli again.  I've got the Ublox GPS on it, but I noticed the Loiter and RTL performance was really quite bad.  Error of... at least 20 feet.  Previously I've had the rock solid performance we've come to expect from the Ublox. When I got in, I checked the space weather, and apparently it's fairly stormy up there.

    So is this type of performance to be expected when there is high solar activity?  Or is something else going on?

    Right off the start I noticed that it had taken a long time, maybe 15-30 seconds to get a lock, which is unusual for the Ublox.

  • I see its now gone to 2.7.1. What issues were fixed in this revision?

  • Hello
    I have a problem in the APM1. In firmware 2.7 reversed the tilt axis of gimbal. On the 5th exit (Pitch) Servo reacts to the deviation of the axis Roll. And on channel 6 (Roll) Servo reacts to the deviation Pitch. In firmware 2.6 all fine. In what may be the problem? Thank you.

  • The last weeks I was chasing vibrations on my T-Rex 450, new Bearings, new flybarles head....to get the vibration down as much as possible. But still there are some, (you can’t totally avoid vibration on a Heli) so I tried to isolate the vibrations to the APM2.5 with different padding’s, in the case, without the case, different locations, but with not much success. Still always less or worse attitude drifts (in some case unflyable, nearly lost the Heli twice)  . The only way to minimise this attitude drifts was through change of head-speed quite below my favourite 3100rpm to around 2700rpm.

    It’s now flyable but still small drifts, which negatively influences all other flight modes. :-(

    I think this is much more obvious on a flybarles T-Rex450 then on a quad, as one mentioned if you going from a quad to a T-Rex450 it’s like going from driving a bus to a super bike, the T-Rex450 is much more reactive.

     

    I’m sure it’s about the relationship between sensor sample frequency and vibration frequency, aliasing.

    Is there any way to increase the sample frequency?

     

    Speaking of drifts, since I upgraded to ArduCopter 2.7  I noticed also a Compass drift. After replying the log of my 1. test flight, I realized the heli was pointing about 90degr. too much to the left.

    I placed the heli on the table pointing SW. If I turn the heli by hand to the right to NW and back to SW, the compass ticks slowly past SW to almost S and then stops. If I do the same procedure the other way round,  SW to SE and back to SW, the compass drifts slowly past SW to W and then stops.

    There are two different headings depending which direction I turned before stopping.

    There was nothing obvious before the 2.7 upgrade.

    Any suggestion please?

  • Hi guys,

    I noticed something when I was tuning my quad for alt hold and loiter in ver. 2.7.

    When I tuned the alt hold and alt throttle parameter away from the default settings, alt hold - 0.4 alt throttle - 0.31, alt hold is stable, but when I switched on Loiter the quad started to bounce. When I reverted to the default settings alt hold - 0.3. Alt throttle - 0.3 Loiter seems to hold altitude better. Is the altitude hold in Loiter now different? It used to be the same in previous versions.
  • Bonjour, je suis nouveau je m'apelle atus et merci d'avance

    J'ai problemes en mettant la mise a jour version 2.4 vers 2.7 je n'arrive pas a prendre la main sur mon APM1

                              impossible de controle le setup pour par exemple controle les moteurs

                                il bip  , n'y controle les donnees avec ma DX8 pourtant je suis bien detecte

                             vous avez change une partie de la communication qui ne me permet plus de me servir

                                du programme HK LIVE en 3D pour controle mes mission

     

    Hello, I'm new my name ATUS and thank you in advance
    I have problems putting the update version 2.4 to 2.7 I can not take a hand on my apM1

                               impossible to control the setup for example control the motors

                                 it beeps, no control of the data with my DX8 yet I am well detected

                              you change one part of the communication which no longer allows me to serve me

                                 HK LIVE program in 3D to control my Mission

                             If the system is not compatible reconnaisant I would be able to have version 2.4 has new

                                  in the update because I had my desaroi can not go backward

                                                                   I am French and a bit lost please let me escuse

                                                                                                             Thank you in advance

                            Si le system n'est pas compatible je vous serais reconnaisant de pouvoir avoir la version 2.4 a nouveau

                                 dans la mise a jour parce que a mon desaroi je ne peut plus revenir en arriere

                                                                  je suis francais et un peut perdu veuillez m'en escuse

                                                                                                            Merci d'avance

     

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Saturday
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
More…