ArduCopter 2.7 Released!


In just a short while, ArduCopter 2.7 will become available for download in Mission Planner. As we worked on ArduCopter 2.6.1, we saw that it had several new and compelling features (as well as many bug fixes and improvement) so it was decided to make this a major version release. 

A full list of changes is here, but they include:


New and Improved:

  • NEW: 3-axis camera stabilization
  • NEW: AP_Limits library: Altitude limits and geofencing.
  • NEW: Automatic Flip (Roll axis) is now enabled on Channel 
  • NEW: GPS lag estimator
  • NEW: the quad first rise vertically to the "ALT_HOLD_RTL" altitude (if declared) when engage RTL
  • Better altitude control in ALT_HOLD and better altitude transitions
  • Better loiter, rtl and auto missions, especially with the new 3DR uBlox GPS. Check out my video above!
  • Better yaw control
  • Better DCM implementation, resulting in noticeably smoother flight
  • Better velocity control in Auto missions
  • Etc


  • Fix to dataflash erasing, which should resolve an issue some users were having
  • Fix some MAVLink commands
  • Fix Circle command
  • Fix some units
  • Etc


No more 1280 support (out of program space)
Know issue:
- throttle stick during loiter need better rpm range


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi All,

    Please help. I have a problem on updating v2.7

    on mavlink 1.0


    on mavlink 0.9

    391232_3956308459715_1750914023_n.jpgIt happen since I update the MP

    thank you,


  • I've found on my tri, that after arming if I increase throttle, the tail servo will start to lean over to the right hand side until it is all the way over. As soon as I give any yaw input, it will return to center and behave normally.

  • 2.7 rocks! I am able to max out the PIDs' for ultra rigid flying, but i am also able to turn them down for a more docile flight with AP gear.  Wasn't able to do this on earlier version.  I am only having one problem though.  Every time I swap out batteries and reboot my APM2 the HUD shows that the copter is leaning to the left several degrees.  As you would expect, when I lift off it rolls hard right to correct.  I have leveled several  times, and auto trim has no effect.  I uploaded the firmware through the IDE and Planner with same effect.  I have even tried two other boards.  Weird.  I am very familiar with the setup process, but this is puzzling.  Currently I am leveling the accels in the planner via wireless telemetry before each flight.  Just wandering if any of the vets here have any ideas before I make an issue.  

    Screen shots of last two initializations                                                                                            


  • Copied over from the blogpost - sorry didn't see the announcement fo this discussion. Attention problem, I guess ;-)

    Regarding the Gimbal control discussion started in the Blog

    Bit more detail about the servos:

    Generally analogue servos are controlled by giving them a new setpoint at 50 Hz (as mentioned) with the usual 1000-2000us PWM scheme

    "Digital" standard servos accept setpoints at a higher frequency still with the approx. 1000-2000us modulation - there is no real standard but if data is given, I have seen <=333Hz at least with Align, Savox (identical for the most part), MKS, Hitec.

    As mentioned, 490 Hz is the practical limit for this modulation.

    "Digital narrowband" uses a different modulation: 760 us as servo center which gets you past the 500Hz, 560 Hz framerate seems to be typical (again, no real standard here). These servos are usually dedicated tail-control servos for helis.

    Operating a servo with too high a framrate leads to signal aliasing and typically smokes the servo as it may be getting forbidden positions and try to get there, destroying itself in the process, but for sure will never rest and just cook its motor and consume lots of power. An indication to this is "singing" or "growling" when the servo really gets a constant input.

    So when programming this, please keep in mind that actual servos might need a different refresh rate from ESCs.

    Regards, Otto

  • @Rui Manuel: I had the same problem. Solved in arduino-1.0.1 to use   arduino\hardware\tools\avr\bin\avrdude.exe and arduino\hardware\tools\avr\etc\avrdude.conf  files from arduino-0022-relaxpatch. That works for me.

  • 100KM

    So the APM1 1280 is now no longer usable :(

    Would it be a good idea to maintain a 1280 version, without things like geofencing but still including the latest bugfixes and performance enhancements ?

    I guess that won't be easy due to the library structure now being used.  Don't think geofencing can easily be turned off, right ?

  • Hi. I would like to know if anyone is having problems uploading AC 2.7 with arduino. If I use version 0022 relaxpatch windows, I get the attached screen error (for version 2.7), but version 2.6 uploads well, if I use version 0100 relaxpatch it doesn't work either with AC 2.6 nor AC 2.7, (same thing with version 0101), same issue, it compile well but doesn't upload, it just says it's uploading but the board leds don't flash, and the board it's configured for a 2560 or mega adk in port 17 (the port I'm using).

    If I'm doing anything wrong please let me know. (I'm using APM1 2560+oilpan)

    Thank you.

  • Developer

    Explanations about AutoApproach value, AutoLand and the "new safe RTL" in 2.7":

    - when engage RTL the quad first rise vertically to the "ALT_HOLD_RTL" value (altitude in meters), only once it has reached it starts to move to the home, very useful if the quad we lost sight behind a barrier away, or to avoid obstacles in flight during RTL. If this parameter is "0" the quad reaches the home at the altitude when you engage RTL

    - if "RTL_APPROACH_ALT" is "0" the quad autoland at home, but if it has a value in centimeters like "800" (8 meters) the quad once it has reached the home begins to descend gradually and once it reaches that approach height gets in "infinite Loiter", waiting for your input, very useful for very large quad, where the auto-land is always risky, or simply to have the possibility to bring the quad in "front of the eyes" by simply pulling on a switch (for newbie)

    - "RTL_LAND" is still on the list of parameters, but is no longer used, disabled

    I hope you enjoy these "safety" features, because I bored the dev team because they were developed properly.... :P

    Bests, Marco

  • @Marco: After board reset and reconnection sensors work fine. Checked.

    But MP behaviour is the same.

  • Can I use the V2.6 parameters or does V2.7 have new defaults?

This reply was deleted.