In just a short while, ArduCopter 2.7 will become available for download in Mission Planner. As we worked on ArduCopter 2.6.1, we saw that it had several new and compelling features (as well as many bug fixes and improvement) so it was decided to make this a major version release. 

A full list of changes is here, but they include:

 

New and Improved:

  • NEW: 3-axis camera stabilization
  • NEW: AP_Limits library: Altitude limits and geofencing.
  • NEW: Automatic Flip (Roll axis) is now enabled on Channel 
  • NEW: GPS lag estimator
  • NEW: the quad first rise vertically to the "ALT_HOLD_RTL" altitude (if declared) when engage RTL
  • Better altitude control in ALT_HOLD and better altitude transitions
  • Better loiter, rtl and auto missions, especially with the new 3DR uBlox GPS. Check out my video above!
  • Better yaw control
  • Better DCM implementation, resulting in noticeably smoother flight
  • Better velocity control in Auto missions
  • Etc

Bugfixes:

  • Fix to dataflash erasing, which should resolve an issue some users were having
  • Fix some MAVLink commands
  • Fix Circle command
  • Fix some units
  • Etc

Notes:

No more 1280 support (out of program space)
Know issue:
- throttle stick during loiter need better rpm range

Cheers,
Marco

Views: 16349

Reply to This

Replies to This Discussion

My quad is home-made and don't conform directly to the diy drones standard model. But either by luck or good fortune, each progressive arducopter FW upgrade has resulted in better (more accurate) loiter.
This is with the default GPS module! There is some variation in accuracy observed from time to time which I put down to more or less satellites aquired affecting performance. Maybe the current solar activity and other atmospheric conditions is responsible.

Since fitting the UBlox gps, it's been constant blustery winds, just waiting for it to calm down, to do some testing.

nothing fixes the pitch and roll mixup in mine... i follow the parameters list changes, tried with yaw at 1 or 0 and it still mixes the axes... I am clueless

After yesterdays update I did a erase/reset/reload to 2.7. 1  APM2.0 MP 1.2.1

did the set up calibrated the radio etc 

went out for a test and can not get the quad to arm 

New update today so I did it all again same problem rechecked everything 

I have not had any problems setting up my other quad and Y6 that also have APM2.0 but older firmware versions

After this last update APM took more than 5 min for the blue lite to stop flashing after the gps had solid blue

Esteban, when you change MNT_STAB_YAW in the Parameter List to 0 and write parameters, move the copter around and let us know how it reacts immediately after doing that.

After changing the MNT_STAB_YAW parameter to 0 - do NOT go back to the Geo Fence menu again. If you do, it will flip the parameter back to 1 again. If for some reason you do have to go back there, finish up by then going back to parameters and flip it back again.  Better yet, until it gets fixed, make all of your Geo Fence parameter changes in the parameters menu. Don't forget to hit write parameters after entering all of your changes.

I'm not touching geo fence. Do you mean Camera Gimbal?

Yup - I did mean camera gimbal. My bad!  I've been playing with GeoFence and forgot to shift gears. Sorry.

It could be happening when going into geo fence as well. However,  I've noticed it soon after going into camera gimbal.

Hello Milay! Thank you for replying and helping out.

When I change MNT_STAB_YAW to 0 nothing happens. I tried combining this change with CAM_Y_FUNCTION to 0 or to 1 but nothing changed.

Another observation: If I disconnect any of the two channels, leaving only one connected, this channel works fine. As soon as I connect the second channel back, they get crossed. This way, I'm never able to get pitch and roll right, they are always mixed.

I hope I explain myself good enough: I have ch5 connected to pitch and ch6 connected to roll. If I disconnect ch6, the pitch servo moves responding to pitch, which is right. As soon as I connect ch6 they get mixed. It's as if the problem comes when I connect both channels at the same time. Both channels run fine by themselves.

I noticed this same issue as soon as I went to 2.7.  It took an erase and reset.  Then I reloaded 2.7 and all worked perfect.  Give this a try and reapply your parameters and hopefully you will be rockin'!!!

i tried that twice.....

The GPS's blue light will go solid after it gets a 2D lock.  The APM2 will only make it's blue light solid after a 3D lock.  Because the APM did eventually get a lock that just means that the GPS took a really long time to get enough satellites to get the full 3D lock.  The APM is almost completely passive with respect to the GPS (ie.. it just receives data from teh GPS) so very unlikely to be any thing to do with the core APM software...maybe something else in the environment has changed that is giving the GPS trouble.

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service