ArduCopter 2.9 / 2.9.1 released

ACRO bug (fixed in 2.9.1b): while doing flips in ACRO mode, if you switch to Stabilize while inverted your throttle will go to minimum.  To regain throttle control you need to switch back to ACRO then back to Stabilize again (i.e. switch to stabilize twice).  You never lose control of roll/pitch/yaw.

Loiter/AltHold/Auto/RTL bug: if you switch into these modes with throttle at zero motors will go to minimum until you raise the throttle.

Auto mode altitude bug (fixed in 2.9.1b): setting a waypoint altitude greater than 320m over home altitude may wrap around and instead be interpreted as a low altitude.

ArduCopter 2.9 is now in the mission planner and the downloads area!

The major improvement is we use inertial navigation to improve altitude hold.  This increased reliance on the accelerometers means you must do some additional set-up before flying:

1. Perform the new accelerometer calibration in the mission planner (video).  The auto-trim metho has also changed (video).


2. Add vibration dampening foam between your frame and the APM.  Some suggested materials: DuBrogelhk foam.


 3. If upgrading from 2.8.1, modify the throttle and altitude PID values:

  • Increase your Throttle Rate P, reduce I to zero, increase D
  • Increase Altitude Hold P, reduce I to zero
  • Tune Throttle Accel P and I terms but try to keep P about 1/2 the size of I



Here is the list of major changes (a more detailed list can be found in the release notes):  

  • Alt hold using inertial navigation (Leonard, Randy, Jonathan)
    • AUTO_VELZ_MIN, AUTO_VELZ_MAX parameters control the max climb/descent rate for the autopilot (cm/s)
    • PILOT_VELZ_MAX controls max climb/descent rate for the pilot (in cm/s)
  • Landing improvements (Leonard/Randy).  Copter will descend to 10m or until an object is sensed with the sonar.  Then slows to 50cm/s descent (speed can be adjusted with LAND_SPEED parameter). (video).
  • Surface tracking with sonar (Randy/Leonard).  Copter will attempt to maintain current distance from objects in front of sonar regardless of altitude.  Only used in alt-hold and loiter, not used for missions.  Sonar can be enabled/disabled with CH7 switch. (video)
  • Failsafe improvements (Randy/Craig/John Arne Birkeland) including bug fixes, additional check for PPM encoder failure and implementation of battery failsafe.  Set-up instructions are here.
  • Mediatek gps driver accuracy improvements and use of SBAS [Craig].  Instructions on upgrading your mediatek to firmware 1.9 are here.
  • Traditional Heli improvements (Rob) including (a) bringing heli code back into the fold, (b) enabled rate controller (previously only used angle controllers). (c) fix to rotor speed controllers - now operates by switching off channel 8.  (d) allow wider collective pitch range in acro and alt hold modes vs stabilize mode  (e) bug fix to allow collective pitch to use the entire range of servos
  • Acro trainer (Leonard). Copter will return to be generally upright if you release the sticks in acro mode.
    • ACRO_TRAINER : set to 1 to enable the auto-bring-upright feature
    • ACRO_BAL_ROLL, ACRO_BAL_PITCH : controls rate at which roll returns to level
  • Camera control improvements (Randy/Sandro Benigno):  (a) AP_Relay enabled for APM2  (b) Trigger camera with CH7 or DO_DIGICAM_CONTROL command  (c) Allow pilot override of yaw during missions and fixed CONDITIONAL_YAW command.
  • PPM sum support for transmitters with as few as 5 channels (Randy/Tridge/John Arne Birkeland).
  • Performance and memory useage improvements (Tridge).


As per usual PIDs are optimised for the 3DR/jDrones quad with 850 motors and 10" props. If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

Special thanks to our testing team lead Marco and the dedicated bunch on the 2.8.1 release thread who put their copters at risk while testing the pre-release version.  Some of their videos are here: 1 2 3 4 5 6 7 8

Please feel free to report issues you find in the discussion below and/or add them to the issues list.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Suggestion for Auto mission planner.

    'Rotate L/R at given rate.

    Just do a 360. Good for filming.

    If loiter turns worked perhaps could use that with zero radius but I dont think rate is adjustable and it dosent work anyway - for me.


    Unless its already there by another name in the camera bits?



  • Guys which log file do you need to provide you to analyze my flight ?

  • Just to be interesting. I have another issue. Had successful missions the previous day but on Saturday things went wrong,

    Was flying the mission and the quad started climbing in altitude and then started to come down. It kept coming down into the ground. Looking at the logs I see it way overshot the target alt but then Im not sure what happened.

    Can I trouble someone to take a look and comment. Not sure if its a fault or something else. 

    2013-02-09 08-46-36.rlog

  • Graham pointed out that his quad gains elevation after the second time he uses loiter. I tried to recreate it today, but it was so windy I had my hands full and could not do a good job with it. But it did climb until it tried to switch from sonar to baro, then it gets jumpy and scarey and I switched out of loiter.

    So I backed up to yesterdays logs and here is what I found. Note that I generally don't go in and out of loiter so much, but I was trying to fly under and around trees in the yard, and I kept moving over grass, then cement, then over a dirt patch etc. It always got worse. Here's some pix and logs. 

    Looking good, altitude stays pretty tight in loiter #1.


    Not bad, but maybe a little trend in Loiter #2.3692618343?profile=original

    Loiter #3 heads up, Loiter #4 heads up too. 3692618274?profile=original

    Loiter #5 and #6 Going Up! I counter act with the throttle, but it was steady going into loiter.3692618415?profile=original

    Loiter 7, 8 ,9, up up up.3692618287?profile=original

    Loiter 10. If anything it's even more aggressive. 3692618382?profile=original

    I know this isn't a lot of climbing, I couldn't afford it under the trees though. Maybe if I just sent it up high enough it would have settled.

    2013-02-09 16-45 16.log

    2013-02-09 16-06-01.tlog

  • Hi All. I flew a 3 WP test mission today twice. The first time it performed flawlessly except for the last 6 feet of the landing were very fast. The second test run again performed flawlessly except for the last 6 feet, where it was like the motors were cut off at 6 feet high. Broke one landing gear leg.  Two props were stuck in the mud and I panicked to shut the quad down - first switched to loiter and then to Stab where I was able to disarm the motors. Can someone look at my logs to tell me why it cut off the motors from 6 feet?

    One other issue that I noticed is my barometer and sonar start out close together but they diverge with time. Is this normal? See the second log file.  Could this be why my quad dropped 6 feet?

    And by the way, looking at a recent post, I had to lower my Stab P to 3.2. The quad is far too twitchy at 4.5.  4.5 worked well for me in 2.9

    I have an APM 2.5, 3DR quad frame, 880KV motors and no anti-vib foam.

    2013-02-10 13-01 1 FY 2_9_1 Stab P 3_2 stab loiter alt hold good.log

    2013-02-10 14-25 4 HO 3 WP mission test 6 ft drop at end.log

  • I've done some balancing and added extra dampers for the APM. Do these z-axis values look ok, or are they still a bit spikey?


    This was indoors on a hex 900mm Vulcan UAV 12x4.5 props. It was a big hall :) Rock steady in stab mode.



  • I am using the new 3DR MTK GPS V2 on two of my quads. It is unclear from what I have been reading whether or not these should also be upgraded to the newer GPS firmware. Anyone know what firmware is on them from 3DR and whether I could expect an improvement if I went to 1.9? 

  • Hi Randy

    I am running 2.9 and as I have pointed out and put a video earlier landing was perfect but because of several crashes

    Hexacopter lost arms and I ordered new from DIYDRONES with Motors and Props. After that last crash I noticed that arm

    we replaced was longer than the original. I have removed the arm and cut it to size and also cut all I have got from diydrones. I don't know why they sent wrong size. My hexa is stable and no problem in usual flying except now it is bouncy and I have to switch to stabilize mode and put throttle to minimum to land it.


    In Auto mode I am having a strange problem and this I noticed 10 days back. when I mark waypoints in mission planner

    it goes in different direction. Same thing I experienced 2 days back and just to make sure there is no problem in marking, this time I marked home where the copter was and after putting copter in the car with power on to the copter I went 500 Meters away and marketed the waypoint and come back close to the home point and used it as land. In flight  it went away approx. 180 degree away and it is happening all the time. I am using Ublox gps.

    I have checked tlogs and it shows that it was going along waypoints lines but it was not.

    If you see the logs, at 49.7% first auto flight is logged but way points are not shown here. copter should have gone towards red line (front) but I flew towards the yellow.

    Same day at 66.5% of the log, same waypoints and again it went in the same wrong direction. I flown it in stabilize in the exact direction of waypoint 2 at 89.2%


    waypoints are not in the logs as I deleted them so that I marked new one but I did not marked them again.

    kindly suggest what would be the problem.






    2013-02-07 15-30-42.tlog

  • Hi,

    I have the 2.9.1 and tested yesterday the Loiter and AltHold. Both works very good. Today I tested with the same setting without changing any PID setting, but it was very bad. The Loiter was a catastrophe and the AltHold too. In the attachment you can see 3 Logs. Two of them are the Logs where Loiter and ALTHold works very good. And the last is the Log where Loiter and ALTHold not working. What is the diffrence betwenn them ? Only thing that  I noticed was the weather.

    2013-02-07 20-50 28 works well Loiter,ALTHOLD.log

    2013-02-07 20-53 29 works well Loiter,ALTHOLD.log

    2013-02-10 14-55 3 works not!!.log

  • Well as promised I completed another mornings testing on 2.9.1 focusing on RTL and Auto Mission.   To summarize, with good setup (careful attention to frame vibrations / interference):

    Stabilize Mode:  Excellent.  Lots of fun flying in this mode

    Loiter:  Well we all know its no so good (watch this space for 2.9.2)

    ALt_Hold  Seamless Transition and hold is near perfect.

    Today I focused on Auto and RTL.  As it turned out I needed to switch into RTL after aborting two Auto missions which went horribly wrong. So my RTL testing was to save my quad.  I the first incident RTL started to work as expected.  My quad rose in altitude to the level I set, turned and started to head back to my take off location,  However the quad seemed to be still slowly gaining altitude and then stopped well short of my start / home location.  I checked and I had good GPS locks and 11 sats during this phase of testing.

    The auto mission I setup was very simple, just two way points and back home.  Of course this was my first time using the Mission planner to plot the Auot mission. So some operator error could have been at play.  The one disturbing thing entering AUTO, is my quad raced towards the first waypoint at an alarming rate.  I did not Change any default parameters by the way. I only set the waypoint altitude as this defaulted to 100m.  Anyway at the speed the quad was going it well overshot the first way point and was too far away to check orientation so I engaged RTL to try an recover.

    My second attempt at Auto was again a simple plan.  Two waypoints and I had the quad wait 20-30 seconds this time before moving on to the first way point.  I adjusted the waypoint radius to 10 metres for this test hoping to stop the quad going too far past the target .  Unfortunately I was unable to save my quad this time.  When my copter sped off to the first way point, it was too far away when I engaged RTL.  Again RTL behaved as expected at first and then seemed to be stuck after moving only a few metres towards home base.  I did engage Loiter and ALT Hold modes to buy more time while I tried to get RTL to work or bring the quad close enough to visually fly it home.   Then I made a classic helicopter mistake and did not realize my quad was facing towards me and while trying to manually fly it back as a small black speck in the distance dropped the throttle too low as well and pow.  Big impact.  Here is the result Not a pretty sight.


    I see someone else discussing APM features earlier and I have to agree having a reliable RTL is more important than the fancy auto features for the moment.  I blame myself because I assumed RTL would work so if my Auto mission got into trouble at least with my quad being so stable I could recover.  So I failed to properly test RTL before engaging the Auto mission. This is lesson learned.

    I have viewed my logs and do not understand why my quad moved so quickly to the first waypoint unless the default rate is currently set too high.  I noticed the Altitude value defaulting  to 100M so perhaps the current speed to waypoint is also excessively highl? The other main issue was the quad flew well beyond the first waypoint before trying to move to the next. I tried RTL at this point with no success.

    As I mentioned I viewed the logs and compared them to the mission plan I set.  I biggest issue I have is the Long and Lat  values in the mission planner seem to be off quite a bit as if there is scaling problem.  If you look at my waypoint data and also the Google view you will see a large Dam nearby.  I set my waypoints only a short distance for the test yet my quad flew very quick to the area almost on the dam.  This is why I has so much trouble recovering. Also when I converted the TLOG to look at the traces in google earth the tracks do not match what actually happened at the field.  For example it showed the quad near the home base and yet it was hundreds of yards away.  I wonder if the GPS accuracy is shot after I upgraded it to v 1.9?

     Hopefully I can ask those more seasoned with Mission planning and Auto mode to perhaps compare my tlog to the valued I set in the mission planner.   Why RTL is not working is also a mystery.  I has solid lock on sats all the time and before I took off.

    Weather conditions were very good.  A very slight breeze but no gusty wind conditions.

    Here are my logs and Mission plan. Note the mission starts ~  5mins in.


    2013-02-10 10-52-48.tlog

This reply was deleted.