Developer

ArduCopter-3.0.1 released!

ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

3691038784?profile=original

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • After, I had change Motors from T-Motor MT4008 600kv to MN 3110-26 470 kv is very stable and temp max about 43 C only. And I still flight with 3.1-rc5  is no have Problem it.

     

  • Hello!

    Yesterday I'm flying with the v.3.1RC4 on my quad. Stabilize works well, but Alt-Hold and any other "automatic mode" like Loiter or RTL is problematic. The main problem is rather strange motor behavior. 

    I had the same problem wrote in: http://diydrones.com/forum/topics/apm-2-6-3-1-rc2-octocopter-alt-ho...

    Also, my GPS3D fix lost and recover continuously... but I was in a elevated point where the GPS have 11 satellites! 

    Anybody knows how to fix this problems?

  • HI Developers of MP --- Where would I place feature issues?

    *** Sorry about a missing problem 3 above. I posted then deleted because it sort of worked and I thought I'd not address it at this time.

    Here is a screen capture which shows crowded HUD text on the MP 1.2.85 and a new field with no indication of use?

    Below also see a long standing issue I had posted with no resolution regarding the updating and viewing of Telemetry.

    3692870037?profile=original

    Thanks for your diligent work!

    Brian.

    MP_Output-HUD.jpg

  • Features?

    Voice Battery Voltage announcement when connected to USB.

    Is it possible to have MP planner automatigically toggle between disabling Battery Voltage announcements when on USB working when no USB connection but, a battery is connected for flight?

  • With latest MP 1.2.85    1.1.5409.36165


    Three (2) Issues/Problems -

    1) Mission Planner Map Error message on start.   Update MP 1.2.85   build 1.1.5049.36165

    Description (Repeating):
    Start up error message is: "Map change failed. try zomming out first." The error instructs to: "try zomming out first." --- I zoomed out. This did not self correct the problem and this error repeats on each MP initiation. Also, the map will not zoom to last zoom level as previously but now zooms out - to N.A. in my case.

    This upgrade has already crashed once with error - Windows 8.


    2) No Heatbeat detected. After MP upgrade the APM USB connection fails. (Repeatable but will connect once in a great while Sporadic).

    Description:
    Mission Planner 1.2.85 1.1.5049.36165 did have one successful connection after the initial automated upgrade but, on subsequent connection attempts the MP fails out indicting no heart beat detected. Note: While writing this report after several minutes of APM connection to USB and no connection to MP I tried again and the connection worked. I had tried several times prior and rebooting the MP with no success. After connection and HUD functioned I disconnected the USB and tried to re-initiate connection between the APM and MP with no success again.

    Repeatability:
    The MP initiates connections by reseting the APM and then times out with the error message that it can not get a heartbeat. Upon which the MP stops connecting to the APM. The APM restarts and comes to a normal stable LED condition of GPS lock, Blue LED solid, and the Arm/Disarm (external in my case) Red LED blinking. The Tx is bound to the Rx on the APM and connects. I am able to Arm and Disarm the APM from the Tx. Note: I can not flight test - My copter is apart.

    ****   Question: How do I downgrade to MP 1.2.84?


    Thanks.

  • Moderator

    Has anyone been flying this new firmware on a Pixhawk unit? C'mon release them already!

     

  • Man this is getting deep and frustrating to find my own posts! And the lack of a topic search is, well, why?  Can we branch off into and RC5/v3.1 version of this?  Just curious. 

  • I've noticed my compass heading when connected via the USB cable is about 10-15degs different from when I'm powering the APM from a flight pack and connecting via telemetry.  Is this normal?

  • Well I just ordered a new 3DR APM 2.6. Hopefully this will work for me.  Oh - also pulled the trigger on an Iris!

  • Is the new MP release buggy for anyone else?

    I just opened up MP, it asked me if I wanted to update, I clicked yes, it updated (1.2.85), then problems started. It says "Map change failed. try zomming out first." every time I startup now. Connecing to my APM fails now. Most of the time when I hit connect, the LEDs on my APM go out, connection fails, and after I close the timeout dialog the LEDs turn back on. I can still get it to connect by letting connection fail first, then hitting connect again as soon as my APM lights start to flash again. It consistently connects to the terminal (CLI) still, but the GPS test seems to crash.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @DanielChiaJH: @a1k0n @diyrobocars @circuitlaunch And here's the final showdown! Video courtesy of @chr1sa I think I was a little faste…
7 hours ago
DIY Robocars via Twitter
RT @DanielChiaJH: @a1k0n @armand_dpl @SmallpixelCar @diyrobocars @circuitlaunch I use @foxglovedev Foxglove Studio for my visualization nee…
7 hours ago
DIY Robocars via Twitter
7 hours ago
DIY Robocars via Twitter
RT @a1k0n: @DanielChiaJH @diyrobocars @circuitlaunch Here's my car's view of that race. About 8.4 second lap times for laps 2 and 3... both…
Monday
DIY Robocars via Twitter
RT @DanielChiaJH: Great racing against @a1k0n today at @diyrobocars! Pretty cool to both break sun-9s at the track today I think I got very…
Sunday
DIY Robocars via Twitter
Broadcasting the @circuitlaunch race live now at https://m.twitch.tv/diyrobocars Races begin around 2:00pm PT
Saturday
DIY Robocars via Twitter
RT @a1k0n: ran a huge number of hyperparameter tuning experiments yesterday; now I can train a new policy, far with better quality, in 15 m…
Saturday
DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Sep 26
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
More…