Developer

ArduCopter-3.1 released!

After months of testing AC3.1 is finally available in the Mission Planner and GitHub.

Warning #1: If the vehicle is left landed (but armed) while in AltHold or Loiter mode for more than a few seconds, the vehicle may suddenly jump into the air the moment the pilot raises the throttle above zero.  The reason is the baro altitude may fall while the vehicle is sitting on the ground.  In AC3.2 this bug is fixed because we reset the target before take-off.

Warning #2: Motors will spin (slowly) by default as soon as the copter is armed!  You can switch this feature off by setting the MOT_SPIN_ARMED parameter to zero.

Warning #3: if you see "Bad Gyro" on the HUD then you may have a blown 3.3V regulator.  See this thread for details.

Warning #4: if you use a sonar set the SONAR_GAIN parameter to 0.8 or lower

Warning #5: Trad Heli users should now connect their main rotor ESC to APM's RC8 output

Warning #6: Trad Heli BUG causes loss of collective control in ACRO mode if swash type set to flybarred (i.e. not flybarless).  Will be fixed in AC3.2.

 

The major improvements over AC3.0.1 are (full list here):

1. Pixhawk support (Tridge & PX4 development team)

2. Autotune of Roll and Pitch gains (Leonard/Randy)

3. Drift mode (Jason)

4. Improved Acro (Rob/Leonard) and new Sport mode (Leonard)

5. Arming, Take-off, Land in Loiter or AltHold

6. TradHeli improvements (Rob) including:

a) support for direct drive tail rotors

b) smoother ramp-up of main rotor

c) reduced collective for better control in stabilize mode (STAB_COL_MIN, STAB_COL_MAX params)

7. Support for SingleCopter (Bill King)

8. Performance improvements resolve AltHold troubles for Hexa & Octacopters

9. Safety Improvements:

a) GPS Glitch detection (Randy)

b) Motors spin when armed (Jonathan Challinger)

c) crash detector shuts off motors if copter flipped for 2secs

d) batt failsafe option to RTL instead of LAND, gps failsafe option to trigger AltHold instead of Land

e) more pre-arm checks of inertial nav speed,

10. Bug fixes:

a) optical flow working again (although performance is still not great because not integrated with inertial navigation)

b) ROI working (use DO_SET_ROI command)

 

How to upgrade:
Click on the MissionPlanner's Initial Setup >> Install Firmware screen.  The version numbers should appear as "ArduCopter-3.1", then click the appropriate frame icon and it should upgrade as per usual.

Special thanks to Marco and the many beta testers on the AC3.0.1 thread who put their copters at risk during the testing of this new version and uncovered many problems so that you don't have to!  Here are some of their videos: loiter in wind, patio sonar, autotune, autotune2, roi, beach, acro, vrbrain, tricopter, train spotting, radio failsafe, the tree, double loiter

 

If you haven't seen it recently, please check out the ArduCopter wiki.

 

Feel free to post comments below and we're going to use the new APM Forum for support issues so please post your support requests there.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

            • Developer

              Clive, I'm really not sure.  Maybe Craig or Jonathan Challinger in the APM Support forums can help.  I think the cause is likely written on the console if you can connect with the arduino ide's serial monitor at 115200 baud.

  • Thanks Rainer, i'll give it a go next time i fly

  • hello all, i feel a little dumb asking this but this was the first time i tried it. How does one launch in Alt Hold or Loiter? when i attempted it with two Aircraft, my props jumped to life when throttle was at 50%, is this normal? my MOT_SPIN_ARMED is set to 0 because i have LED indicators for the Armed Status. thanks in advance

    • I think it's still a problem even in 3.1.2

      And it seems intermittent. Often launching in Loiter for instance, when you start slowly moving the throttle up, all of a sudden, it JUMPS into the sky, reaches about 1.5 to 2 meters and then lands. I can't stop it from jumping or landing afterwards. Also trying to disarm while still in Loiter yaws the aircraft on the ground.

      Other times, often a second attempt after the initial bad one, and it works just fine.

      It still sort of pops up fairly quickly, but not like the previous JUMP, and control is maintained without it trying to land right away. You can fly a whole flight in loiter and land, after which time it properly disarms.

      Go figure.

      It was an acknowledged bug a few revs ago, and they were going to fix it......

      So your not crazy!!

      • thanks David,

        I would think start up would have been more like stabilize, allowing you to ease into the take off then stopping at a certain altitude when you reach the 50-60% throttle. NAZA does that if i remember correctly, not sure why APM/Pixhawk wouldnt do similar. 

        guess i will stick to Launching in Stabilize then switch to Loiter/Alt. Hold. seems silly to have to do that but then what the heck do i know :P

        • When it works, it works well. It makes a clean crisp take off, and stabalizes to "whatever altitude" as you center the stick.

          The "crisp" take-off is intentional I understand, to make a clean break from ground effect, where the UAV is less stable.

          Of course when it isn't working right, the JUMP into the air is excessive.

          For me it seems that whether it is a good takeoff or a bad one, is random. Sometimes it works, sometimes it doesn't.

          I haven't tried an auto-take off. The Loiter take off was uncomfortable enough.

          • This weeknd I tested more extensively in 3.1.2 and it seems to be working fine now.

  • Hi,

    So i decided to try Auto Mode on 3.1.2. But upon auto take off the copter  yaw 90 degrees from the waypoint heading but still continued to head towards the waypoint. When i noticed that this was weird i immediately came out of auto mode but then the copter did some bizarre movements and flipped up side down and then crashed. I have posted the log file of the crash. Any idea what went wrong? Log file is directly from Pixhawk Memory card.

    Regards

    Chandruth

    31.BIN

  • Has anyone tried Circle Mode with AC3.1.2?  I was out flying today and did several waypoints. Everything worked just fine except that my copter will not enter Circle Mode...circle_radius 20, circle_rate 30. Instead of doing circle, it simply loiter.

    Here's the summary of the simple mission plan:

    Takeoff       30m

    waypoint#1  50m

    waypoint#2   50m

    waypoint#3   50m

    loiter_circle   50m

    waypoint#4    50m

    waypoint#5     20m

    when the copter reaches waypoint#3, it simply loiter and never finishes the mission.

    Can someone please tell me, what am i doing wrong?  Many thanks.

    • @Willy, 

      I think something is wrong with the setting up of Loiter_Circle, something looks wrong there. Have you mentioned the number of circles to take, and the radius of the circle. I believe it is going to the infinite mode and it stucks there.

      Others can confirm. If you try setting simple waypoint, it would work Ok.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
More…