Developer

ArduCopter-3.2 beta testing

Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

      • Rainer das ist Thüringen :-)

  • Can anyone tell me why my heli isn't landing?  I have a simple flight plan with Takeoff, a couple of splines and an RTL. The winds were gusting up to about 25kt and this was the first flight on 3.2rc12.  I did the flight plan twice.

    The first time it loitered at home for about a minute (should be 4 sec) before landing.  The second time it loitered until I had to take the aircraft for batteries.   I tried again later with the same results even in RTL mode.

    When I looked at the NTUN. DPosX/Y are not recorded at line numbers 46K and 70k from reaching home to shutdown.  CTUN DAlt has a steady alt. 

    Any clues?

    5.BIN

    https://storage.ning.com/topology/rest/1.0/file/get/3701852558?profile=original
    • I've seen an issue wherein if you set the WP radius to 1 (I am working in units of feet and feet per second), save a flight plan, and then reload it, the MP resets it to zero when I reload it. If I try to fly the flight plan without checking that the WP radius is not zero it will not properly execute the flight plan (it takes off but does not move), or when I try to RTL it will not land. If I remember to set the WP radius to 1 it works perfectly. For what it's worth, my experience...
      • Thanks.  I've seen this problem too.  I think it's a rounding problem.  This issue usually shows itself on takeoff, though.  It'll take off and climb to altitude and them stay there, unable to reach the impossibly small target, indefinitely. 

        It happened to me again, today; once out of the two flight plans I did.  Can it be because of high winds? That when it shows.

         

    • Hello

      The problem I had.
      I deleted the SD card, and OK with RTL

      • Yeah, it seems to be working fine now.

      • Thanks, I'll try it.

  • Developer

    Sorry, I haven't been answering too many reports or support questions in the past 3 days but I'll be back reviewing the build-up from tomorrow.

    • Please can you have look at my Question

    • no problem Randy, take your time.
This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…