ArduCopter-3.2 beta testing

Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi - I started to use APM2.6 a few months ago and now

    would like to do some compiling of source code.

    I downloaded ArduCopter V3.2-rc4 and used the procedures outlined in

    to compile it.  All looked good except when it came to downloading to

    the APM2.6.  I got the following message:

    avrdude: Version 6.0.1, compiled on Oct 17 2013 at 21:37:20
             Copyright (c) 2000-2005 Brian Dean,
             Copyright (c) 2007-2009 Joerg Wunsch

             System wide configuration file is "C:\ArduPilot-Arduino-1.0.3-windows\hardware/tools/avr/etc/avrdude.conf"
    avrdude: error at C:\ArduPilot-Arduino-1.0.3-windows\hardware/tools/avr/etc/avrdude.conf:332: programmer type must be written as "id_type"

    What should be done to get rid of the error ?

    Thank you for your time.


    • Check this thread,

      Make sure that you have the latest MHV AVR Tools and copy the

      C:\Program Files (x86)\MHV AVR Tools\bin\avrdude.conf 



      Then it should work.

      • Hello - I thought that everything worked fine after I following your suggestions but

        there are a few more glitches.

        The ArduCopter V3.2-rc4 source code compiled successfully using

        ArduPilot-Arduino-1.0.3-windows-gcc482 and  it could also be uploaded to the

        APM2.6 (using the ArduPilot-Arduino-1.0.3-windows-gcc482); however, towards the end of the upload,

        a message came up that said "verify failed: exp 6F got 8 at 245760"

        I then opened ArduPilot Mission Planner and tried to connect Mission Planner to the APM2.6 board;

        MAVLink could not establish a connection despite having the correct COM port and baud rate settings.

        MAVLink has no problem establishing a connection to the APM2.6 when a pre-compiled version

        of ArduCopter (available on the ArduPilot Mission Planner) is used.

        Is the MAVLink problem related to the verify error problem ?

        Thank you for you time.


        • your sketch size must be < 242kB. Try to disable unused features in apm_config.h

          • Hello - Thank you for your help.  I reduced the compiled code size to less

            than 242KB and everything worked fine.

            Now I will start to look at the code itself and try to find out what it is doing.

            Thank you.


      • Hello - Thank you very much.  I followed your suggestions and it worked.

        Best Regards,


  • Randy and Julien here is another log with plenty of ERR16-2.

    more on the setup/ particalar flight:

    foldable tricopter with 16mm CF tubes

    flight controller: APM 2.6 by 3DR with 3dr gps/mag running 3.2-rc4

    motors/ESC/prop/batt   4108-380kv/30amp 6s/15x5.5 DJI style props/ 4s 4000mah (this particular flight) 

    pre-story:  trying out a new vibration dampening foam, vibes are well within the acceptable ranges especially on the Z axis. wiped eeprom with arduino IDE example sketch, loaded AC3.2-rc4, did calibrations, bumped baroglitch and ekf check to the advised values, set up flight modes, setup failsafes, plugged battery in, tested in front of my garage with awesome results in alt hold and loiter. downloaded logs, changed yaw slew to 3000, flew again with again good experience. Decided to run a quick autotune, got a fresh battery, drove to a nearby park, plugged the batt, got gps lock, took off in stab, switched to alt hold, this is where the problems started. Upon releasing the sticks all in their middle positions, tri started yawing in the clockwise direction gentle stick input seemed to correct the position and it seemed to remain in that position, took the copter in the middle of the field. Almost flipped autotune switch when copter started yawing uncontrollably and my corrections were not really helping, since it would overshoot greatly, at this point it was about 30m away from me, so i couldn't even get the copter to point its tail in my direction, so I decided to land it (with a little flip on the ground w/o damage).  came to the copter, fixed tilted motor, unfolded one arm and decided to run some more test. armed, tried putting it in loiter, as soon as I put it loiter copter would shoot in a random direction tried this several times. no gps glitches recorded with 9sats and hdop 1.6.  

    log of the flight is attached:

    2014-08-05 21-18-15.log

  • T3

    Hi all,

    not sure if this is related to 3.2rc, Mission Planner or both. I made a compass calibration and MP reported the offsets. For example 2 -6 and 3 for the second compass. However, in the parameter list these values transfer to 12 -140 and -31 for the second compass. Is this ok?

    In the wiki it is stated that "For the PX4  and Pixhawk it is OK if the values are greater 150 or ...". A Log Analysis tells me: "Test: Compass = FAIL - Large compass off params..." (Z = 187, and the Compassmot interference is 0%). Should I ignore the "FAIL"?

    Thanks and kind regards,


    • T3

      Update: concerning the differences in the compass offsets it seems that the vales are just not directly updated in the full param list but are stored on the Pixhawk correctly. After refreshing the list everything is fine.

  • Had a strange issue today. Flying 3.2-rc4 since a few days. Did a successful autotune yesterday and so far very happy with position mode stability etc. But today I did a flight around the local field and a few minutes into the flight the copter would stop in mid-air and didn't react to the transmitter anymore. I tried to invoke rtl, but it just sat there and didn't react. When switching back from rtl to stable mode I could regain control and landed.

    After analyzing the dataflash log (as far as I'm capable of this) I saw an error 16-2 and 16-0 and failsafe_fence1 and failsafe_fence0.

    At the moment when this happened the copter was only about 50m away from me and maybe 30,40 m high and the fence is set to 100m altitude and 500m distance so I'm really wondering what happened.

    Dataflash log attached...

    The copter is a foldable h-quad with inversed motor direction in comparison to a normal quad.

    2014-08-05 18-40-36.log

This reply was deleted.


David Hori liked Isabella Domi's profile
Jan 12