ArduCopter-3.2 beta testing

Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


          • Developer


            Does it make any sounds?  If the red light is coming on then it's not completely dead.

            Maybe try holding down the safety switch while it boots?

            Failing all that I think a log file is created on the sd card if there's a low level failure (i.e. a failure before arducopter even starts).  I've had a look on my sd card and I don't immediately see it but I think it's called something like "bootlog.txt".  There's a LOGS directory but that's the dataflash logs.  There's also a new TERRAIN directory but that just hold terrain info (not yet used).  Anyway, the SD card's contents are probably small enough that you could put the contents in dropbox and post a link and I'll have a look.

            • Thanks Randy for the advice. No sounds from the Pixhawk other than the 3 short little do-re-mi beeps, but I suppose that could be coming from something else, it's hard to tell. But I don't get the startup failed sound or the usual startup ok sound. The safety switch also is flashing quickly. Holding it down after it's powered up does nothing. 

              Alternatively, if I hold down the safety switch while it's powering up, i still get a solid red light, but safety switch then does not light up. The B/E light flashes quickly and the ACT light is out. Otherwise if I just power it up normally, the B/E light is steady on and the ACT light blinks steady.

              But I can't get around the solid red main light. 

              Here's a link to the content of my SD card (I deleted a bunch of older flight logs to make the file smaller). I couldn't find any bootlog files like you mentioned unless they're hidden. 


              Let me know what you think. Thanks again!

              Pixhawk Card
              Shared with Dropbox
  • I can't seem to make my throttle failsafe to work in RC10, It worked just fine before (I'm using a x8r connected via S-bus)

    My Throttle goes to 950µs when I turn my taranis off and it's at 988µs when it's on, already tried FS PWM at 970 and 975, also increased the min throttle when ON to 1000µs.

    When I turned my transmiter off before I got a FAILSAFE message even if my quad wasn't armed, now if I turn it off I get a "DISARMED - FAILSAFE" alert.

    Also, do you recommend to fly with compass learning off or on?

    • Esteban, my Taranis has a low throttle of around 1100uS, your 988uS seems a bit out for -100% throw with no trim or offset (which you would have avoided).

      BTW, have you done or checked the stick calibration on your Taranis since you bought it ?

      • 1100us is too high, most likelly you never did your Taranis stick calibration, or did it a wrong way.  My taranis all stick channels are 982-2006. also, I disabled the ratchet on the throttle stick, this way I have a much finer throttle control. I can hover in Stab without constantly adjusting throttle, well maybe 1-2 times a minute. 

      • Have you checked your settings?

        I only ask as my throttle also has a range of 988 - 2012 (when switched on) and that's the out the box default setting.

        • Mine is the same. Comproved with oscilloscope.
          Throttle failsafe is working.
          First do the radio calibration with stock settings. Second make the throttle channel go bellow 988 by extending the range on the taranis. Press the f/s button on the receiver so it saves failsafe values. Don't forget that the receiver sets the failsafe value for all channels when you press the button so make sure the other channels are were you want them. After that remove the extended throttle on the receiver.
          You should see the failsafe kick in when you turn the receiver off. You can see it working on MP failsafe tab, for e.g.

          After that don't forget to set on MP the failsafe value. Look at the link Randy posted.
    • I don't know if this is relevant to your situation but I noticed with 3.2 copter rc10 when I turn my TX off there is no indication [ in the ground control station ] if FS is set up and working right. In apm_plane even just sitting on the bench it says 'circle' then after 30 seconds 'RTL' just as it should when the TX is shut off. In copter it does not indicate a mode change on the bench. I realized however it is set and works correctly if I turn my TX off while it's flying. I think the fact it knows it's not flying might be why there is no indication it's going into FS on the bench. I carefully tried FS while only up 2-3 feet and confirmed it is in fact working perfectly. I do not however get that message you indicated so as I said.... the above might not be relevant. 

    • Developer


      Did you follow the instructions on the Throttle failsafe wiki page to test the failsafe?  They are quite detailed.

      compass-learning should definitely be off (the default value).

      • Randy I often fly in different locations, inside and outside the city, should I redo compass calibration or something if I leave compass-learning off when I fly in a different environment?

        Also, a bit off-topic but I've been struggling a long time ago to get rid of YAW Oscillations in both my F450 and my TBS Discovery now, according to the wiki the max for stb_yaw_p is 6, rate_yaw_p max is 0.50 and rate_yaw_i is 0.050. What does those limits mean? Any number above that isn't going to make a difference?

        There's a guy here in DIYDrones using 9 for stab yaw p and 0.8 for the rate yaw p and he notices a difference, could it just be him?

        Thanks Randy for answering our questions, you really help a lot!

This reply was deleted.


Gremsy liked Gremsy's profile
Mar 12
DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27, 2022
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24, 2022
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer
Nov 24, 2022
DIY Robocars via Twitter
UC Berkeley's DIY robocar program
Nov 24, 2022
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24, 2022
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup
Nov 20, 2022
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video.…
Nov 20, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs
Nov 8, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video.
Nov 8, 2022
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23, 2022
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23, 2022
DIY Robocars via Twitter
Oct 23, 2022
DIY Robocars via Twitter
Oct 19, 2022
DIY Robocars via Twitter
Oct 18, 2022
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13, 2022