Arducopter Fly-aways: A PSA

I have seen recently a lot of threads about sudden fly-aways occurring on previously rock solid platforms, and I feel it necessary to share my experience. I have an SK-450 quad with Ardupilot 2.5+ that has over 100 flight hours on it currently, and a few weeks ago, I had a fly-away. I throttled up, and instantly had absolutely zero control. It just lazily hovered and drifted into a tree, luckily, where it refused to respond. The motors refused to stop spinning until I unplugged the main battery. I replaced the props, checked every wire, checked every setting, re-flashed the firmware, re-calibrated, and set out the next morning, with the same result. 

I began tearing the quad apart the next day, trying to replicate the results without props, and much to my delight and annoyance, I found the problem. The 900MHz 3DR telemetry cable I was using was fine, but when the motors began to spin up, the slight high frequency vibration from the motors very momentarily disconnected one of the pins hooking into the radio, which caused the APM to reset immediately, leaving the output pins locked with whatever output they had at the time of reset. To make matters worse, the APM will not re-initialize until the power is reset. I was able to replicate this by just slightly tapping on the header, and every time, the APM lit up in orange and the RX/TX LED's both stayed solid on. Of course, the problem was solved by soldering the wiring harness to the air module, but needless to say, I ALWAYS add a little bump of throttle after initializing and arming on every flight, just so that the throttle is low in the event it happens again.

If anyone has any ideas as to what causes this reset, I would be most interested in hearing it. I would love to be able to add some protection in if possible, as I demonstrate this quadcopter for representatives from the Airforce, generals from the Army, and executives from Boeing, Northrop, Bosh Global Services, and several other companies. Having a quadcopter uncontrollably drifting through a window or onto a runway would not exactly be the best way to demonstrate Ardupilot :) Also, if anyone has any experience they want to add, or any other cause they've found, please add it!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Admin

    @Austin,

    I have been operating a number of rover chassis that have employed APM2.5/.6s and accompany 3DR telemetry radios and I have yet to experience a telemetry radio causing the issue that you have described.

    I have had my rover chassis get flipped over by curbs and hit by a rover on the side the telemetry radio was on and have never lost the telemetry connection nor had the APM reset.

    I have had APM resets due to an instantaneous low battery caused by fast chassis motor accelerations when the battery was near its end of charge. Otherwise my APM2.5/.6s and telemetry radios have performed to expectations.

    Regards,

    TCIII ArduRover2 Developer

  • I have had similar issues from my own and a clients machine due to telemetry glitches.

    Client in the field, 3.01FW, APM2.5+, XBee/adaptor from 3DR. They phoned me when they were having trouble because they kept getting 'failed to set home' from Mission Planner and the copter would then disarm every time they tried to arm it. When I got them to bring the copter closer they were able to arm and started the mission, whereupon the copter went wild including a flip to upside down. The operator switched to stabilise and saved the craft. When I received the copter I found the telemetry cable had come adrift and was only touching the ends of the pins on the telemetry board. Secured them in place and she flew reliably again.

    I was testing 3.1beta's and was trying to use a couple of cheaper XBee's I had purchased by mistake. The telemetry was established, but proved to be very flaky. The copter was flying ok but on occasions would dive off in random directions. Replacing the XBee modules with ones purchased from JDrones (Pacific 3DR reseller) and all problems went away.

    I have been unable to open logs for the past couple of iterations of Mission Planner so I am unable to provide any here.

    So two different scenarios both involving telemetry causing APM to go askew.

    As you raised the subject I am just adding my experience to indicate it is not isolated.

  • Admin

    @Austin,

    Are the APM and the telemetry radios genuine 3DR products or are they clones?

    What version of the Arducopter firmware are you using?

    Do you have tlogs or dataflash logs available to help troubleshoot your issue?

    Regards,

    TCIII Admin

  • Developer

    Follow Mil Standard 810c it will reveal any weakness like this good luck!!

This reply was deleted.

Activity

DIY Drones via Twitter
RT @chr1sa: After more than a year of only virtual races, @DIYRobocars returns to the newly renovated @circuitlaunch on May 22 for the resu…
Sunday
DIY Robocars via Twitter
RT @DAVGtech: And now available with LiDAR 🔥 https://twitter.com/Heavy02011/status/1381137016381964293
Sunday
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #9 - #ParkingLotNerds #thunderhillracetrack, CA Join us for the next race April 24th,…
Sunday
DIY Robocars via Twitter
RT @DWalmroth: Weather's finally cooperating, looking forward to racing 1:10 scale autonomous cars outdoors again! @diyrobocars, @NVIDIAEm…
Apr 7
DIY Robocars via Twitter
RT @AIDRI_: I finally succeeded in optimizing the trajectory and speed of a car on a #racetrack. Next step: implement a 2d controller and…
Apr 7
DIY Robocars via Twitter
@jetdillo @circuitlaunch Actually the second *in person* event in a year. We do virtual races every month
Apr 2
DIY Robocars via Twitter
Update: we're moving it back one day to Sunday (the 4th) at 11:00am instead
Apr 2
DIY Robocars via Twitter
@GrantEMoe @circuitlaunch Update: we're doing it on Sunday (4th) at 11:00am instead
Apr 2
Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
DIY Robocars via Twitter
RT @chr1sa: Maybe we should have a mini @DIYRobocars race in our lower school's playground https://t.co/xLFeua1R6X
Mar 29
DIY Robocars via Twitter
If anybody wants to join us for an informal outdoors hack/race we're going to be meeting at the @CircuitLaunch park… https://twitter.com/i/web/status/1375907409223249923
Mar 27
DIY Robocars via Twitter
RT @SmallpixelCar: Ready to reopen, innovation has to continue. Inside/outside, LiDAR/GPS, race/delivery https://t.co/jpmvttoHEd
Mar 26
DIY Drones via Twitter
RT @DAVGtech: By far best race yet! Congratulations to the winner @Heavy02011 🥇🏆🍾👏👏👏 @diyrobocars @donkey_car @NVIDIAEmbedded https://t.co/…
Mar 20
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #8 - #ParkingLotNerds ⁦@DAVGtech⁩ ⁦@DWalmroth⁩ ⁦@OttawaAVGroup⁩ - join us tomorrow h…
Mar 20
DIY Drones via Twitter
RT @mrpollo: 11 years ago, the pxIMU was announced to the world on @DIYDrones, and it changed the life of many (mine included). The followi…
Mar 18
DIY Drones via Twitter
RT @ishcahealth: This is awesome! ☘️ @DroneDJ @DIYDrones @WorkerDrones @DroneMedia_UK @dublinaviation https://twitter.com/media_ireland/status/1372077878536462336
Mar 18
More…