Arducopter Fly-aways: A PSA

I have seen recently a lot of threads about sudden fly-aways occurring on previously rock solid platforms, and I feel it necessary to share my experience. I have an SK-450 quad with Ardupilot 2.5+ that has over 100 flight hours on it currently, and a few weeks ago, I had a fly-away. I throttled up, and instantly had absolutely zero control. It just lazily hovered and drifted into a tree, luckily, where it refused to respond. The motors refused to stop spinning until I unplugged the main battery. I replaced the props, checked every wire, checked every setting, re-flashed the firmware, re-calibrated, and set out the next morning, with the same result. 

I began tearing the quad apart the next day, trying to replicate the results without props, and much to my delight and annoyance, I found the problem. The 900MHz 3DR telemetry cable I was using was fine, but when the motors began to spin up, the slight high frequency vibration from the motors very momentarily disconnected one of the pins hooking into the radio, which caused the APM to reset immediately, leaving the output pins locked with whatever output they had at the time of reset. To make matters worse, the APM will not re-initialize until the power is reset. I was able to replicate this by just slightly tapping on the header, and every time, the APM lit up in orange and the RX/TX LED's both stayed solid on. Of course, the problem was solved by soldering the wiring harness to the air module, but needless to say, I ALWAYS add a little bump of throttle after initializing and arming on every flight, just so that the throttle is low in the event it happens again.

If anyone has any ideas as to what causes this reset, I would be most interested in hearing it. I would love to be able to add some protection in if possible, as I demonstrate this quadcopter for representatives from the Airforce, generals from the Army, and executives from Boeing, Northrop, Bosh Global Services, and several other companies. Having a quadcopter uncontrollably drifting through a window or onto a runway would not exactly be the best way to demonstrate Ardupilot :) Also, if anyone has any experience they want to add, or any other cause they've found, please add it!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Admin

    @Austin,

    I have been operating a number of rover chassis that have employed APM2.5/.6s and accompany 3DR telemetry radios and I have yet to experience a telemetry radio causing the issue that you have described.

    I have had my rover chassis get flipped over by curbs and hit by a rover on the side the telemetry radio was on and have never lost the telemetry connection nor had the APM reset.

    I have had APM resets due to an instantaneous low battery caused by fast chassis motor accelerations when the battery was near its end of charge. Otherwise my APM2.5/.6s and telemetry radios have performed to expectations.

    Regards,

    TCIII ArduRover2 Developer

  • I have had similar issues from my own and a clients machine due to telemetry glitches.

    Client in the field, 3.01FW, APM2.5+, XBee/adaptor from 3DR. They phoned me when they were having trouble because they kept getting 'failed to set home' from Mission Planner and the copter would then disarm every time they tried to arm it. When I got them to bring the copter closer they were able to arm and started the mission, whereupon the copter went wild including a flip to upside down. The operator switched to stabilise and saved the craft. When I received the copter I found the telemetry cable had come adrift and was only touching the ends of the pins on the telemetry board. Secured them in place and she flew reliably again.

    I was testing 3.1beta's and was trying to use a couple of cheaper XBee's I had purchased by mistake. The telemetry was established, but proved to be very flaky. The copter was flying ok but on occasions would dive off in random directions. Replacing the XBee modules with ones purchased from JDrones (Pacific 3DR reseller) and all problems went away.

    I have been unable to open logs for the past couple of iterations of Mission Planner so I am unable to provide any here.

    So two different scenarios both involving telemetry causing APM to go askew.

    As you raised the subject I am just adding my experience to indicate it is not isolated.

  • Admin

    @Austin,

    Are the APM and the telemetry radios genuine 3DR products or are they clones?

    What version of the Arducopter firmware are you using?

    Do you have tlogs or dataflash logs available to help troubleshoot your issue?

    Regards,

    TCIII Admin

  • Developer

    Follow Mil Standard 810c it will reveal any weakness like this good luck!!

This reply was deleted.

Activity

DIY Robocars via Twitter
Practice virtual race this Saturday; the real thing will be on Oct 3 https://www.meetup.com/DIYRobocars/
22 hours ago
DIY Robocars via Twitter
22 hours ago
Derrick Davies liked lisa TDrones's profile
23 hours ago
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @SahikaGenc: AWS DeepRacer & Hot Wheels Track https://youtu.be/4H0Ei07RdR4 via @YouTube
Sep 14
DIY Robocars via Twitter
Sep 8
DIY Robocars via Twitter
RT @davsca1: We are releasing the code of our Fisher Information Field, the first dedicated map for perception-aware planning that is >10x…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: How this works: 1)object detection to find cones in single camera image, 30 frames/sec on @NVIDIAEmbedded Xavier. 2)comp…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: Use two color cones to guide the robocar. No map needed, on onsite training needed. Just place the cones and it will fol…
Sep 7
DIY Robocars via Twitter
Sep 7
DIY Robocars via Twitter
RT @roboton_io: Great to see http://roboton.io running at 60fps on the cheapest #chromebook we could find! #edtech #robotics #educat…
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Crazy in-depth article about using the OpenMV Cam for Astrophotography: https://github.com/frank26080115/OpemMV-Astrophotography-Gear https://t.co/BPoK9QDEwS
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Hi folks, it's finally here! Our first draft of our Arduino Interface Library is out! It works over SoftwareSerial, Hardware…
Sep 3
DIY Robocars via Twitter
RT @chr1sa: Please let them have an open API. This would be perfect for @DIYRobocars races https://twitter.com/NintendoAmerica/status/1301513099707658246
Sep 3
DIY Robocars via Twitter
RT @SmallpixelCar: Lanenet pretty much used all my GPU power on @NVIDIAEmbedded Xavier since I optimized with tensorRT. I need to run anoth…
Sep 3
DIY Robocars via Twitter
RT @LyftLevel5: Our @kaggle competition on Motion Prediction for Autonomous Vehicles is now live! Experiment with the largest-ever self-dri…
Aug 24
More…