Ardupilot Crash - Help needed

Hi Guys,

We have been using Pixhawk in our fixed wings since a long time and have been quite successful with it so far. Today something strange happened:

We were tuning a new platform meant for aerial mapping. It was a bit windy day but manual take off went well and after trimming a the platform we switched to FBWA for finer tuning when suddenly the plane lost all the control and came down like a rock. It felt like it had no power and when it got inverted it could be recovered at all. We tried switching to manual mode but I dont think this was registered at all.

Following are the specs of the platforms:

3m span Glider

Hacker Motor

Castle Creations ESC

16000 mah 6S Tattu battery

Mauch Power Module

Hitech Servos

I am attaching the drive link below of the bin file and would be great if anyone could help us understand what went wrong. 

https://drive.google.com/file/d/0B-wBxBwIyRqVeTNfRUs0QnFfZHc/view?usp=sharing

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Developer

    @Pravin,

    looking at the log, the voltage of you main battery went from 24.7V down to 17.5V at one point. For a 6S battery that means you got to 2.9 volts per cell. That is a dead battery. Given you were only drawing a few amps and flew for only 6 minutes that means the battery was very sick. Quite possibly a cell in the battery has died.

    Your servo rail voltage was also very noisy. It got down to 3.9V at one point. The main 5V bus voltage is very noisy too, getting to 4.6V.

    The POWER_STATUS_CHANGED flag (32) in POWR.Flags also got set. That happens when one of your power sources drops below the minimum valid voltage. The log shows POWR.Flags fluctuating between 33 and 35. That means the servo power is sometimes dropping below 3.7V.

    So really you need to completely review the power setup. You had multiple problems with your power in the whole flight. It is highly likely that it lost power and reset the Pixhawk.

    Cheers, Tridge

    • Thanks a lot Tridge for pointing all the problems!
      The battery had taken quite a few flights but I checked before using and it was full charged and perfect. However this sounds understandable and lesson is, not to use batteries sitting on the table for a long time!

      My current power system is single 22.2V pack powering the whole system and pixhawk via a mauch power module and the servo rail via the ESC's internal BEC. Can you recommend something better than this?

      PS: I have taken a lot of flights in this set up without much problems and I'm starting to feel weather I was too lucky with all of them?

      -Pravin
      • Be sure that the voltage sensor is properly calibratied and working, its unusual to see a 6S be pulled below 6v, - let's say you need only 5v for voltage regulator to provide pixhawk with voltage above brown-out.

        cells providing 5v means a cell voltage of only 0.83v   - it's next to impossible to push them that low, in a short time, simply because the ESC/motor won't present an high enough load at such low voltage to further pull it down.

        I do agree that the power supply(/ies) was to blame.  But having analyzed plenty of plane logs where people flew the battery empty, it's much more typical to see useless/no thrust for several minutes before the voltage is anywhere low enough to make servos /flight controller stop working.

        • Developer

          @Andre, the 6S got down to 17.5V, which is 2.9V/cell. It was never pulled below 6V total.

          • yes, that's why I don't think the logging stopped midair due to bad battery , but rather another power problem.  Possible bad power module , and the servo rail power was too high/low for the power select IC to failover to.

            Just wanted to make that clear, so he was not under the impression of it all being caused by bad main battery,  - and did not try to fly same setup with new battery.

            • Developer

              quite possibly.

              If we have a tlog we could check if the SiK radio continued to be powered through the RADIO_STATUS packets. We may even see the reboot.

              @Pravin, do you have a tlog from the GCS of the flight?

              • Hi Tridge,

                Sorry! The radio was unfortunately disconnected due the USB wire coming loose. 

                Also there was some problem with the mission planner later and we had to reinstall it.

                -Pravin

      • Developer

        @Pravin,

        You'd need to check your previous logs to see if this was a problem just on this flight. It is possible for a servo to pull more power than usual, but if it pulled enough to drain a 16Ah 6S in 6 minutes then it would have melted.

        Using the built-in BEC in an ESC is often OK, but it is worth checking logs to make sure it is handling the load. In this case the POWR.VServo log shows it wasn't.

        Cheers, Tridge

        • Hey Tridge!

          I will certainly check the old logs too. In our case the ESC is connected to the servo rail via a long (about 3 feet) servo extensions and so is the power module. Do you think this could be the reason for noisy voltage? If yes what could be a way to send clear voltage to long distance (upto 3 feet)? 

          -Pravin

  • the log ends midair, most likely Pixhawk lost power.

    -use the 3-way power redundancy that pixhawk offers...

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ : A Home-brew computer club* for Connected Autonomous Driving. talk at #piandmore ⁦@PiAndMore⁩ on Jan 23rd h…
Saturday
DIY Robocars via Twitter
RT @a1k0n: New blog post! Deep dive into my ceiling light based localization algorithm which runs in 1ms on a Raspberry Pi 3: https://t.co/…
Saturday
DIY Robocars via Twitter
Great new guide to using @donkey_car https://custom-build-robots.com/donkey-car-e-book-en
Saturday
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars virtual AI race is tomorrow morn at 9:00am PT. You can watch live on Twitch https://www.meetup.com/DIYRobocars/events/275268196/
Friday
DIY Robocars via Twitter
New version of Intel OpenBot! This resolves many of the issues with the first version, including a much smoother tr… https://twitter.com/i/web/status/1352395636369313798
Thursday
DIY Robocars via Twitter
Jan 18
DIY Robocars via Twitter
Jan 15
DIY Robocars via Twitter
Jan 15
DIY Robocars via Twitter
RT @Heavy02011: @diyrobocars : A Home-brew computer club* for Connected Autonomous Driving on Jan 23rd, 2021 https://www.meetup.com/Connected-Autonomous-Driving/events/275728684/ #Meetu…
Jan 14
DIY Robocars via Twitter
Jan 14
David Hori liked Isabella Domi's profile
Jan 12
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ Autonomous Driving Assembly at #rC3. join us at https://rc3.world/rc3/assembly/diyrobocars-f1tenth/ ⁦@f1tenth⁩ ⁦@DAVGtech⁩ ⁦@DWalmroth⁩…
Jan 11
DIY Robocars via Twitter
RT @chr1sa: New car designs coming for our next @DIYRobocars @donkey_car virtual race on the 23rd. Choose any one you want at race time Le…
Jan 11
DIY Robocars via Twitter
RT @RoboticMasters: Thanks to @EllerbachMaxime and the Sydney Uni Capstone Students the @donkey_car @diyrobocars simulator is getting a ma…
Jan 11
DIY Robocars via Twitter
Jan 6
DIY Robocars via Twitter
Dec 28, 2020
More…