Ardupilot uploading problem

I'm working on a ATMega168 version of Ardupilot. I have added the airspeed sensor shield. As far as I can tell (from the leds and voltmeter readings) I have put it together properly. Today I downloaded Ardupilot software version 2.1.2. I did modify the constant definition "SHIELD_ENABLE to 1. Then I uploaded the code using Arduino-15. Because I have the shield I did not disconnect my EM406 GPS.The upload was unsuccessful and the Arduino IDE stopped responding. I tried again while observing the 3.3V and blue GPS leds on the shield. When the upload started, the leds went off as they should. However they almost immediately came on again, indicating that the GPS was powered up-not good during uploading.So then I disconnected the GPS and uploaded again. This time the 3.3V led went off and stayed off while the upload was in progress, as it should. The upload was successful.Then I tried the Arduino-16 IDE with similar results. The only difference was that the Arduino-16 response was a lot of red error messages when I tried uploading with the GPS connected. With the GPS disconnected, the upload was successful.Anyone else having a similar problem?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Admin
    Hi all,

    I think that I might have discovered why I, like many others, could not perform the I/O upload with the GPS connected.

    Since I had exhausted all of the usual electrical design issues without any success, I decided to tackle this issue from a S/W point of view. I had been using FTDI drivers that I had downloaded from the Parallax website over two years ago. Well alot can change in a few years especially with S/W. So I went back to the Parallax website and downloaded the latest FTDI drivers (2.04.16). After installation, I was able to I/O upload Ardupilot 2.2.3 with the GPS connected using the Adafruit FTDI cable.

    Therefore, I suggest that for everyone having the I/O upload problem with the GPS connected, try updating the FTDI drivers on your PC as it might resolve this issue for you.

  • There was a suggestion that bad solder joints could be the cause of some of these issues so I reapplied the soldering iron and a touch of solder to every male and female connector and checked the joint with a magnifying glass. Then the multimeter was used to check every connection between the shield and 328 board. I then reran all the tests you guys have gone through and still get the same errors – No upload with GPS attached and no read/write from Config utility (still waiting for my new FTDI cable to arrive).
    I like your “brute force” solution Fred. Sounds like you and Thomas have this thing figured out.
    Has anyone heard from Jordi on this issue?
  • As I understand it the shield only works with Ardupilots fitted with 328 processors and ver 2.2 software.

This reply was deleted.